pfSense Forum

pfSense English Support => IPv6 => Topic started by: NotAnAlias on February 09, 2018, 02:43:07 am

Title: Can't get IPV6 on LAN with two routers
Post by: NotAnAlias on February 09, 2018, 02:43:07 am
Hello, I have a setup with two routers.
The reason I have two routers is because the first router runs wireless, and is connected to a UPS. It is low power, so it will stay on much longer compared to a desktop with pfsense.

Comcast assigns a /60,
The first router runs LEDE. It assigns a /64 to connected devices, and all my computers can browse ipv6 sites fine. The WAN interface on LEDE is assigned a /60 as expected.
Settings for IPV6 on LAN for LEDE.
(https://i.imgur.com/pcthw9M.png)

Pfsense sucessfully gets an IP on the WAN interface, a /64. I can ping ipv6 addresses through the web interface.
However the LAN interface gets no ipv6 address.

WAN is set to DHCP6, LAN is is set to Track.
Computers connected to pfsense cannot get an ipv6 address.

I have disabled bogon blocking in the WAN interface tab but that did not help, any ideas?
Title: Re: Can't get IPV6 on LAN with two routers
Post by: JKnott on February 09, 2018, 07:54:55 am
Routers, such as pfSense, typically use DHCPv6-PD to get the prefix.  Your Wifi router is already doing that, as would pfSense, if it were connected directly to the WAN.  To get IPv6 on the LAN side of pfSense in your setup, you'd have to provide DHCPv6-PD from that router or manually configure routing, to pass a /64 prefix to the LAN side of pfSense.  Can your WiFi router handle that?
Title: Re: Can't get IPV6 on LAN with two routers
Post by: NotAnAlias on February 09, 2018, 10:37:00 pm
These are the main ipv6 settings I see configurable in the web interface,
(https://i.imgur.com/VaJ62gK.png)
(https://i.imgur.com/2JzJQFk.png)

I'm not familiar with ipv6, so I will read up. It is very likely possible on this router as it's just a fork of openwrt.
Title: Re: Can't get IPV6 on LAN with two routers
Post by: JKnott on February 10, 2018, 01:41:41 pm
I don't use OpenWRT, so I can't help you with it.