The pfSense Store

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Understudy

Pages: [1]
1
Installation and Upgrades / Re: edit config.xml
« on: December 19, 2012, 03:51:12 pm »
Okay, that worked.

Let me give some details for those who come behind.

I had physical access to my pfsense box. Despite enabling ssh I could not access the box with ssh.

From the main page on the pfsense box. option 8 is the command shell. So I entered 8
It goes to a command line.

I had to do a find / -name config.xml to find the file. Do not use the one in the defaults section.

I use ee not vi.
Code: [Select]
ee /cf/conf/config.xml  <--- Your location may vary
Go to the webgui section
Code: [Select]
<webgui>
           <protocol>https</protocol>
           <ssl-certref>50d1ed60453xx</ssl-certref>   
</webgui>

and add the following

Code: [Select]
<webgui>
           <protocol>https</protocol>
           <ssl-certref>50d1ed60453xx</ssl-certref> 
           <max_procs>16</max_procs>    <--add this
           <nodnsrebindcheck/>               <--add this
           <nohttpreferercheck/>             <--add this
</webgui>

Once you exit and save the changes you have to remove the tmp cache. At the command line type this;

Code: [Select]
rm /tmp/config.cache

Then if you go into your webpae of pfsense you should now stop getting the

Error: 501 Description: An HTTP_REFERER was detected other than what is defined in System -> Advanced (https://10.0.0.136/). You can disable this check if needed in System -> Advanced -> Admin

when you try to go to the pages. I still see it in the dashboard under the version box but it does not affect anything as far as trying to make changes to the configuration.

Thanks to marcello for his help on this matter.

Sincerely,

Brendhan

2
Installation and Upgrades / Re: edit config.xml
« on: December 19, 2012, 03:09:43 pm »
use viconfig(carefully) to edit config.xml

               <webgui>
                        <protocol>https</protocol>
                        <ssl-certref>XXXXXXXXXX</ssl-certref>
                        <port>XXXXX</port>
                        <max_procs>16</max_procs>
                        <nodnsrebindcheck/>
                        <nohttpreferercheck/>
                </webgui>


Thank you. I am trying it now.

Sincerely,

Brendhan

3
Installation and Upgrades / Re: edit config.xml
« on: December 19, 2012, 02:46:15 pm »
access your pfsense via ssh and forward gui port on it.

then access https://127.0.0.1:pfsense_port and make your changes.

for example:
ssh -L 443:127.0.0.1:443 root@pfsense_ip

or access it without names, just with ip address.

SSH is not working properly. Can help me with the config file?

Sincerely,

Brendhan

4
Installation and Upgrades / edit config.xml
« on: December 19, 2012, 01:01:48 pm »
Hi,

I have pfsense 2.0.1 install on it's own server. I am having the same issue as many others.

Error: 501 Description: An HTTP_REFERER was detected other than what is defined in System -> Advanced (https://10.0.0.136/). You can disable this check if needed in System -> Advanced -> Admin.

I access the box by going to 10.0.0.136 so I am not coming from the outside.

When I access the webconfig page and I try to save the checkmark in the Disable HTTP_REFERER enforcement check box. I can't save it because the webpage returns the same error.

I can also access the physical box itself.

I have put the config.xml file into edit mode and to properly place the nohttpreferercheck in the webgui section. However I want to ask exactly how that is to be done.

Here is the section in the config.xml file
Code: [Select]
<webgui>
           <protocol>https</protocol>
           <ssl-certref>50d1ed60453xx</ssl-certref>
</webgui>


So my question is how is nohttpreferercheck placed in that section what are the open and close tags for it if any?


Sincerely,

Brendhan
 


5
Installation and Upgrades / Re: Invalid VLAN tag ' '
« on: August 12, 2012, 02:22:03 pm »
It would not auto detect the wlan. So I gave it the em0 interface, since that connects to the DSL modem. It appears to have moved on to the next step. So thank you very much for your help.

:)

6
Installation and Upgrades / Invalid VLAN tag ' '
« on: August 12, 2012, 09:56:39 am »
Hi,

I am trying to install and setup pfsense 2.0.1

Do you want to setup your vlans now y/n? y

vlan capable interfaces

em0
em1
sk0

enter the parent name of the vlan (or nothing if finished)? em0
enter the vlan tag (1-4094):
Invalid vlan tag ' '

Rinse lather repeat.

Since I can't even get autodetect to work right it won't let me go any further.

I could use some help with this one.


7
General Questions / Re: pf sense and a multiple domain server
« on: December 21, 2011, 04:34:04 pm »
Thank you. This helps a great deal.


Sincerely,
Brendhan

8
General Questions / pf sense and a multiple domain server
« on: December 20, 2011, 09:04:27 pm »
Hi,

I am new to pf sense. I have been reading some of the tutorials and some of the other resources. However I am not getting a clear answer on this question. Can pf sense handle multiple domains on a box behind it?

I am looking to set up pf sense as a firewall, router, and dns box. I would then set up a box behind it on an internal lan. That box would be a webserver mail server. The webserver would have multiple domains and a single IP. The real IP would be on the pf sense box so the webserver would have a private ip.

Also are there any special configuration issues or additional packages I should be aware of?

Sincerely,
Brendhan

Pages: [1]