Netgate SG-1000 microFirewall

Author Topic: Niet op elk device internet  (Read 1648 times)

0 Members and 1 Guest are viewing this topic.

Offline Rico

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Niet op elk device internet
« on: March 13, 2016, 09:56:31 am »
Ik heb een firewall opgezet met PFSense.
Deze firewall beschikt over twee fysieke netwerkkaarten.
Netwerkkaart 1 = WAN
Netwerkkaart 2 = LAN

Op de LAN interface heb ik vervolgens 3 vlans aangemaakt.
Vlan 2 = Netwerk voor gezinsleden
Vlan 3 = Netwerk voor gasten
Vlan 4 = Test netwerk voor testdoeleinden.

Ik ben in bezit van een access point dat vlans ondersteunt. Zodoende heb ik eigenlijk 3 wifi netwerken aangemaakt
- Bewoners, 172.20.0.0 (Geen captiveportal)
- Gasten, 172.21.0.0 (Wel captiveportal)
- Test, 172.0.0.0 (Wel captiveportal)

Met de computers en laptops heb ik nauwelijks problemen als ik met één van de drie netwerken verbonden ben. Ik krijg van ieder vlan de juiste IP-adres in de DHCP reeks toegewezen. Ook heb ik toegang tot het internet, als het MAC-adres bekend is in de captiveportal.

Met mijn Galaxy S6 heb ik ook geen problemen, hier werkt ook alles goed mee. De juiste IP en internet toegang na het inloggen op de captiveportal.

Maar, zodra ik met een Galaxy S3 mini wilt internetten op één van de drie netwerken, krijg ik geen toegang. De captiveportal komt ook niet te voorschijn. Krijg wel de juiste IP-adres van de vlan. Als ik in de browser blader naar www.google.nl krijg ik na verloop van tijd de foutmelding dat de webpagina niet beschikbaar is. Blader ik bijvoorbeeld naar 8.8.8.8 (google) dan zie je het adres veranderen naar de captiveportal link, maar toch zie je de captiveportal niet. Inloggen is dus ook niet mogelijk.

Misschien of het verhaal nog leuker te maken: in een virtuele machine (bridged network) werkt het evenals niet, wel het juiste IP-adres. Terwijl de fysieke host wel toegang heeft tot het internet.

Wat ik geprobeerd heb
- Captiveportal uitschakelen,
- Veel gezocht op internet.

DNS staat naar mijn wetende goed ingesteld ook in de Rules van de Firewall.
De cache van de S3 mini is geleegd, daarnaast heb ik ook de fabrieksinstellingen toegepast.

Ik ben ten einde raad.

Iemand een idee?

Alvast bedankt voor het mee denken naar een oplossing!!
Rico

Offline PDJ

  • Jr. Member
  • **
  • Posts: 57
  • Karma: +2/-0
    • View Profile
Re: Niet op elk device internet
« Reply #1 on: March 22, 2016, 03:56:21 am »
Heb je in de firewall rules wel de toegang viir get captive portal ip en poort geregeld? (Dit is in de meeste gevallen het ip van de firewall)

Offline Rico

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: Niet op elk device internet
« Reply #2 on: March 23, 2016, 05:11:24 pm »
Heb je in de firewall rules wel de toegang viir get captive portal ip en poort geregeld? (Dit is in de meeste gevallen het ip van de firewall)

Dank voor je reactie.

Klopt, vaak wordt is nog wel eens vergeten, echter staan deze poorten (vaak 8002) open. DNS port (UDP 53) stond ook open.
Inmiddels is het probleem na lange troubleshooting gelukkig opgelost, door de CaptivePortals uit te schakelen en vervolgens opnieuw in te schakelen.

Nu hebben alle cliënts verbinding met het internet.

In ieder geval, bedankt voor het mee denken naar een oplossing, fijn!
Rico