pfSense Gold Subscription

Author Topic: pfsense 2.3.3-RELEASE-p1 - CAPTIVE PORTAL - Couldn't be able to make it work  (Read 203 times)

0 Members and 1 Guest are viewing this topic.

Offline sheshman

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-1
    • View Profile
Hi,

I did captive portal configuration for wifi connections but users who connected to wifi can access to internet without any username or password asked,even captive portal login page is not showing up,they are connecting to internet directly via wifi, what am i missing ?

My Configuration as below;

1-) WAN Gateway: 192.168.10.2 (192.168.10.1 is router,wifi is enabled on the router and there is no wifi password) - Interface name is : WAN

2-) LAN : 192.168.1.1 - Interface name is : LAN

3-) DHCP Enabled on WAN : 192.168.10.3->192.168.10.200

4-) DNS Servers of DHCP on WAN : 192.168.10.2(WAN INTERFACE) + 213.74.0.1(ISP) + 213.74.1.1(ISP)

5-) Default gateway of DHCP on WAN : 192.168.10.1 (Router) - when i changed to 192.168.10.2 which is pfsense interface,then wifi users won't be able to connect to internet,i don't know why.

6-) Services->Captive portal->Add->Zone name : TEST->Zone description : TESTDESC

7-) Edit Test

8-) Interface : WAN

9-) Maximum concurrent connections : 100->Idle timeout (Minutes) : 10->Hard timeout (Minutes) : 5687->Reset waiting period : Checked->Logout popup window : Checked->After authentication Redirection URL : my company's web site->Local User Manager / Vouchers : checked->Allow only users/groups with "Captive portal login" privilege set : checked->SAVE

10-) System->User Manager->Groups->Add->Group name : CPTV_USERS->Scope:Local->Description : BLABLA->SAVE

11-) Edit CPTV_USERS->Priviliges Add->Added all  Captive related privileges (17 total privileges)->SAVE

12-) System->User Manager->Users->Add : Username : test1->password : 123456->Full Name : Test USER->Group membership : CPTV_USERS->SAVE

13-) Services->DNS Resolver->General Settings->Enable DNS resolver : checked->Network Interfaces: All(i've tried to choose WAN only bu result was the same)->Outgoing Network Interfaces : All (i've tried to choose WAN only bu result was the same)->DHCP Registration : checked->Static DHCP : checked->Save->APPLY

14-) Connect to the wifi-> connect to the www.google.com or www.amazon.com->expecting pfsense captive portal's default login page->no login page showd up, www.google.com or www.amazon.com opened without any problem.

With above configuration wifi users can directly connect to the internet without any username or password asked.


What am i missing ?




Offline raghvendra

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
my configuration is kinda different but it works. My ISP cable /optical fibre/leaseline is connected to a modem now from that modem i have a  lan cable connected to my pc on lan port(NIC 1) 1 which works as a WAN for pfsense , now the output is coonect to wifi router through lan port 2 (NIC 2 which act as lan). I have activated my dhcp on lan , captive portal is enabled on lan, dhcp of router is off and bridge mode is on in router. You need to have atleast two NIC on your pc .

Offline sheshman

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-1
    • View Profile
i've re-installed PfSENSE and it solved.