pfSense Support Subscription

Author Topic: Unable to Check For Updates  (Read 30215 times)

0 Members and 1 Guest are viewing this topic.

Offline muhammet

  • Jr. Member
  • **
  • Posts: 60
  • Karma: +0/-0
    • View Profile
Re: Unable to Check For Updates
« Reply #60 on: August 29, 2016, 04:03:24 pm »
Nope! Still "unable to check for updates" error, and no way to update manually...nice!

If you're still getting that at this point, you likely have connectivity issues. First guess, the system thinks it has IPv6 connectivity and it doesn't, but could be any number of things. SSH in, option 8, run:
Code: [Select]
pfSense-upgrade -4
what's that get you?

Thanks, working.

Offline franklinsj

  • Newbie
  • *
  • Posts: 8
  • Karma: +3/-0
    • View Profile
Re: Unable to Check For Updates
« Reply #61 on: August 31, 2016, 11:40:29 am »
Same thing just happened to me but got it fixed by going to System > Routing and setting the WAN gateway as default gateway instead of the LAN gateway. 

Offline gchavy

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Unable to Check For Updates
« Reply #62 on: October 24, 2016, 03:57:00 am »
I had those issues in August, and then the dashboard changed from "unable to check for updates" to "version 2.3.2 available".

I am running a 2.3.1-RELEASE version on a specific machine, and had no time to upgrade while I had time. I upgraded other pfsense machines, but not that one (the main server, that has 11 IPSec VPNs running, and could not have an interruption until this time of the year).

And now, the 2.3.2-p1 is there, and the same problem comes again : "unable to check for updates" in the dashboard. I can't access to the console of the machine (it is a Virtual Machine hosted by a provider that gives me no console to the VMs), so I can't do it manually.

Is there a way to configure something in the GUI to make a workaround?

Thank you all (next ime, I'll do the upgrades whenever I see it's possible!)
« Last Edit: November 04, 2016, 11:41:27 am by gchavy »

Offline hawk82

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Unable to Check For Updates
« Reply #63 on: December 06, 2016, 08:21:01 pm »
Same thing just happened to me but got it fixed by going to System > Routing and setting the WAN gateway as default gateway instead of the LAN gateway.
Similar situation for me. I had an old tunnelbroker IPv6 tunnel that I had deleted, but did not delete the default gateway (it was disabled, but listed at the top of the gateways). Once I deleted this disabled gateway, the Updates were shown on the main screen. Thanks for the tip.

Offline ginne

  • Newbie
  • *
  • Posts: 23
  • Karma: +0/-0
    • View Profile
Re: Unable to Check For Updates
« Reply #64 on: March 01, 2017, 08:39:36 pm »
I did manual update because I had "Unable to check for updates" running 2.3.2 with pfSense-upgrade -4
I'm now on 2.3.3-RELEASE-p1 - fine, but again   "Unable to check for updates"!
Any solution?

Offline ginne

  • Newbie
  • *
  • Posts: 23
  • Karma: +0/-0
    • View Profile
Re: Unable to Check For Updates
« Reply #65 on: March 02, 2017, 03:30:17 pm »
I did manual update because I had "Unable to check for updates" running 2.3.2 with pfSense-upgrade -4
I'm now on 2.3.3-RELEASE-p1 - fine, but again   "Unable to check for updates"!
Any solution?

Nobody?

Offline serge2pf

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Unable to Check For Updates
« Reply #66 on: March 02, 2017, 09:23:07 pm »
I think it's related as i am getting: "The system is on a later version than the official release." while on official release.
Quote
2.3.3-RELEASE (amd64)
built on Thu Feb 16 06:59:53 CST 2017
FreeBSD 10.3-RELEASE-p16

Also, if i go to update settings it's showing wrong version while in settings it's on branch Stable (Default):
Quote
Current Base System
2.3.3
Latest Base System
0.19


~Sergei

Offline luckman212

  • Hero Member
  • *****
  • Posts: 727
  • Karma: +59/-0
    • View Profile
    • @luckman212 - github
Re: Unable to Check For Updates
« Reply #67 on: March 02, 2017, 09:25:21 pm »
I was getting this too on a fresh 2.3.3 build earlier today.
try getting to a console/ssh and issuing:

Code: [Select]
pkg update -f
pkg upgrade -f

Offline serge2pf

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Unable to Check For Updates
« Reply #68 on: March 02, 2017, 09:38:12 pm »
That's fixed for me. Thanks.

Offline taius

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Unable to Check For Updates
« Reply #69 on: March 03, 2017, 05:53:36 pm »
I was getting this too on a fresh 2.3.3 build earlier today.
try getting to a console/ssh and issuing:

Code: [Select]
pkg update -f
pkg upgrade -f

Worked for me too.  Thanks!

Offline ginne

  • Newbie
  • *
  • Posts: 23
  • Karma: +0/-0
    • View Profile
Re: Unable to Check For Updates
« Reply #70 on: March 12, 2017, 06:38:42 am »
    pkg update -f
    pkg upgrade -f

did not help. I still have:

2.3.3-RELEASE-p1 (i386)
built on Thu Mar 09 07:17:43 CST 2017
FreeBSD 10.3-RELEASE-p16

Unable to check for updates

Anybody an idea? Please.

Guenther

Offline woo

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Unable to Check For Updates
« Reply #71 on: July 06, 2017, 04:18:38 am »
Got this same issue.. Dashboard claims 'unable to check for updates'.
I can see successful traffic to files00.netgate.com in tcpdump, and pkg update -f told me that all repositories are up to date.

Offline oldunixguy

  • Newbie
  • *
  • Posts: 24
  • Karma: +0/-0
    • View Profile
Re: Unable to Check For Updates
« Reply #72 on: September 01, 2017, 08:06:30 pm »
It is happening again. I'm running 2.4.0-RC (arm)
built on Wed Aug 23 01:13:55 CDT 2017
FreeBSD 11.0-RELEASE-p11

It started at least late yesterday (31 Aug 2017) and is the same now.

oldunixguy

{Update]
I can do a packet capture but I'm not sure what to look for. Can you give me a hint at what the "Check for Update" transaction is like such as destination host, etc?

oldunixguy
« Last Edit: September 02, 2017, 10:50:41 pm by oldunixguy »

Offline shastacourts

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Unable to Check For Updates
« Reply #73 on: September 29, 2017, 01:56:36 pm »

Just curious,  is there a solution for this issue?  We have the same issue running 2.3-RELEASE. 

Offline shaker242

  • Newbie
  • *
  • Posts: 4
  • Karma: +1/-0
    • View Profile
Re: Unable to Check For Updates
« Reply #74 on: November 27, 2017, 09:47:22 am »
pkg-static update –f
pkg-static upgrade –f

I'm a late upgrader, found this issue and running pkg -f  was presented with missing libssl.so.8, switched to pkg-static and the update, upgrade worked... although, I did have to reboot the pfsense server afterwards to get things up and running.
« Last Edit: November 27, 2017, 09:57:37 am by shaker242 »