pfSense English Support > Installation and Upgrades

Issues updating from 2.3-RC (or older 2.3 installs) to 2.3-RELEASE

(1/13) > >>

jimp:
For issues updating from RC (or older) to -RELEASE:

No trusted public keys found
If you see an error when checking for or installing updates that states "No trusted public keys found", run the following command from the shell or Diagnostics > Command:


--- Code: ---fetch -qo /usr/local/share/pfSense/keys/pkg/trusted/ https://raw.githubusercontent.com/pfsense/pfsense/RELENG_2_3_0/src/usr/local/share/pfSense/keys/pkg/trusted/pkg.pfsense.org.20160406
--- End code ---

Unable to Check for Updates
If you see "unable to check for updates", and/or the package manager cannot fetch data:

First, make sure you have pfSense-base or pfSense-base-nanobsd installed:

Check the output of:

--- Code: ---pkg info -x pfSense
--- End code ---

If pfSense-base is missing (Full install) or if pfSense-base-nanobsd missing (NanoBSD), run:


--- Code: ---pkg install pfSense-base
--- End code ---



Upgrade resulted in running 2.3.1 or the version claims to be newer

For anyone who landed on 2.3.1 or has a message stating that they are on a newer version than release: To get 2.3-RELEASE proper, follow this:

First, check the pkg repository configuration:


--- Code: ---ls -l /usr/local/etc/pkg/repos/pfSense.conf
--- End code ---

It should point to /usr/local/share/pfSense/pkg/repos/pfSense-repo.conf

If it does not:


--- Code: ---rm /usr/local/etc/pkg/repos/pfSense.conf
ln -s /usr/local/share/pfSense/pkg/repos/pfSense-repo.conf /usr/local/etc/pkg/repos/pfSense.conf
--- End code ---

Double check the contents of the file:


--- Code: ---: cat /usr/local/etc/pkg/repos/pfSense.conf
FreeBSD: { enabled: no }

pfSense-core: {
  url: "pkg+http://pkg.pfsense.org/pfSense_v2_3_0_amd64-core",
  mirror_type: "srv",
  signature_type: "fingerprints",
  fingerprints: "/usr/local/share/pfSense/keys/pkg",
  enabled: yes
}

pfSense: {
  url: "pkg+http://pkg.pfsense.org/pfSense_v2_3_0_amd64-pfSense_v2_3_0",
  mirror_type: "srv",
  signature_type: "fingerprints",
  fingerprints: "/usr/local/share/pfSense/keys/pkg",
  enabled: yes
}
--- End code ---

If the contents of that file matches above, OK, if not, edit the file and make it match.

Force an update to the pkg database:


--- Code: ---pkg update -f
--- End code ---

If that fails:


--- Code: ---fetch -qo /usr/local/share/pfSense/keys/pkg/trusted/ https://raw.githubusercontent.com/pfsense/pfsense/RELENG_2_3_0/src/usr/local/share/pfSense/keys/pkg/trusted/pkg.pfsense.org.20160406
--- End code ---

And then run the update command again.

Lastly, force an upgrade of all installed packages:


--- Code: ---pkg upgrade -f
--- End code ---

If an error is shown that the kernel package is locked, you can unlock it with "pkg unlock <name>" replacing <name> with what the error complains about, then run the "pkg update -f" command again. Be sure to lock it back after you're done.

GTAXL:
One bug I'm getting, I did that and was able to upgrade to 2.3-Release.
On the dashboard page it shows 2.3-RELEASE (amd64)  The system is on a later version than the official release.
It doesn't show the update available button, but when I go to the System > Update it shows,
Current Base System 2.3.1.a.20160412.1112
Latest Base System 2.3
and has the update button, I click it but get,
pfSense repository is up-to-date.
All repositories are up-to-date.
Your packages are up to date
Success

So I guess it's just reading the current base system incorrectly? No biggie just throwing that out there.

ohwell:
I'm seeing:

   Current Base System 2.3.r.20160406.0534
   Latest Base System 2.3.1.a.20160412.1222

even though I have Update Settings set to

   Follow 2.3 snapshots and move automatically to -RELEASE (Default). The Dashboard still shows that I'm on 2.3-RC.

jimp:

--- Quote from: ohwell on April 12, 2016, 02:36:29 pm ---I'm seeing:

   Current Base System 2.3.r.20160406.0534
   Latest Base System 2.3.1.a.20160412.1222

even though I have Update Settings set to

   Follow 2.3 snapshots and move automatically to -RELEASE (Default). The Dashboard still shows that I'm on 2.3-RC.

--- End quote ---

To make sure you're on the right track, click Save on the update settings with that set. Then run the update. It will show that and then during the backup it will see -RELEASE and use that instead, due to that setting.

Achromatic:

--- Quote from: jimp on April 12, 2016, 02:38:21 pm ---
To make sure you're on the right track, click Save on the update settings with that set. Then run the update. It will show that and then during the backup it will see -RELEASE and use that instead, due to that setting.

--- End quote ---

I saved as Dev, then saved as Stable.

Still showed 2.3.1 (noting what you said above), and hit update:


--- Code: --->>> Updating repositories metadata...
Updating pfSense-core repository catalogue...
pfSense-core repository is up-to-date.
Updating pfSense repository catalogue...
pfSense repository is up-to-date.
All repositories are up-to-date.
ERROR: It was not possible to determine pfSense-repo-devel remote version
Failed

--- End code ---

Navigation

[0] Message Index

[#] Next page

Go to full version