pfSense Support Subscription

Author Topic: Issues updating from 2.3-RC (or older 2.3 installs) to 2.3-RELEASE  (Read 47921 times)

0 Members and 1 Guest are viewing this topic.

Offline deajan

  • Full Member
  • ***
  • Posts: 180
  • Karma: +27/-0
    • View Profile
Re: Issues updating from 2.3-RC (or older 2.3 installs) to 2.3-RELEASE
« Reply #15 on: April 13, 2016, 09:49:10 am »
I am also having an issue with updating. I was on the last RC and attempted to update to 2.3-RELEASE and received the following error.

First post of jimp resolves this issue !
NetPOWER.fr - some opensource stuff for IT people

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 21312
  • Karma: +1423/-26
    • View Profile
Re: Issues updating from 2.3-RC (or older 2.3 installs) to 2.3-RELEASE
« Reply #16 on: April 13, 2016, 09:58:06 am »
You guys made a major poop on this one.

I don't  know about that, at this point 2.3.1 is ~= 2.3-REL (aside from a few extra fixes, so, bonus). It didn't brick anything, things still work, etc. Inconvenient, sure, but not FUBAR.

By following this some of us some how ended up on the dev even though we had the "Follow 2.3 snapshots and move automatically to -RELEASE (Default)" set.
How can we fix this? Like others here I try to force an update to 2.3-RELEASE but I cant cause I am on a devel version.
There has to be a fix to this without having to re-install.

There is, I was able to replicate it once yesterday. I'm working on a procedure to switch back. It's not terribly difficult, but I need to be able to repeat it reliably.
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline raidflex

  • Jr. Member
  • **
  • Posts: 41
  • Karma: +1/-0
    • View Profile
Re: Issues updating from 2.3-RC (or older 2.3 installs) to 2.3-RELEASE
« Reply #17 on: April 13, 2016, 11:43:28 am »
I am also having an issue with updating. I was on the last RC and attempted to update to 2.3-RELEASE and received the following error.

First post of jimp resolves this issue !

I was also successful with updating using the command in the first post.  Thanks for the fix!

Offline waves

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: Issues updating from 2.3-RC (or older 2.3 installs) to 2.3-RELEASE
« Reply #18 on: April 13, 2016, 11:44:18 am »
Please, help me to restore a full back-up that i made before "upgrading" to 2.3. My snort rules doesn't work anymore and i have the feeling that a bunch of other things are broken now with this new 2.3 release.


I have the back-up stored on /root   ( pfSense-full-backup-20160413-1446.tgz). How can i invoke it from the terminal?  In /etc i can't find any rc.restore full back-up. On the forum i can't find any other info about this.  Thank you in advance.

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 21312
  • Karma: +1423/-26
    • View Profile
Re: Issues updating from 2.3-RC (or older 2.3 installs) to 2.3-RELEASE
« Reply #19 on: April 13, 2016, 11:50:20 am »
Please, help me to restore a full back-up that i made before "upgrading" to 2.3. My snort rules doesn't work anymore and i have the feeling that a bunch of other things are broken now with this new 2.3 release.

I have the back-up stored on /root   ( pfSense-full-backup-20160413-1446.tgz). How can i invoke it from the terminal?  In /etc i can't find any rc.restore full back-up. On the forum i can't find any other info about this.  Thank you in advance.

That feature is not supported on pfSense 2.3. Your safest path is to reinstall the older version directly. Otherwise you'll end up with a mix of things all over the filesystem (which was one of many reasons that feature was removed...)

Better still would be to work and get snort working on 2.3. The package maintainer is very active in the IDS/IPS board here under packages. Post there for snort help, it's probably not a difficult fix.
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline serialdie

  • Sr. Member
  • ****
  • Posts: 454
  • Karma: +8/-0
    • View Profile
Re: Issues updating from 2.3-RC (or older 2.3 installs) to 2.3-RELEASE
« Reply #20 on: April 13, 2016, 11:56:36 am »
You guys made a major poop on this one.

I don't  know about that, at this point 2.3.1 is ~= 2.3-REL (aside from a few extra fixes, so, bonus). It didn't brick anything, things still work, etc. Inconvenient, sure, but not FUBAR.

By following this some of us some how ended up on the dev even though we had the "Follow 2.3 snapshots and move automatically to -RELEASE (Default)" set.
How can we fix this? Like others here I try to force an update to 2.3-RELEASE but I cant cause I am on a devel version.
There has to be a fix to this without having to re-install.

There is, I was able to replicate it once yesterday. I'm working on a procedure to switch back. It's not terribly difficult, but I need to be able to repeat it reliably.

Thank you for your fast reply jimp.

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 21312
  • Karma: +1423/-26
    • View Profile
Re: Issues updating from 2.3-RC (or older 2.3 installs) to 2.3-RELEASE
« Reply #21 on: April 13, 2016, 11:58:58 am »
I just edited a fix into the first post for people who ended up on 2.3.1 or otherwise have a message saying they're on a version newer than the release. Should fix it all up.
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline waves

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: Issues updating from 2.3-RC (or older 2.3 installs) to 2.3-RELEASE
« Reply #22 on: April 13, 2016, 12:08:58 pm »

Quote
That feature is not supported on pfSense 2.3. Your safest path is to reinstall the older version directly. Otherwise you'll end up with a mix of things all over the filesystem (which was one of many reasons that feature was removed...)

Better still would be to work and get snort working on 2.3. The package maintainer is very active in the IDS/IPS board here under packages. Post there for snort help, it's probably not a difficult fix.


This is very bad news...  :(  I will try to install the older version and restore config.xml.  I have a post in IDS as well, but i'm in a production enviroment and...   You get my point.  Thank you for your reply.

Offline serialdie

  • Sr. Member
  • ****
  • Posts: 454
  • Karma: +8/-0
    • View Profile
Re: Issues updating from 2.3-RC (or older 2.3 installs) to 2.3-RELEASE
« Reply #23 on: April 13, 2016, 12:43:09 pm »

Quote
That feature is not supported on pfSense 2.3. Your safest path is to reinstall the older version directly. Otherwise you'll end up with a mix of things all over the filesystem (which was one of many reasons that feature was removed...)

Better still would be to work and get snort working on 2.3. The package maintainer is very active in the IDS/IPS board here under packages. Post there for snort help, it's probably not a difficult fix.


This is very bad news...  :(  I will try to install the older version and restore config.xml.  I have a post in IDS as well, but i'm in a production enviroment and...   You get my point.  Thank you for your reply.

Ouch!
2.3 is too new for production, Hence why I am using it at home/dev for now. Good luck.

Offline serialdie

  • Sr. Member
  • ****
  • Posts: 454
  • Karma: +8/-0
    • View Profile
Re: Issues updating from 2.3-RC (or older 2.3 installs) to 2.3-RELEASE
« Reply #24 on: April 13, 2016, 12:43:36 pm »
@jimp,

Thanks for the update... so far so good.

Offline christian.arminio

  • Jr. Member
  • **
  • Posts: 29
  • Karma: +0/-0
    • View Profile
Re: Issues updating from 2.3-RC (or older 2.3 installs) to 2.3-RELEASE
« Reply #25 on: April 13, 2016, 05:51:25 pm »
Hello,

after update I've many problems and web gui shows always this message :

Code: [Select]
pfSense is booting, then packages will be reinstalled in the background.
Do not make changes in the GUI until this is complete.

I've tried the Jimp's guide at first post but it doesn't work :

Code: [Select]
pkg update -f
fetch -qo /usr/local/share/pfSense/keys/pkg/trusted/ https://raw.githubusercontent.com/pfsense/pfsense/RELENG_2_3_0/src/usr/local/share/pfSense/keys/pkg/trusted/pkg.pfsense.org.20160406
fetch: https://raw.githubusercontent.com/pfsense/pfsense/RELENG_2_3_0/src/usr/local/share/pfSense/keys/pkg/trusted/pkg.pfsense.org.20160406: Network is unreachable

Any help is very appreciated .
Best regards

Offline MyKroFt

  • Jr. Member
  • **
  • Posts: 27
  • Karma: +1/-0
    • View Profile
Re: Issues updating from 2.3-RC (or older 2.3 installs) to 2.3-RELEASE
« Reply #26 on: April 13, 2016, 06:28:52 pm »
have done everything is post #1 am still stuck....

Code: [Select]
2.3-RELEASE (amd64)
built on Mon Apr 11 18:10:34 CDT 2016
FreeBSD 10.3-RELEASE

The system is on a later version than
the official release.

Myk

Offline IrrationalEscalation

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: Issues updating from 2.3-RC (or older 2.3 installs) to 2.3-RELEASE
« Reply #27 on: April 13, 2016, 08:37:35 pm »
Code: [Select]
fetch -qo /usr/local/share/pfSense/keys/pkg/trusted/ https://raw.githubusercontent.com/pfsense/pfsense/RELENG_2_3_0/src/usr/local/share/pfSense/keys/pkg/trusted/pkg.pfsense.org.20160406

... worked for me. Thanks!

Offline wirerogue

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
    • View Profile
Re: Issues updating from 2.3-RC (or older 2.3 installs) to 2.3-RELEASE
« Reply #28 on: April 13, 2016, 08:58:48 pm »
I just edited a fix into the first post for people who ended up on 2.3.1 or otherwise have a message saying they're on a version newer than the release. Should fix it all up.

worked for me. you da man!!!


Offline YonNomNom

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Issues updating from 2.3-RC (or older 2.3 installs) to 2.3-RELEASE
« Reply #29 on: April 14, 2016, 02:11:17 am »
My pfsense box cant access the internet unless it is using a proxy (the proxy is separate to this instance of pfsense). It managed to update but now it is stuck attempting to download package metadata :(
« Last Edit: April 14, 2016, 02:14:27 am by YonNomNom »