pfSense Gold Subscription

Author Topic: Gateway monitoring not working post-2.3 upgrade? Read here  (Read 11418 times)

0 Members and 1 Guest are viewing this topic.

Offline jano23

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: Gateway monitoring not working post-2.3 upgrade? Read here
« Reply #15 on: April 10, 2017, 10:50:08 pm »
Thanks!!

Offline ikinoktabilisim

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Gateway monitoring not working post-2.3 upgrade? Read here
« Reply #16 on: June 09, 2017, 01:20:02 am »
If your gateway monitoring isn't working post-2.3 upgrade, it's likely one of two things.

Verify advanced options are sane

Browse to System>Routing and edit the gateway that's down. Then click Save. That will trigger the input validation that makes sure the configuration is valid, especially the advanced options. You may have had options set for apinger that are not valid for dpinger. If you get any errors upon saving, fix them, save, and apply changes.

Set ping payload size

Some modems have a bug that makes them drop pings with 0 byte payloads. dpinger uses a 0 byte payload by default because there isn't a need to include one and unnecessarily chew up bandwidth. If you have such a buggy upstream device, you'll need to set the payload to something greater than 0. System>Routing, edit the gateway, go to Advanced, and set payload to 1. Save and apply changes.

Yes, it works again  ;D