Netgate SG-1000 microFirewall

Author Topic: send() failed (40: Message too long)  (Read 6957 times)

0 Members and 1 Guest are viewing this topic.

Offline Gertjan

  • Hero Member
  • *****
  • Posts: 2435
  • Karma: +191/-9
    • View Profile
Re: send() failed (40: Message too long)
« Reply #30 on: January 30, 2018, 04:38:06 am »
I changed my form from:
<input name="redirurl" type="hidden" value="$PORTAL_REDIRURL$">

To:
<input name="redirurl" type="hidden" value="http://www.google.com">

to see the results... I will reply asap

Did you try to change your old redirect URL "http%3A%2F%2F172.16.0.1%2F" == "http://172.16.0.1/"
to "http://www.google.com" instead of changing the source ?

What pfSense version ? - is it patched or modified ?

Offline pama

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
    • Pama billing and machine tools
Re: send() failed (40: Message too long)
« Reply #31 on: February 05, 2018, 01:11:47 am »
The same here.
After re-applying the squid settings it stopped to logs the errors, but after 2 or 3 days (depends on load) it reappears

Offline sujyo1

  • Jr. Member
  • **
  • Posts: 91
  • Karma: +4/-0
    • View Profile
Re: send() failed (40: Message too long)
« Reply #32 on: February 10, 2018, 08:24:19 pm »
2.4.2-RELEASE-p1 (amd64)
built on Tue Dec 12 13:45:26 CST 2017
FreeBSD 11.1-RELEASE-p6

Intel(R) Core(TM) i5 CPU 750 @ 2.67GHz
Current: 2667 MHz, Max: 2668 MHz
4 CPUs: 1 package(s) x 4 core(s)
AES-NI CPU Crypto: No

Interfaces:   
 WAN      1000baseT <full-duplex>   xx.xx.ccc.ccc
 LAN              autoselect   192.168.1.1
 OFFICE      100baseTX <full-duplex>   192.168.100.1
HOTSPOT      1000baseT <full-duplex>   10.10.10.1 (captive portal is ON)



nginx: 2018/02/10 19:49:01 [error] 28887#100127: *4888 open() "/usr/local/www/phpmyadmin" failed (2: No such file or directory), client: 1x0.2x9.1xx.x6, server: , request: "GET /phpmyadmin HTTP/1.1", host: "xx.3x.2xx.xxx", referrer: "http://xx.xx.xxx.xxx/phpmyadmin"

I getting same a full page...

Feb 10 15:05:55   nginx: 2018/02/10 15:05:55 [alert] 43837#100173: send() failed (40: Message too long)
« Last Edit: February 10, 2018, 08:27:47 pm by sujyo1 »