Netgate SG-1000 microFirewall

Author Topic: Upgrade 2.3_1 details  (Read 1914 times)

0 Members and 1 Guest are viewing this topic.

Offline deajan

  • Full Member
  • ***
  • Posts: 180
  • Karma: +27/-0
    • View Profile
Upgrade 2.3_1 details
« on: May 11, 2016, 02:23:22 am »
Hello,

I just updated my home pfSense from 2.3 to 2.3_1.
I usually make this before deciding to go with production pfsense updates.

The blog states
Quote
Updating ntpd from 4.2.8p6 to 4.2.8p7 is the only change.

When reading the upgrade log, from pfsense, it seems that the squidGuard package also gets updated.

Code: [Select]
>>> Updating repositories metadata...
Updating pfSense-core repository catalogue...
pfSense-core repository is up-to-date.
Updating pfSense repository catalogue...
pfSense repository is up-to-date.
All repositories are up-to-date.
>>> Scheduling package pfSense-repo-devel for removal...
>>> Installing pfSense-repo... done.
>>> Removing pfSense-repo-devel... done.
>>> Updating repositories metadata...
Updating pfSense-core repository catalogue...
Fetching meta.txz: . done
Fetching packagesite.txz: . done
Processing entries: .. done
pfSense-core repository update completed. 13 packages processed.
Updating pfSense repository catalogue...
Fetching meta.txz: . done
Fetching packagesite.txz: .......... done
Processing entries: .......... done
pfSense repository update completed. 374 packages processed.
>>> Unlocking package pfSense-kernel-pfSense... done.
>>> Downloading upgrade packages...
Updating pfSense-core repository catalogue...
pfSense-core repository is up-to-date.
Updating pfSense repository catalogue...
pfSense repository is up-to-date.
All repositories are up-to-date.
Checking for upgrades (5 candidates): ..... done
Processing candidates (5 candidates): .... done
The following 3 package(s) will be affected (of 0 checked):

Installed packages to be UPGRADED:
pfSense-pkg-squidGuard: 1.14_2 -> 1.14_3 [pfSense]
pfSense: 2.3 -> 2.3_1 [pfSense]
ntp: 4.2.8p6 -> 4.2.8p7 [pfSense]

495 KiB to be downloaded.
Fetching pfSense-pkg-squidGuard-1.14_3.txz: ..... done
Fetching pfSense-2.3_1.txz: . done
Fetching ntp-4.2.8p7.txz: .......... done
Checking integrity... done (0 conflicting)
>>> Upgrading necessary packages...
Updating pfSense-core repository catalogue...
pfSense-core repository is up-to-date.
Updating pfSense repository catalogue...
pfSense repository is up-to-date.
All repositories are up-to-date.
Checking for upgrades (5 candidates): ..... done
Processing candidates (5 candidates): .... done
Checking integrity... done (0 conflicting)
The following 3 package(s) will be affected (of 0 checked):

Installed packages to be UPGRADED:
pfSense-pkg-squidGuard: 1.14_2 -> 1.14_3 [pfSense]
pfSense: 2.3 -> 2.3_1 [pfSense]
ntp: 4.2.8p6 -> 4.2.8p7 [pfSense]
[1/3] Upgrading ntp from 4.2.8p6 to 4.2.8p7...
[1/3] Extracting ntp-4.2.8p7: .......... done
[2/3] Upgrading pfSense-pkg-squidGuard from 1.14_2 to 1.14_3...
Removing squidGuard components...
Menu items... done.
Services... done.
Loading package instructions...
[2/3] Extracting pfSense-pkg-squidGuard-1.14_3: .......... done
Saving updated package information...
overwrite!
Loading package configuration... done.
Configuring package components...
Loading package instructions...
Custom commands...
Executing custom_php_install_command()...done.
Executing custom_php_resync_config_command()...done.
Menu items... done.
Services... done.
Writing configuration... done.
Please visit Services - SquidGuard Proxy Filter - Target Categories and set up at least one category there before enabling SquidGuard. See https://forum.pfsense.org/index.php?topic=94312.0 for details.[3/3] Upgrading pfSense from 2.3 to 2.3_1...
[3/3] Extracting pfSense-2.3_1: ... done
Message from pfSense-pkg-squidGuard-1.14_3:
Please visit Services - SquidGuard Proxy Filter - Target Categories and set up at least one category there before enabling SquidGuard. See https://forum.pfsense.org/index.php?topic=94312.0 for details.
>>> Removing unnecessary packages... done.
>>> Cleanup pkg cache... done.
>>> Locking package pfSense-kernel-pfSense... done.
Success

Altough this is not a big deal, it would be nice to know what gets updated before doing it so we know what critical services needs to be checked later.
Maybe a side effect of the new package update system ?

Regards,
Ozy.
NetPOWER.fr - some opensource stuff for IT people

Online heper

  • Hero Member
  • *****
  • Posts: 2708
  • Karma: +257/-11
    • View Profile
Re: Upgrade 2.3_1 details
« Reply #1 on: May 11, 2016, 02:50:39 am »
The _1 update involved NTP.
But since 2.3 everything is a package.

So every package gets updated when updating the system

Offline deajan

  • Full Member
  • ***
  • Posts: 180
  • Karma: +27/-0
    • View Profile
Re: Upgrade 2.3_1 details
« Reply #2 on: May 11, 2016, 03:11:55 am »
I understand this, but it should be advertised on the release notes :)
NetPOWER.fr - some opensource stuff for IT people

Offline cmb

  • Hero Member
  • *****
  • Posts: 11228
  • Karma: +896/-7
    • View Profile
    • Chris Buechler
Re: Upgrade 2.3_1 details
« Reply #3 on: May 11, 2016, 04:29:45 am »
If you have packages installed that are outdated, yes they'll also be updated in the process. We'll have to clarify that in the future, showing which packages will be upgraded.