pfSense Support Subscription

Author Topic: ERROR Installing squid and squidGuard in pfsense 2.3.2  (Read 1031 times)

0 Members and 1 Guest are viewing this topic.

Offline nayanivijay

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
ERROR Installing squid and squidGuard in pfsense 2.3.2
« on: July 27, 2016, 08:47:32 am »
Hi All,

I am getting below error when i am going to install squid and squidGuard pakage

>>> Installing pfSense-pkg-squidGuard...
Updating pfSense-core repository catalogue...
pfSense-core repository is up-to-date.
Updating pfSense repository catalogue...
pfSense repository is up-to-date.
All repositories are up-to-date.
Checking integrity... done (0 conflicting)
The following 3 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
   pfSense-pkg-squidGuard: 1.14_3 [pfSense]
   squidGuard: 1.4_15 [pfSense]
   squid: 3.5.19_1 [pfSense]

Number of packages to be installed: 3

The process will require 10 MiB more space.
[1/3] Installing squid-3.5.19_1...
===> Creating groups.
Using existing group 'squid'.
===> Creating users
Using existing user 'squid'.
install: not found
pkg: PRE-INSTALL script failed
Failed
« Last Edit: July 27, 2016, 08:51:01 am by nayanivijay »

Offline cmb

  • Hero Member
  • *****
  • Posts: 11228
  • Karma: +894/-7
    • View Profile
    • Chris Buechler
Re: ERROR Installing squid and squidGuard in pfsense 2.3.2
« Reply #1 on: July 27, 2016, 10:53:09 pm »
That's the issue here.
https://redmine.pfsense.org/issues/6643

To work around it, run:

Code: [Select]
tar xv -C / -f /usr/local/share/pfSense/base.txz ./usr/bin/install

Offline nayanivijay

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: ERROR Installing squid and squidGuard in pfsense 2.3.2
« Reply #2 on: July 29, 2016, 02:04:42 am »
Thanks cmb,

Now its working.