The pfSense Store

Author Topic: Squid installation Fail after latest update  (Read 534 times)

0 Members and 1 Guest are viewing this topic.

Offline lgalford

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Squid installation Fail after latest update
« on: July 27, 2016, 05:13:23 pm »
After yesterday update i downloaded the last version and I was trying to install squid + squidguard but when I try to initiate the installatiion process i get the following error.

Code: [Select]
>>> Installing pfSense-pkg-squid...
Updating pfSense-core repository catalogue...
pfSense-core repository is up-to-date.
Updating pfSense repository catalogue...
pfSense repository is up-to-date.
All repositories are up-to-date.
Updating database digests format: . done
New version of pkg detected; it needs to be installed first.
The following 1 package(s) will be affected (of 0 checked):

Installed packages to be UPGRADED:
pkg: 1.7.2_2 -> 1.8.7 [pfSense]

2 MiB to be downloaded.
Fetching pkg-1.8.7.txz: .......... done
Checking integrity... done (0 conflicting)
[1/1] Upgrading pkg from 1.7.2_2 to 1.8.7...
You may need to manually remove /usr/local/etc/pkg.conf if it is no longer needed.
[1/1] Extracting pkg-1.8.7: .......... done
pkg: option EVENT_PIPE is defined in the environment to '/tmp/pfSense-upgrade.sock' but command line option redefines it
pkg: Connect event pipe(/tmp/pfSense-upgrade.sock): Connection refused
Updating pfSense-core repository catalogue...
pfSense-core repository is up-to-date.
Updating pfSense repository catalogue...
pfSense repository is up-to-date.
All repositories are up-to-date.
The following 15 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
pfSense-pkg-squid: 0.4.21 [pfSense]
squid_radius_auth: 1.10 [pfSense]
squid: 3.5.19_1 [pfSense]
krb5: 1.14.2 [pfSense]
pkgconf: 0.9.12_1 [pfSense]
cyrus-sasl: 2.1.26_12 [pfSense]
squidclamav: 6.14 [pfSense]
c-icap: 0.4.3,2 [pfSense]
c-icap-modules: 0.4.3 [pfSense]
clamav: 0.99.2 [pfSense]
unzoo: 4.4_2 [pfSense]
arc: 5.21p [pfSense]
lha: 1.14i_6 [pfSense]
arj: 3.10.22_4 [pfSense]
json-c: 0.12_2 [pfSense]

Number of packages to be installed: 15

The process will require 26 MiB more space.
7 MiB to be downloaded.
Fetching pfSense-pkg-squid-0.4.21.txz: ...... done
Fetching squid_radius_auth-1.10.txz: . done
Fetching squid-3.5.19_1.txz: .......... done
Fetching krb5-1.14.2.txz: .......... done
Fetching pkgconf-0.9.12_1.txz: ... done
Fetching cyrus-sasl-2.1.26_12.txz: .......... done
Fetching squidclamav-6.14.txz: ...... done
Fetching c-icap-0.4.3,2.txz: .......... done
Fetching c-icap-modules-0.4.3.txz: .......... done
Fetching clamav-0.99.2.txz: .......... done
Fetching unzoo-4.4_2.txz: .. done
Fetching arc-5.21p.txz: .... done
Fetching lha-1.14i_6.txz: ... done
Fetching arj-3.10.22_4.txz: .......... done
Fetching json-c-0.12_2.txz: .... done
Checking integrity... done (0 conflicting)
[1/15] Installing pkgconf-0.9.12_1...
[1/15] Extracting pkgconf-0.9.12_1: ....... done
[2/15] Installing unzoo-4.4_2...
[2/15] Extracting unzoo-4.4_2: .. done
[3/15] Installing arc-5.21p...
[3/15] Extracting arc-5.21p: ...... done
[4/15] Installing lha-1.14i_6...
[4/15] Extracting lha-1.14i_6: .. done
[5/15] Installing arj-3.10.22_4...
[5/15] Extracting arj-3.10.22_4: .......... done
[6/15] Installing json-c-0.12_2...
[6/15] Extracting json-c-0.12_2: .......... done
[7/15] Installing krb5-1.14.2...
[7/15] Extracting krb5-1.14.2: .......... done
[8/15] Installing cyrus-sasl-2.1.26_12...
*** Added group `cyrus' (id 60)
*** Added user `cyrus' (id 60)
[8/15] Extracting cyrus-sasl-2.1.26_12: .......... done
[9/15] Installing c-icap-0.4.3,2...
===> Creating groups.
Creating group 'c_icap' with gid '959'.
===> Creating users
Creating user 'c_icap' with uid '959'.
[9/15] Extracting c-icap-0.4.3,2: .......... done
[10/15] Installing clamav-0.99.2...
===> Creating groups.
Creating group 'clamav' with gid '106'.
Using existing group 'mail'.
===> Creating users
Creating user 'clamav' with uid '106'.
Adding user 'clamav' to group 'mail'.
[10/15] Extracting clamav-0.99.2: .......... done
[11/15] Installing squid_radius_auth-1.10...
[11/15] Extracting squid_radius_auth-1.10: .... done
[12/15] Installing squid-3.5.19_1...
===> Creating groups.
Creating group 'squid' with gid '100'.
===> Creating users
Creating user 'squid' with uid '100'.
install: not found
pkg: PRE-INSTALL script failed
Failed


any ideas..  ::)

Rgds
Luis

Offline cmb

  • Hero Member
  • *****
  • Posts: 11228
  • Karma: +894/-7
    • View Profile
    • Chris Buechler
Re: Squid installation Fail after latest update
« Reply #1 on: July 27, 2016, 10:53:39 pm »
That's the issue here.
https://redmine.pfsense.org/issues/6643

To work around it, run:

Code: [Select]
tar xv -C / -f /usr/local/share/pfSense/base.txz ./usr/bin/install