pfSense English Support > Installation and Upgrades

2.3.x "Unable to check for updates"/"Unable to retrieve package information"

(1/1)

jimp:
If a firewall is running pfSense 2.3.0_x or 2.3.1_x and before August 3rd it attempted to upgrade to pfSense 2.3.2 and failed, or if the firewall was on an older version but installed or updated a package, the firewall will have upgraded to pkg version 1.8.7 or later during the process.

This version of pkg requires a slightly different set of command line arguments which are not passed to it by the older GUI code, and as such it will be unable to upgrade using the GUI and it is also unable to manage packages. The dashboard System Information widget will display "Unable to check for updates"  and attempting to list packages results in "Unable to retrieve package information". Using the pkg command manually in the shell will continue to function.

We have updated our pkg version to 1.8.7_1 which includes a workaround for the problem.

There are two solutions:

1. Upgrade the firewall to pfSense 2.3.2 or later. An upgrade can be performed by using option 13 from the console or over ssh. Alternately, from a shell (ssh or console option 8), use "pfSense-upgrade -d"

2. Upgrade pkg to the corrected version:

--- Code: ---pkg update; pkg upgrade pkg
--- End code ---

We highly recommend that all firewalls be upgraded to 2.3.2 instead of staying on older versions.

jimp:
Updated the post to reflect the fix we have published.

jimp:
Please do not post other update failures to this thread, as they are highly unlikely to be related. Start new threads for different errors.

Navigation

[0] Message Index

Go to full version