Netgate SG-1000 microFirewall

Author Topic: Install squid package without internet access directly  (Read 499 times)

0 Members and 1 Guest are viewing this topic.

Offline Moredo

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Install squid package without internet access directly
« on: September 15, 2016, 01:19:21 pm »
hello to everybody

I am a beginner in pfsense.

I want to install squid package in pfsense or another , but when i tried to access to the package list i can't see anything, the pfsense gui says that it can't find available package.

My ISP provider have a proxy over my network

Offline KOM

  • Hero Member
  • *****
  • Posts: 5596
  • Karma: +688/-23
    • View Profile
Re: Install squid package without internet access directly
« Reply #1 on: September 15, 2016, 02:06:58 pm »
You're going to have to figure that out with them eventually.  There is no easy way to install pfSense packages offline that I am aware of.  You would have to figure out what's being downloaded from where, grab it manually from outside your network, copy it to your pfSense box and then run the package manager to install it.

Offline Moredo

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: Install squid package without internet access directly
« Reply #2 on: February 09, 2018, 05:17:57 pm »
Finally, i resolved my problem.

I downloaded the repository to a computer, later i install an apache server and put inside the repositoty.
With Winscp yo must connect to pfsense server and modify the file: pfsense-Repo.conf  in /usr/local/share/pfSense and /usr/local/share/pfSense/pkg/repos . Change https by http and put in tha line your apache site ip

FreeBSD: { enabled: no }

pfSense-core: {
  url: "pkg+http://YOUR APACHE IP/pfSense_v2_3_4_amd64-core",
  mirror_type: "srv",
  signature_type: "fingerprints",
  fingerprints: "/usr/local/share/pfSense/keys/pkg",
  enabled: yes
}

pfSense: {
  url: "pkg+http://YOUR APACHE IP/pfSense_v2_3_4_amd64-pfSense_v2_3_4",
  mirror_type: "srv",
  signature_type: "fingerprints",
  fingerprints: "/usr/local/share/pfSense/keys/pkg",
  enabled: yes