pfSense Gold Subscription

Author Topic: Nintendo Switch - Needs static port on its outbound NAT  (Read 691 times)

0 Members and 3 Guests are viewing this topic.

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 19819
  • Karma: +1122/-8
    • View Profile
Nintendo Switch - Needs static port on its outbound NAT
« on: March 06, 2017, 08:46:41 pm »
At least with the one online multiplayer game I have used so far (Fast RMX) the only requirement for Nintendo Switch online multiplayer is static port outbound NAT. It did not appear to require UPnP, but it's safer to enable that in case another game needs it later.

So as with the Wii U, 3DS, and other similar consoles the best course of action is:

1. Set a static IP address for the device via DHCP static mappings
- Status > DHCP Leases, find the device, click + to add a mapping, set a static address, save, etc.

2. Switch to Hybrid Outbound NAT
- Firewall > NAT, Outbound tab
- Select Hybrid Outbound NAT, Save

3. Add Outbound NAT rule
- Firewall > NAT, Outbound tab
- Click +
- Set the console address as the source (Type = Network, then enter the IP address, pick /32 for the CIDR)
- Check Static Port
- Save/Apply

4. (Optional, So far) Enable UPnP & NAT-PMP
- Enable UPnP & NAT-PMP
- Allow UPnP Port Mapping
- Pick External (WAN) and Internal Interfaces (LAN)
- Set other options as desired
- Save

EDIT: My son is using the Splatoon pre-release global test fire and the online multiplayer is working fine, still only using static port outbound NAT. No UPnP.
« Last Edit: Yesterday at 03:16:07 pm by jimp »
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline iloveramen

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Nintendo Switch - Needs static port on its outbound NAT
« Reply #1 on: March 08, 2017, 11:19:18 am »
Thank you jimp.  This is a great reminder and advice for everyone on the forum.

Offline Alex Atkin UK

  • Newbie
  • *
  • Posts: 24
  • Karma: +0/-0
    • View Profile
Re: Nintendo Switch - Needs static port on its outbound NAT
« Reply #2 on: Yesterday at 03:07:55 pm »
Are you sure about this?

I just tried and you can't set the console IP as the source as the only options are Network, Any or This  Firewall.

 think you may have applied Static Port to the whole LAN not the Switch specifically, in which case you do not need a new rule, just modify the existing one.

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 19819
  • Karma: +1122/-8
    • View Profile
Re: Nintendo Switch - Needs static port on its outbound NAT
« Reply #3 on: Yesterday at 03:15:17 pm »
Nope, just the switch. Use network and /32 for a single host on the outbound NAT source.
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline sirjorj

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Nintendo Switch - Needs static port on its outbound NAT
« Reply #4 on: Yesterday at 03:20:34 pm »
Thanks for this!  I just spent the hour trying to get the Splatoon 2 test fire working and for all I know, the entire event was to show off their new "Unable to connect" screen (I have a screenshot if you want to see it - it is very pretty!)

I had UPNP enabled for the right addresses and it did nothing.  I then unchecked the 'deny access by default' option and it still did nothing.  If that didn't help, what good is UPNP anyway?  Or is this just Nintendo writing bad network code?

Anyway, thanks again!

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 19819
  • Karma: +1122/-8
    • View Profile
Re: Nintendo Switch - Needs static port on its outbound NAT
« Reply #5 on: Yesterday at 03:40:42 pm »
Well UPnP is for inbound connections, outbound NAT is for outbound. Apparently the way their multiplayer code works, it needs to send back to the console on a particular port, which needs to be static so it's the same in both directions. Not sure why game servers can't just send back to the port it came from, but who knows...

So UPnP does nothing for that kind of setup. Just setup the static port outbound NAT as I laid out above and it should be fine.

At least there are two more days of test fires so keep trying. There are times tomorrow and Sunday. And even one more tonight. See attached (times in EDT)

Edit: Not my pic. Shamelessly lifted from Reddit.
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline Alex Atkin UK

  • Newbie
  • *
  • Posts: 24
  • Karma: +0/-0
    • View Profile
Re: Nintendo Switch - Needs static port on its outbound NAT
« Reply #6 on: Yesterday at 06:03:57 pm »
Still annoying that Nintendo did it this way.

For a portable device that most likely will get used a fair bit on public networks that you CAN'T specify their outbound NAT settings, it seems like a very poor design indeed.

Thanks for reminding me about the /32, it was only hours later I realised my mistake.  Its just been one of those days.
« Last Edit: Yesterday at 06:08:27 pm by Alex Atkin UK »

Offline Yockanookany

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Nintendo Switch - Needs static port on its outbound NAT
« Reply #7 on: Yesterday at 11:03:09 pm »
I made a thread dealing with these issues (https://forum.pfsense.org/index.php?reportsent;topic=127837.msg705258#msg705258) and followed your directions which were already mostly done besides hybrid NAT. I had no luck with those changes sadly and it's the end of the testfire so I'm unable to test further for now.