pfSense Gold Subscription

Author Topic: driver does not support altq on new build  (Read 791 times)

0 Members and 1 Guest are viewing this topic.

Offline Omitted

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
driver does not support altq on new build
« on: March 11, 2017, 10:23:09 am »
Hi All,

Running into an issue on a newly built pfSense system and hoping someone will be able to help. I've done some reading but can't find anything specific on how to fix the issue.

Motherboard: Supermicro X10SDV-4C-TLN2F
using the onboard NIC: 2 RJ45 10GBase-T ports

2.3.3-RELEASE-p1 (amd64)
FreeBSD 10.3-RELEASE-p17


I went through the wizard to setup traffic shaping and get the following error:
There were error(s) loading the rules: pfctl: ix0: driver does not support altq - The line in question reads
  • :



I was previously using Traffic Shaping on a similar setup without any problems. Difference was it was in a virtualized situation with virtio drivers.


Has anyone else run into this issue or found a workaround?

Thanks

Offline w0w

  • Sr. Member
  • ****
  • Posts: 538
  • Karma: +31/-6
  • kernel panic attack
    • View Profile
Re: driver does not support altq on new build
« Reply #1 on: March 11, 2017, 11:08:22 am »
I don't think it's a good idea to run pfSense on 10G interfaces, even if you are lucky and getting ALTQ working you will be limited in bandwidth.
http://marc.info/?l=openbsd-misc&m=131004567300627&w=2
https://groups.google.com/forum/#!topic/bsdmailinglist/ES_3966Cb3Q
If you are building some shaper, you may try to play with IPFW codel https://forum.pfsense.org/index.php?topic=126637.0
If you don't really need 10G bandwidth create redmine ticket and ask for ALTQ support/patch on your hardware, but before just try 2.4 beta, may be already working.
« Last Edit: March 11, 2017, 11:39:56 am by w0w »

Offline pvuchetich

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: driver does not support altq on new build
« Reply #2 on: August 23, 2017, 08:53:46 am »
Just adding a note that this is a relevant issue on the pfSense XG-1540 (2.3.4-RELEASE-p1, which is the most recent version at the time of this post).  The *default* WAN and LAN interfaces use the ix0 and ix1 (10G) connections, so the traffic shaping wizard created the alert that altq traffic shaping was not supported.

OPT1 and OPT2 use the igb0 and igb1 connections (1 G), which should support altq.  This is easy enough to reconfigure, and it may be addressed in a later version as noted (2.4 beta?), although I am not planning on testing the beta software on this particular firewall.

Thanks for the thread - with this note, it looks like reassigning interfaces may be needed prior to applying altq traffic shaping on this and future devices, or waiting until altq is supported on 10G (ix0/ix1 interface).

Offline Ap0p0

  • Newbie
  • *
  • Posts: 24
  • Karma: +0/-0
    • View Profile
Re: driver does not support altq on new build
« Reply #3 on: October 19, 2017, 11:22:12 am »
Hi all,

I'm experiencing the same issue. I Have two XG-2758 gateways with pfSense 2.3.4_p1 (FreeBSD 10.3_p19). It's not possible to support altq on ix0 and ix1 interfaces. Since last post, pfSense 2.4 is released.

Can someone confirm that altq support is OK with ix driver in 2.4?

Thanks to all.

Offline w0w

  • Sr. Member
  • ****
  • Posts: 538
  • Karma: +31/-6
  • kernel panic attack
    • View Profile
Re: driver does not support altq on new build
« Reply #4 on: October 20, 2017, 10:42:29 am »
According to this https://www.freebsd.org/cgi/man.cgi?query=altq&sektion=4#end should be fine on 2.4 or any FreeBSD 9 and up, also we have https://redmine.pfsense.org/issues/5923 You should contact Netgate directly to obtain information or just try 2.4.

Offline Ap0p0

  • Newbie
  • *
  • Posts: 24
  • Karma: +0/-0
    • View Profile
Re: driver does not support altq on new build
« Reply #5 on: October 20, 2017, 05:37:01 pm »
Thank you for your answer. I had confirmation that this issue is always present in 2.4. I'm trying to know if there is a roadmap for it.

Offline Nullity

  • Hero Member
  • *****
  • Posts: 973
  • Karma: +96/-9
    • View Profile
Re: driver does not support altq on new build
« Reply #6 on: October 20, 2017, 07:08:55 pm »
Thank you for your answer. I had confirmation that this issue is always present in 2.4. I'm trying to know if there is a roadmap for it.

I'd ask whomever confirmed the 2.4 issue.
Please correct any obvious misinformation in my posts.
-Not a professional; an arrogant ignoramous.