pfSense Support Subscription

Author Topic: Unable to reboot 2.4  (Read 2378 times)

0 Members and 1 Guest are viewing this topic.

Offline meruem

  • Jr. Member
  • **
  • Posts: 67
  • Karma: +2/-1
    • View Profile
Re: Unable to reboot 2.4
« Reply #30 on: April 22, 2017, 01:20:31 pm »
Seem like you have an ACPI problem if it is failing to read those values.

You might try a different ACPI mode in the BIOS. But it's probably because the motherboard vendor wrote it for Windows only. You running the latest BIOS?

Steve

Yep. latest bios. I tried turning off acpi all kinds of ways .. changed settings for over 4 hours , reinstalled pfsense multiple times. I may be unlucky but I think its a pervasive issue because I read few other online posts of different day 0 kaby lake support mobo's (200 series chipsets) having similar issues on freebsd

Offline meruem

  • Jr. Member
  • **
  • Posts: 67
  • Karma: +2/-1
    • View Profile
Re: Unable to reboot 2.4
« Reply #31 on: April 22, 2017, 01:42:17 pm »
Took a bunch of random shots of bios incase anyone see's any red flags

http://imgur.com/a/hKk3T


Offline meruem

  • Jr. Member
  • **
  • Posts: 67
  • Karma: +2/-1
    • View Profile
Re: Unable to reboot 2.4
« Reply #32 on: April 27, 2017, 02:32:37 am »
edit: bad info's i gave
« Last Edit: May 13, 2017, 08:32:48 am by meruem »

Offline meruem

  • Jr. Member
  • **
  • Posts: 67
  • Karma: +2/-1
    • View Profile
Re: Unable to reboot 2.4
« Reply #33 on: April 27, 2017, 03:06:05 am »
also btw dont do this shit you see all over the net

Code: [Select]
set hint.acpi.0.disabled="1"
cause then your pc wont boot and you'll spend an hour trying to figure out how to fix it

Offline kpa

  • Hero Member
  • *****
  • Posts: 1047
  • Karma: +117/-4
    • View Profile
Re: Unable to reboot 2.4
« Reply #34 on: April 27, 2017, 04:28:51 am »
also btw dont do this shit you see all over the net

Code: [Select]
set hint.acpi.0.disabled="1"
cause then your pc wont boot and you'll spend an hour trying to figure out how to fix it

The quoted setting to disable ACPI was valid advice around the year 2000 when ACPI was brand new and the implentations were sometimes very buggy, not anymore. Don't disable ACPI on any modern system, you'll just shoot yourself in the foot.
« Last Edit: May 19, 2017, 01:25:18 pm by kpa »

Offline meruem

  • Jr. Member
  • **
  • Posts: 67
  • Karma: +2/-1
    • View Profile
Re: Unable to reboot 2.4
« Reply #35 on: April 27, 2017, 02:27:08 pm »
Ah ok thanks for background

also i just tried rebooting and it hanged again, so I guess what I said early about adding a pci-e card didnt fix it

Offline meruem

  • Jr. Member
  • **
  • Posts: 67
  • Karma: +2/-1
    • View Profile
Re: Unable to reboot 2.4
« Reply #36 on: May 13, 2017, 08:33:54 am »
anyone have updates on this? it's terrible having nice new hardware upgrade, but you can reboot the thing without physically going to the case and hitting the reset button

Offline eXceed

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Unable to reboot 2.4
« Reply #37 on: May 19, 2017, 10:57:15 am »
also btw dont do this shit you see all over the net

Code: [Select]
set hint.acpi.0.disabled="1"
cause then your pc wont boot and you'll spend an hour trying to figure out how to fix it

Erm... Tried this and every other solution in this thread.

Do not do the above, it causes kernel panic (way to resolve is to escape to loader prompt. Type set set hint.acpi.0.disabled="0", and remove the line in your devices.hint file (in /boot/ directory).

Tried all ACPI workarounds to no avail.

System specs are:

Intel E3-1270 v5
Supermicro X11DAT
32GB ECC DDR4
128GB NVMe 960 Pro

Boot hangs on uptime, this is kind of critical as this stops updates from being possible remotely. Shutdown/Halt system works fine, however...

EDIT - Just to add I've tried the following (perhaps more can't remember everything):
  • Disabling ACPI
  • Enabling ACPI
  • Disabling ACPI and adding: hw.acpi.handle_reboot with value of 0 and 1 to system tunables
  • Enabling ACPI and adding: hw.acpi.handle_reboot with value of 0 and 1 to system tunables
  • Enabling WHEA and adding: hw.acpi.handle_reboot with value of 0 and 1 to system tunables

« Last Edit: May 19, 2017, 11:02:28 am by eXceed »

Offline yon

  • Full Member
  • ***
  • Posts: 294
  • Karma: +1/-0
    • View Profile
Re: Unable to reboot 2.4
« Reply #38 on: May 23, 2017, 05:09:40 pm »
me too. updated to 0522 1958version.

Offline betatest

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Re: Unable to reboot 2.4
« Reply #39 on: June 07, 2017, 03:51:34 pm »
I have the same problem with my ASROCK H270M-ITX and Intel 600p nvme boot drive. Strangely it will only recognise one nic as intel, the other one as generic. It also does not show the wifi adapter but I will not use it anyway.

Do you want me to upload any logs for research?

Offline eXceed

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Unable to reboot 2.4
« Reply #40 on: June 08, 2017, 10:43:52 am »
Any update to this issue at all?

Or does anyone know how to raise an issue on issue tracker?

Offline yon

  • Full Member
  • ***
  • Posts: 294
  • Karma: +1/-0
    • View Profile
Re: Unable to reboot 2.4
« Reply #41 on: June 08, 2017, 04:54:55 pm »
>>> Updating repositories metadata...
Updating pfSense-core repository catalogue...
pfSense-core repository is up to date.
Updating pfSense repository catalogue...
pkg: sqlite error while executing iterator in file pkgdb_iterator.c:1035: database disk image is malformed
pfSense repository is up to date.
All repositories are up to date.
ERROR: It was not possible to determine pkg remote version
Failed
ERROR: It was not possible to determine pfSense-repo remote version
Failed
ERROR: Unable to compare version of pfSense-repo
Failed