pfSense Support Subscription

Author Topic: [Dell R200] acd0 timeout, installation impossible  (Read 13754 times)

0 Members and 1 Guest are viewing this topic.

Offline Sh4

  • Jr. Member
  • **
  • Posts: 35
  • Karma: +0/-0
    • View Profile
[Dell R200] acd0 timeout, installation impossible
« on: December 01, 2008, 02:24:09 pm »
Hello,

I bought 15 Dell R200 fully loaded (Quad Core 3Ghz / 4Gb / Intel Pro 1000PT Dual / SAS6iR Raid1) and I can't install pfsense on those (tried two weeks old snapshot and RC2)

The error is :

acd0: TIMEOUT - READ_BIG retrying (1 retry left)
acd0: TIMEOUT - READ_BIG retrying (0 retry left)
acd0: TIMEOUT - READ_BIG timed out

(Cycle a few times and then)

GEOM_LABEL: Label for provider acd0 is iso9660/pfSense

(and cycle again)

I've tried disabling DMA and ACPI, burned each CD twice at slow speed, disabled all onboard uneeded stuff.

Edit: When I boot in safe mode I get additional verbose before and while the error occur : "interrupt storm detected on "irq6:" ; throttling interrupt source"
IRQ6 is "Embedded SATA 1" and "Embedded South Bridge Device 11", changing the IRQs doesn't solve the issue, error appear again with the new IRQ#

Help please im in big trouble.
« Last Edit: December 01, 2008, 02:33:57 pm by Sh4 »
pfSense 1.2
24x [DELL PowerEdge 1950 III]
-2x Quad Core Intel Xeon E5420 2.5GHz
-8GB FB 667MHz Memory (4x2GB) Memory RAID 2x4GB
-PERC 6/i RAID Controller
-Intel® PRO 1000PT Dual Port PCIe x4

Offline fastcon68

  • Sr. Member
  • ****
  • Posts: 593
  • Karma: +1/-0
    • View Profile
Re: [Dell R200] acd0 timeout, installation impossible
« Reply #1 on: December 01, 2008, 02:54:20 pm »
Have you tried to diable the raid controller and install?  I under stand that there is a software raid built into PF-Sense built have attempted to try to utilize it myself?  Just a thought.
RC

Offline Sh4

  • Jr. Member
  • **
  • Posts: 35
  • Karma: +0/-0
    • View Profile
Re: [Dell R200] acd0 timeout, installation impossible
« Reply #2 on: December 01, 2008, 03:33:16 pm »
Well just let it sit there for 30 minutes and when I came back it was booted, the IRQ messages that appeared in safe mode are worrying me tho, did a drive install and the acd0 error is gone (obviously)

Will see how that works
pfSense 1.2
24x [DELL PowerEdge 1950 III]
-2x Quad Core Intel Xeon E5420 2.5GHz
-8GB FB 667MHz Memory (4x2GB) Memory RAID 2x4GB
-PERC 6/i RAID Controller
-Intel® PRO 1000PT Dual Port PCIe x4

Offline Darkk

  • Full Member
  • ***
  • Posts: 234
  • Karma: +1/-0
    • View Profile
Re: [Dell R200] acd0 timeout, installation impossible
« Reply #3 on: December 01, 2008, 11:45:41 pm »
Nice piece of hardware for a firewall.   I can imagine plans for alot of IPSec stuff?

Darkk
« Last Edit: December 01, 2008, 11:50:40 pm by Darkk »

Offline Sh4

  • Jr. Member
  • **
  • Posts: 35
  • Karma: +0/-0
    • View Profile
Re: [Dell R200] acd0 timeout, installation impossible
« Reply #4 on: December 02, 2008, 12:01:28 pm »
Nice piece of hardware for a firewall.   I can imagine plans for alot of IPSec stuff?

Darkk


Just a boring firewall with nothing fancy, VIP and 1:1 NAT.

The specs are high because it is used for a popular MMORPG game server (10k+ clients, Gigabit Wan)

Important thing on online games is the latency, that's why its complicated to use software firewall, we currently use 40k€ Juniper firewalls but I want to move everything to pfsense to save on budget and gain scalability.

The setup is done now and everything looks fine, will start testing tomorow.
pfSense 1.2
24x [DELL PowerEdge 1950 III]
-2x Quad Core Intel Xeon E5420 2.5GHz
-8GB FB 667MHz Memory (4x2GB) Memory RAID 2x4GB
-PERC 6/i RAID Controller
-Intel® PRO 1000PT Dual Port PCIe x4

Offline atamido

  • Jr. Member
  • **
  • Posts: 58
  • Karma: +0/-0
    • View Profile
Re: [Dell R200] acd0 timeout, installation impossible
« Reply #5 on: December 02, 2008, 01:51:45 pm »
I'm very curious to see how it does latency wise with a high number of connections compared to expensive commercial firewalls.

Offline Sh4

  • Jr. Member
  • **
  • Posts: 35
  • Karma: +0/-0
    • View Profile
Re: [Dell R200] acd0 timeout, installation impossible
« Reply #6 on: December 15, 2008, 01:22:57 pm »
I reup this post because I bought some more R200 with slightly different specs and this problem is still present and won't go away, I avoided the problem on the others servers by just loading a disk image of a fresh pfsense install from the one that worked after 30 mins, but now im stuck with the different R200, trying the same things than with the previous except its been 5 hours.

Editing my post because it is unclear in the original post, this appear when booting from the livecd so it is not HD install only problem.

Theres obviously something wrong here with the release, please give me clues.
« Last Edit: December 15, 2008, 01:25:03 pm by Sh4 »
pfSense 1.2
24x [DELL PowerEdge 1950 III]
-2x Quad Core Intel Xeon E5420 2.5GHz
-8GB FB 667MHz Memory (4x2GB) Memory RAID 2x4GB
-PERC 6/i RAID Controller
-Intel® PRO 1000PT Dual Port PCIe x4

Offline eyewittness

  • Jr. Member
  • **
  • Posts: 32
  • Karma: +0/-0
    • View Profile
Re: [Dell R200] acd0 timeout, installation impossible
« Reply #7 on: December 19, 2008, 07:59:47 am »
You need to download imgburn from filehippo. see http://www.filehippo.com/screenshot/imgburn/4428_1/
Then make sure you put the verify check on.
This will fix that problem! I have the same hardware as you i think!
I'm running RC4.

Offline AudiAddict

  • Full Member
  • ***
  • Posts: 201
  • Karma: +0/-0
    • View Profile
Re: [Dell R200] acd0 timeout, installation impossible
« Reply #8 on: December 19, 2008, 08:57:35 am »
Running RC4 here on two of them.. still having problems with dropping connections.. console not showing after some reboots..

fresh installs.. both machines have it.. argg.!

Offline eyewittness

  • Jr. Member
  • **
  • Posts: 32
  • Karma: +0/-0
    • View Profile
Re: [Dell R200] acd0 timeout, installation impossible
« Reply #9 on: December 19, 2008, 09:34:10 am »
I also think that im having trouble with connection lost, cause some users login very slowly and loose there profile.
Someone knows whats going on?

Offline AudiAddict

  • Full Member
  • ***
  • Posts: 201
  • Karma: +0/-0
    • View Profile
Re: [Dell R200] acd0 timeout, installation impossible
« Reply #10 on: December 19, 2008, 01:12:27 pm »
With the help of Billm I solved the connection problems by turning off RIP.

The missing console is still gone.. but I can live with that..