pfSense Support Subscription

Author Topic: Upgrade from 2.3.3_p1 to 2.4 failed  (Read 876 times)

0 Members and 1 Guest are viewing this topic.

Offline yodaphone

  • Jr. Member
  • **
  • Posts: 65
  • Karma: +1/-0
    • View Profile
Upgrade from 2.3.3_p1 to 2.4 failed
« on: April 20, 2017, 04:53:52 pm »
I was on 2.3.3 p1 release. I triggered the update to 2.4 from the web.

it went thro & said "Upgrade is complete" & rebooted. It still showed 2.3.3 p1.

so i went to the console & looked & found this after reboot

Code: [Select]
Shared object "libssl.so.8" not found, required by "pkg"
Shared object "libssl.so.8" not found, required by "pkg"
ERROR: It was not possible to identify which pfSense kernel is installed
I then tried the "upgrade from console" but still got the same error
Any ideas?

Do i have to do a fresh install?
PS: I do have a backup

BTW the firewall is working though  ::)

Attaching the upgrade log

When i open the package manager i get this

  • Unable to retrieve package information.

so i tried the step in the upgrade log which said

pkg: Warning: Major OS version upgrade detected.  Running "pkg-static install -f pkg" recommended

Quote
Updating pfSense-core repository catalogue...
Fetching meta.txz: 100%    940 B   0.9kB/s    00:01
Fetching packagesite.txz: 100%    2 KiB   1.7kB/s    00:01
Processing entries: 100%
pfSense-core repository update completed. 7 packages processed.
Updating pfSense repository catalogue...
Fetching meta.txz: 100%    944 B   0.9kB/s    00:01
Fetching packagesite.txz: 100%  123 KiB 126.2kB/s    00:01
Processing entries: 100%
pfSense repository update completed. 454 packages processed.
All repositories are up to date.
Checking integrity... done (0 conflicting)
The following 1 package(s) will be affected (of 0 checked):

Installed packages to be REINSTALLED:
        pkg-1.10.1_1 [pfSense]

Number of packages to be reinstalled: 1

Proceed with this action? [y/N]: y
[1/1] Reinstalling pkg-1.10.1_1...
[1/1] Extracting pkg-1.10.1_1: 100%
You may need to manually remove /usr/local/etc/pkg.conf if it is no longer needed.

still nothing....
« Last Edit: April 20, 2017, 05:49:28 pm by yodaphone »

Offline doktornotor

  • Hero Member
  • *****
  • Posts: 8230
  • Karma: +861/-231
  • Not a pfSense employee, they cannot fire me...
    • View Profile
Re: Upgrade from 2.3.3_p1 to 2.4 failed
« Reply #1 on: April 21, 2017, 05:20:34 am »
Waste of time, do a fresh install (preferably taking the opportunity to switch to ZFS while there) and restore the config (could even be done during install, automatically.)

P.S. Hate to state the obvious, but we'll either never see 2.4 released, or it will turn out as a major fiasco with package management/upgrade mechanism like this... Junk.
Do NOT PM for help!

Offline yodaphone

  • Jr. Member
  • **
  • Posts: 65
  • Karma: +1/-0
    • View Profile
Re: Upgrade from 2.3.3_p1 to 2.4 failed
« Reply #2 on: April 21, 2017, 06:04:40 am »
thanks

did exactly that..

now another quick question...

i used ufs with GPT . any idea how to enable TRIM on 2.4? 'cause instead of UFS id its now a gptid.

i looked up ZFS & since i dont have enough memory & TRIM causes major issues in ZFS i ignored it. moreover,, i dont need ZFS for my setup. thanks for the tip though

Offline doktornotor

  • Hero Member
  • *****
  • Posts: 8230
  • Karma: +861/-231
  • Not a pfSense employee, they cannot fire me...
    • View Profile
Re: Upgrade from 2.3.3_p1 to 2.4 failed
« Reply #3 on: April 21, 2017, 07:02:46 am »
Trim is autoenabled on ZFS. No idea about trim on UFS, that filesystem is suicidal junk... having ZFS is alone a good reason to upgrade to 2.4. You'd really be much better off with getting more RAM for this (Pretty cheap nowadays, and 4GB is plenty enough for ZFS.)
Do NOT PM for help!

Offline yodaphone

  • Jr. Member
  • **
  • Posts: 65
  • Karma: +1/-0
    • View Profile
Re: Upgrade from 2.3.3_p1 to 2.4 failed
« Reply #4 on: April 21, 2017, 01:21:51 pm »
great, i'll switch to ZFS then

BTW, just for the heck of it, i tried to re-install 2.3.3 & then updated to p1. did a restore of the config (which was working on the same version). got the same error message. :-\ :o

the restore is messing up the kernel. not sure which module though. the packages i have in the backup are

1. pfblockerng
2. Cron
3. nut
4. OpenVPN Client
5. tinc
6. System Patches
7. ntopng
8. arping
9. Service Watchdog
10. squid3
11. acme


going back to 2.4 with ZFS with these required packages

1. pfblockerng
2. Cron
3. nut
4. OpenVPN Client
5. tinc
6. acme

UPDATE: Ok, install & upgrade with above packages worked. Not sure but definitely one of these packages is breaking the upgrade

1. System Patches
2. ntopng
3. arping
4. Service Watchdog
5. squid3

« Last Edit: April 21, 2017, 04:23:17 pm by yodaphone »

Offline Marc A. Mapplebeck

  • Jr. Member
  • **
  • Posts: 35
  • Karma: +3/-0
    • View Profile
Re: Upgrade from 2.3.3_p1 to 2.4 failed
« Reply #5 on: May 02, 2017, 12:48:59 pm »
I ran the following to at least resolve a few issues related to name resolution(specifically failures with dynamic VPN endpoints) with this issue:
Code: [Select]
echo "nameserver 8.8.8.8" >> /etc/resolv.conf

That being said, I am still unable to go up to 2.4

Hopefully this can be easily resolved, as flashing would be a last ditch effort.
« Last Edit: May 02, 2017, 02:05:32 pm by Marc A. Mapplebeck »