pfSense Support Subscription

Author Topic: SquidGuard Default Blacklist SafeSearch settings and Shallalist  (Read 24351 times)

0 Members and 1 Guest are viewing this topic.

Offline BobFather

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
SquidGuard Default Blacklist SafeSearch settings and Shallalist
« on: December 08, 2008, 04:09:19 pm »
I am new to pfSense. 
Used IPCop for several years, but have switched because Configuration is much better with pfSense.
Trying to setup SquidGuard to filter using Shallalist Blacklist.
List seems to be working correctly but I lost the "default" web search filtering that was working before.
With the Default SquidGuard Database It would include the SafeSearch and also redirect actual unacceptable searches before providing results.
Have been searching on how to configure this or keep the default functionality while using a more advanced blacklist.

Any Ideas, or am I missing something simple.
I am very seriously needing this filtering and am open to alternate suggestions.
Thanks

Online dvserg

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4783
  • Karma: +0/-0
    • View Profile
    • My Homepage
Re: SquidGuard Default Blacklist SafeSearch settings and Shallalist
« Reply #1 on: December 09, 2008, 12:41:26 am »
Inplaced SquidGuard blacklist is replaced with Shallalist Blacklist.
You can use only one blacklist. For restoring inplaced SG blacklist you can reinstall package.

Offline BobFather

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: SquidGuard Default Blacklist SafeSearch settings and Shallalist
« Reply #2 on: December 09, 2008, 08:50:09 am »
I have already reinstalled the package to get the search filtering back.
Was wondering how to "include" the search filtering in a more advanced list.
Or is there already a list out there that includes the default "safesearch" features?

Online dvserg

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4783
  • Karma: +0/-0
    • View Profile
    • My Homepage
Re: SquidGuard Default Blacklist SafeSearch settings and Shallalist
« Reply #3 on: December 09, 2008, 01:30:19 pm »
Shallalist Blacklist have searchengines option

Offline BobFather

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: SquidGuard Default Blacklist SafeSearch settings and Shallalist
« Reply #4 on: December 09, 2008, 04:09:20 pm »
Yes but I can only set it to Allow or Deny.
I don't want to shut the search engine down, just control it.
Somehow the Default Settings before loading a blacklist (have tried Shallalist and several others)
Rewrite the search URL so the search engines run in SafeSearch mode and also seem to filter the Search Expresions directly.  I would like to include this WITH a blacklist. 

Have been researching and I think there might be a rewrite rule I can setup under SquidGuard to modify the URL's, but crashed my pfSense box trying to see what would work.  Just finished reloading and restoring my backup.

Thanks for any help or ideas you may have.

Offline BobFather

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: SquidGuard Default Blacklist SafeSearch settings and Shallalist
« Reply #5 on: December 09, 2008, 05:39:52 pm »
I just blew up my install again.
I am trying to use the Rewrite Rules under SquidGuard to modify the URL's of the searches to include SafeSearch paramagers.

I found these on one of my searches:
s@(google..*/search?.*q=.*)@\1\&safe=active@i
s@(google..*/images.*q=.*)@\1\&safe=active@i
s@(google..*/groups.*q=.*)@\1\&safe=active@i
s@(google..*/news.*q=.*)@\1\&safe=active@i

but taking the "(google..*/search?.*q=.*)" as the original match
and using "\1\&safe=active" as the modification
is causing my pfSense to crash.

Is this the way to do what I want, or is there another way?
I know on the SquidGuard sight it talks about modifying the configuration file to include customizations,
but I am not familar with what file to modify or where to change it.

Online dvserg

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4783
  • Karma: +0/-0
    • View Profile
    • My Homepage
Re: SquidGuard Default Blacklist SafeSearch settings and Shallalist
« Reply #6 on: December 10, 2008, 01:06:54 pm »
I just blew up my install again.
I am trying to use the Rewrite Rules under SquidGuard to modify the URL's of the searches to include SafeSearch paramagers.

I found these on one of my searches:
s@(google..*/search?.*q=.*)@\1\&safe=active@i
s@(google..*/images.*q=.*)@\1\&safe=active@i
s@(google..*/groups.*q=.*)@\1\&safe=active@i
s@(google..*/news.*q=.*)@\1\&safe=active@i

but taking the "(google..*/search?.*q=.*)" as the original match
and using "\1\&safe=active" as the modification
is causing my pfSense to crash.

Is this the way to do what I want, or is there another way?
I know on the SquidGuard sight it talks about modifying the configuration file to include customizations,
but I am not familar with what file to modify or where to change it.

Use 'Rewrite' item for define Google safe search rule
Example:
Item s@(google..*/search?.*q=.*)@\1\&safe=active@i
Must be added as
Target URL = (google..*/search?.*q=.*)
Replace To URL  = \1\&safe=active

And etc...
« Last Edit: December 10, 2008, 01:08:38 pm by dvserg »

Offline BobFather

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: SquidGuard Default Blacklist SafeSearch settings and Shallalist
« Reply #7 on: December 10, 2008, 03:42:52 pm »
I have already tried using a rewrite item to do this twice.
Target URL = (google..*/search?.*q=.*)
Replace To URL  = \1\&safe=active

Doing this caused something in the configuration to go bad and pfSense started acting like it was just installed.
Installed Packages disapeared, pfSense DropDown GUI reverted to default pfSense GUI, then it just quit working.

Restore of backup wouldn't run, so I reloaded from CD and restored.

I thought I had done something wrong, so tried again and got same results.

Are you positive this should work? 
I can try again, but expect to have to reload if the results come out the same as the last 2 times.

I do appreciate the help. 
Have everything else working by using Shallalist and Expression Rules.
This would be the "Icing on the cake".

Thanks

Offline choup

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: SquidGuard Default Blacklist SafeSearch settings and Shallalist
« Reply #8 on: January 13, 2009, 09:58:46 pm »
I seem to have run into this same Google SafeSearch problem. I have implemented SquidGuard on a regular school K12LTSP server and this works perfectly.

It seems that there is something in the pfSense configuration file that is awry.

using rewrite item:
Target URL = (google..*/search?.*q=.*)
Replace To URL  = \1\&safe=active

Causes the system to lose its configuration? To my way of thinking, this sure seems like a bug in how pfSense handles data input in this area.

Has anyone found a fix/workaround for the Google SafeSearch?

Charlie

Online dvserg

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4783
  • Karma: +0/-0
    • View Profile
    • My Homepage

Offline choup

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: SquidGuard Default Blacklist SafeSearch settings and Shallalist
« Reply #10 on: January 14, 2009, 12:42:25 am »
DVSERG

Looked at the link you provided, don't know how that resolves the problem, because it is still not working.

I have installed pfSense v1.2.2, reinstalled squid and squidguard packages, installed blacklists, and checked to make sure squidguard was working correctly.

However, once you try to add the rewrite info for Google SafeSearch it blows out, defaults to different web admin theme, loses all package settings and base configuration. Cannot re-load from backups either. If you close and reopen the browser, it won't even let you access the web console.

The only way you're going to see this problem and understand it is for you to try doing it on a system.

Your response to BobFather is the same one I'm trying and it's not working.

"Use 'Rewrite' item for define Google safe search rule"
Example:
Item s@(google..*/search?.*q=.*)@\1\&safe=active@i
Must be added as
Target URL = (google..*/search?.*q=.*)
Replace To URL  = \1\&safe=active

Thanks for the feedback.

Charlie

Online dvserg

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4783
  • Karma: +0/-0
    • View Profile
    • My Homepage
Re: SquidGuard Default Blacklist SafeSearch settings and Shallalist
« Reply #11 on: January 14, 2009, 02:27:46 am »
Code: [Select]
Looked at the link you provided, don't know how that resolves the problem, because it is still not working.Exists package manager bug with 'rowhelper' field and \1 \2 \x codes  - config will crashed
Neet fix this bug.

Offline choup

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: SquidGuard Default Blacklist SafeSearch settings and Shallalist
« Reply #12 on: January 14, 2009, 10:18:39 am »
Thanks again for the response DVSERG.

Hopefully this bug will get fixed soon, otherwise pfSense is really not usable in an educational environment due to not being able to properly block unwanted content.

Charlie

Online dvserg

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4783
  • Karma: +0/-0
    • View Profile
    • My Homepage
Re: SquidGuard Default Blacklist SafeSearch settings and Shallalist
« Reply #13 on: January 29, 2009, 02:04:10 am »
SquidGuard safesearch Google and Yandex(ru/com) update. ! For test ONLY, Not for worked systems !

- download 'http://diskatel.narod.ru/pfSense/packages/squidguard_safesearch.zip'
- unpack to '/usr/local/pkg'

Changes:
- ACL: order
- ACL/Default: rewrite
  -- added sys rewrite 'safesrch_google'

Please test..
« Last Edit: January 30, 2009, 12:10:13 pm by dvserg »

Online dvserg

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4783
  • Karma: +0/-0
    • View Profile
    • My Homepage
Re: SquidGuard Default Blacklist SafeSearch settings and Shallalist
« Reply #14 on: January 30, 2009, 12:09:02 pm »
Any body interested this?  ???