The pfSense Store

Author Topic: slbd bug on SMP fixed?  (Read 5155 times)

0 Members and 1 Guest are viewing this topic.

Offline familyguy

  • Jr. Member
  • **
  • Posts: 77
  • Karma: +0/-0
    • View Profile
slbd bug on SMP fixed?
« on: December 13, 2008, 02:51:54 pm »
I noticed there is a new release candidate.  Just wondering if the bug where slbd runs away with the cpu(s) on SMP machines has been addressed so I can go back to using an SMP kernel.  :)

Cheers,

Offline databeestje

  • Hero Member
  • *****
  • Posts: 1048
  • Karma: +1/-0
  • It just might be your luck day, if you only knew.
    • View Profile
Re: slbd bug on SMP fixed?
« Reply #1 on: December 14, 2008, 04:10:47 pm »
We have made changes there so it should work normally now. It needs testing for confirmation, so please test!

Offline cmb

  • Hero Member
  • *****
  • Posts: 11230
  • Karma: +893/-7
    • View Profile
    • Chris Buechler
Re: slbd bug on SMP fixed?
« Reply #2 on: December 16, 2008, 07:58:43 pm »
I believe that went away with FreeBSD 7.0, but that hasn't been fully confirmed.

Offline NickC

  • Jr. Member
  • **
  • Posts: 31
  • Karma: +0/-0
    • View Profile
Re: slbd bug on SMP fixed?
« Reply #3 on: December 17, 2008, 06:21:33 am »
It's a while since I thought about this one. I've been running 1.2.1-RCx with SLBD (3 failover groups) for weeks now on a quad core xeon rackmount (DL140). I've not seen SLBD grab 100% of a core for a long time now. And stability seems good.

One thing I do see is some mis-reporting in the GUI. A line may show "Offline" whereas the logs show that line as up ie. "marking service UP" was the most recent log for that line. I consistently see this on the primary firewall (SMB) but not on the backup firewall (uniprocessor). The backup firewall uses the same synched-over settings and correctly shows all the lines as "online".

Nick.