Netgate Store

Author Topic: Hardrive stuck in PIO  (Read 5459 times)

0 Members and 1 Guest are viewing this topic.

Offline stevewm

  • Newbie
  • *
  • Posts: 21
  • Karma: +0/-0
    • View Profile
Hardrive stuck in PIO
« on: December 16, 2008, 04:32:52 pm »
Problem: In 1.2.1 (any RC) the hardrive and CD-ROM operate in PIO4 mode.  Installation takes quite a while because of this obviously and I fear other operations such as Squid caching will be negatively affected by this.    With 1.2 Release, the hardrive operates in UDMA66 and the CD-ROM in UDMA33.

Specs: Epox Socket 754 mobo, Sempron 1.6Ghz, 768MB RAM, Nvidia 410 chipset, 80GB WD IDE hardrive.

The BIOS on this board offers only one setting for UDMA..  Either AUTO or OFF.

Is there any way to force UDMA on? 

Offline wallabybob

  • Hero Member
  • *****
  • Posts: 5239
  • Karma: +11/-1
    • View Profile
Re: Hardrive stuck in PIO
« Reply #1 on: December 17, 2008, 07:49:31 am »
I'm running 1.2.1-RC4. My "disk" is a Transcend 1GB solid state modules that plugs into the motherboard IDE socket. Startup reports:


atapci0: <VIA 8235 UDMA133 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xea00-0xea0f at device 17.1 on pci0
ata0: <ATA channel 0> on atapci0
ata0: [ITHREAD]
ata1: <ATA channel 1> on atapci0
ata1: [ITHREAD]

ad0: DMA limited to UDMA33, device found non-ATA66 cable
ad0: 955MB <TRANSCEND 20071207> at ata0-master UDMA33

Looks like the driver thinks its running in UDMA33.

Offline maximilien

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Hardrive stuck in PIO
« Reply #2 on: December 23, 2008, 12:26:55 am »
Set hw.ata.ata_dma=0

for compac flash.

Refer to
>>>> Disable DMA for IDE drives
« Last Edit: December 23, 2008, 12:30:21 am by maximilien »