Netgate SG-1000 microFirewall

Author Topic: Help! Wireless AP setup - local network connection ok but no internet connection  (Read 517 times)

0 Members and 1 Guest are viewing this topic.

Offline bucks

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Hello All,

First off, I'm a PFSense newbie but with some general IT background.  I've spent a few days on forums and goolge but nothing seems to work properly. 

I have an old hp desktop that I'm using for pfsense.  Just bought a wireless desktop card (Apple Airport Atheros AR5BXB112 AR9380) and tried to setup an wireless AP on pfsense.

I've added/enabled the new wifi interface, changed the general configuration and enabled the dhcp server for the 'wifi interface'. I can connect to the new wifi network but no internet connection.  If I setup a bridge (lan-wifi) it works just fine but I do not want to bridge. 

I think I'm missing something simple but can't think of it.  Any ideas?

Here's a few screenshots with my current setup/configurations.  Please don't laugh at my setup, I have it this way for various reasons. 

Thank you in advance.   



Offline ptt

  • Hero Member
  • *****
  • Posts: 2282
  • Karma: +388/-46
    • View Profile
Add the NAT rule for your "WIFI" net... Or change the NAT to "Auto"

Offline Soyokaze

  • Full Member
  • ***
  • Posts: 174
  • Karma: +20/-2
    • View Profile
1st: kudos for providing all necessary info (including network diagram! wow!).
2nd: @ptt says it right - you don't have NAT rule for packets from your wifi network (10.20.2.0/24) through WAN interface.
Need full pfSense in a cloud? PM for details!

Offline bucks

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Thank you for your kind responses.  I have to set my NAT to 'Manual' for my vpn (assuming your referring to the Firewall-->NAT-->Outbound-->Outbound NAT Mode). 

If I understand correctly, I've added a rule to the WAN interface (see image). After that, I still have no internet connection.  I've even added the same rule (see same image) to the LAN and WIFI interface (Firewall-->Rules) as well. 

None of the IP in the WIFI range even shows up in Status-->System Logs-->Firewall. 

I'm apologize, but can you explain how to do that?  Networking is my kryptonite, but I've been learning as much as I can. 

Kind Regards





Offline johnpoz

  • Hero Member
  • *****
  • Posts: 14293
  • Karma: +1330/-193
  • Not a pfSense employee, they cannot fire me...
    • View Profile
"I have to set my NAT to 'Manual' for my vpn (assuming your referring to the Firewall-->NAT-->Outbound-->Outbound NAT Mode)."

No not really.. Hybrid would of worked that allows you to create your own special outbound nats for like vpn but auto create for your local interfaces to the internet, etc.
- An intelligent man is sometimes forced to be drunk to spend time with his fools.
- Please don't PM me for personal help
- if you want to say thanks applaud or https://www.freebsdfoundation.org/donate/
1x SG-2440 2.3.4_p1 (work)
1x 2.4.2-RELEASE on VM esxi 6.5 (home)

Offline bucks

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Thanks johnpoz for clarifying that I just followed the setup instructions on the vpn site. 

Unfortunately, I still have the same issue when I selected hybrid (and restarted pc just to be safe).  I can connect to the wifi interface but no internet still. 

Now it's on Hybrid mode, do I still need to configure rules to allow packets?

I appreciate your help. 

Kind Regards

Offline Derelict

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 9084
  • Karma: +1037/-306
    • View Profile
Duplicate the LAN pass any any rule on the WIFI interface. Change the interface and the source network to WIFI, of course.
Las Vegas, Nevada, USA
Use this diagram to describe your issue.
The pfSense Book is now available for just $24.70!
Do Not PM For Help! NO_WAN_EGRESSTM

Offline bucks

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Thanks Derelict for the info. 

That was one of the first thing I tried - I even restarted the firewall for safe measures. 

Anything else I can try?






Offline Soyokaze

  • Full Member
  • ***
  • Posts: 174
  • Karma: +20/-2
    • View Profile
Add rule on wifi interface to allow trafic from wifi network to any?
Need full pfSense in a cloud? PM for details!

Offline bucks

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
I believe that's the rule I had in there already, correct me if I'm wrong. 

What worked for me is setting the gateway to 'WAN_DHCP' instead of leaving it as default.  This is what I wanted to achieve. 

Thanks everyone for your input. 

Kind Regards

B

Offline Derelict

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 9084
  • Karma: +1037/-306
    • View Profile
That would only be necessary if that gateway is not your default gateway.
Las Vegas, Nevada, USA
Use this diagram to describe your issue.
The pfSense Book is now available for just $24.70!
Do Not PM For Help! NO_WAN_EGRESSTM

Offline bucks

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Weird, the wan is my default gateway. 

Offline Derelict

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 9084
  • Karma: +1037/-306
    • View Profile
Perhaps one of those VPN services is pushing a set of default routes.

If you don't want to route all traffic all the time out a VPN client it is probably best to check don't pull routes there and policy route just what you want out of it. Else you have to understand that the VPN is your default gateway.
Las Vegas, Nevada, USA
Use this diagram to describe your issue.
The pfSense Book is now available for just $24.70!
Do Not PM For Help! NO_WAN_EGRESSTM