Netgate SG-1000 microFirewall

Author Topic: ntopng stopping  (Read 436 times)

0 Members and 1 Guest are viewing this topic.

Offline zMaliz

  • Jr. Member
  • **
  • Posts: 46
  • Karma: +2/-0
    • View Profile
ntopng stopping
« on: August 02, 2017, 09:18:06 am »
Hi

I've noticed ntopng 0.8.8 intermittently keeps stopping.
If I restart it, it will run for a period and then the Dashboard reports it as stopped.

Can some one point me to the logs I need to be checking.
or is this a known issue ?

Thanks

Offline hescominsoon

  • Newbie
  • *
  • Posts: 21
  • Karma: +0/-0
    • View Profile
Re: ntopng stopping
« Reply #1 on: August 31, 2017, 08:38:28 pm »
we are witing for pfsense to bundle the new ntopng...i think the delay is freebsd has not made the newer version of ntopng available.

Offline doktornotor

  • Hero Member
  • *****
  • Posts: 8553
  • Karma: +956/-278
  • Not a pfSense employee, they cannot fire me...
    • View Profile
Re: ntopng stopping
« Reply #2 on: August 31, 2017, 09:20:37 pm »
It's been crashing for ages. Not sure what you are waiting for but the newer version in 2.4 seems even worse, does not even run for some people. Plus the redis junk that corrupts itself periodically. Good luck.
Do NOT PM for help!

Offline cfapress

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Re: ntopng stopping
« Reply #3 on: October 12, 2017, 11:16:54 am »
On some of my pfSense boxes I find ntopng to core dump without any clear reason. While on other boxes (with nearly identical hardware) it runs well.

I'm using it on the latest pfSense with success. On the older 2.2 branch it's hit-or-miss with core dumps.

Jason

Offline rafaelr

  • Newbie
  • *
  • Posts: 13
  • Karma: +2/-1
    • View Profile
Re: ntopng stopping
« Reply #4 on: December 03, 2017, 04:08:01 pm »
I'm reading around the forum to see if I can find a solution to a similar issue. In my pfSense 2.4.2 box ntopng 0.8.11 stops working after @12 hours and all I get in my logs is a warning:

ntopng [Lua.cpp:6479] WARNING: Script failure [/usr/local/share/ntopng/scripts/lua/index.lua][/usr/local/share/ntopng/scripts/lua/index.lua:42: attempt to concatenate global 'ifname' (a nil value)]


I then notice:

ntopng      [mongoose.c:4515] ERROR: set_ports_option: cannot bind to 3000s: Address already in use
ntopng      [HTTPserver.cpp:806] ERROR: Unable to start HTTP server (IPv4) on ports 3000s

So, basically it seems the service just hangs. I have to manually restart the service to bring it back and obviously all the data logging from the time it crashed up until the service is manually restarted is missing.


Offline rafaelr

  • Newbie
  • *
  • Posts: 13
  • Karma: +2/-1
    • View Profile
Re: ntopng stopping
« Reply #5 on: December 05, 2017, 11:27:57 am »
I no longer see the service crashing at least for now.

I have disabled all data retention and also the following alert:

Enable Hosts Malware Blacklists
Enable alerts generated by traffic sent/received by malware-marked hosts. Overnight new blacklist rules are refreshed.

I'm letting it run for few more days and then I will enable data retention one at a time and make sure it doesn't crash... I'm under the impression the crash was caused by Enable Hosts Malware Blacklists.