pfSense Gold Subscription

Author Topic: Out of subnet routing... (Failover IP setup)  (Read 85 times)

0 Members and 1 Guest are viewing this topic.

Offline FearNaBoinne

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Out of subnet routing... (Failover IP setup)
« on: November 14, 2017, 01:23:53 pm »
My provider put me up with a somewhat unusual, but otherwise functional routing config known as a failover IP...

I have an ESXi with pfSense on it (amongst other things, obviously), and two IP's (I'll be using different IP's, but for the sake of discussion, the setup is working identically):

Main IP (on ESXi mgmt)
195.195.195.195/24
Def GW:
195.195.195.1

Failover IP (on pfSense VM WAN NIC):
195.195.110.111/32  (!!!!)
No default gateway for this IP...

To make it work from the pfSense I had to manually perform:
route add -net 195.195.195.0/24 -link -iface em0
route add default 195.195.195.1

This works fine, I can access the pfSense WebGUI, it can access the internet, etc.

However there are a few challenges I do not know how to solve:
1) Getting the above two routes to stick (so they don't get deleted on every reload)
2) Getting pfSense to accept 195.195.195.1 as a valid gateway, because the UI keeps saying it's not in any interface's network

Any suggestions appreciated!
« Last Edit: November 14, 2017, 02:00:58 pm by FearNaBoinne »

Offline FearNaBoinne

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: Out of subnet routing... (Failover IP setup)
« Reply #1 on: November 14, 2017, 02:11:08 pm »
After more searching (I already searched before posting here) I pretty much found most of the answer here:
https://forum.pfsense.org/index.php?topic=79141.msg431581#msg431581