pfSense English Support > 2.4 Development Snapshots

Problems & Questions

(1/3) > >>

Was running the last stable 2.3.4 RC I believe and it was very stable minus a few issues. Updated to the latest 2.4.0. release and had a few issues that I wanted some feedback on.

- Date & Time: The system does not reflect the correct time even though the computer time is 100% accurate. Changing the various time zones of America/XXX to CST6DST changes the time but its still incorrect. Reading the forums this has been an ongoing issue which I haven't read about a solution.

Also rebooting the system doesn't seem to make any difference. Restarting the service and adding in multiple NTP servers also does nothing.

- Reboot: The system does not seem to want to reboot and come back up gracefully. This is another on going issue which I've read in these forums with no solution. The system will just count down endlessly and never complete. The only recourse is to complete a hard shut down by pressing the power button.

This was never an issue on 2.3.4 final . .

I'm seeing this on a brand new system:

Intel(R) Atom(TM) CPU E3845 @ 1.91GHz
4 CPUs: 1 package(s) x 4 core(s)
AES-NI CPU Crypto: Yes (active)

- Services: When the system is rebooted almost none of the services are coming back on line?!?! In some cases I have to select the Start Services. While others do nothing and the only method I've found is to actually select the reload option. Which brings the packages back on line and active.

- Traffic Graph: This operated just fine in 2.3.4 final now under 2.4.0 nothing appears in the charts?!?! Removing it and adding it back does nothing to make data show up.

- Performance: Like some here who have taken the time to report issues. This new build is slower in doing basic tasks from tabbing over to one option to the next. Adding a package will either declare a fault of some kind or just never appears. Items in the dashboard don't seem to be updating for what ever reason??

I know there has been an incredible effort to bring 2.4.0 to market ~ but there is something wrong here. I'm going to take a wild guess some of the packages are not compatible or there has been a break in compatibility because watching the install process I see lots of *This package is being removed blah blah and replaced with X.

I don't ever see X actually being inserted into the system??? So it begs to ask the question if the system says its going to remove something and replace it with a better, older, newer version, where is it??

Any insight would be greatly appreciated as I love the software and the incredible features it provides to the end users.

Thank You

Afaik going from 2.3.x to 2.4 no packages are removed.. (yes freeradius 2.x is replaced by 3.x or something.. and probably some others..)

Timezones has always been troublesome, the more generic ones usually work fine afaik, but those defined by city have their share of issues.. Best i can advice is try a few..
b.t.w. what exactly do you mean with 'its incorrect' is it off by an hour? or something else?

Reboot whats shown on console? Is there perhaps a bios update for your machine?

What services are we talking about? whats in the systemlogs or specific logs for the services where applicable?

Traffic graphs.. tried a different browser? or clearing cache maybe some javascript that aint refreshing..? Does status/trafficgraph screen work?

Performance, is any background process using a lot of cpu?

Packages that wont install, what error is shown? You do have working dns and a default route on pfSense? Perhaps prefering IPv4 might help.

If the system says its going to replace something 'that' is what should happen.. unless of course there is an error is there?
What package did you try to install? What happens when you install the same package from console/ssh?

Hello PiBa,

I'll start with what should be the easiest problem ~ Time

If I select the correct location with my city in America the time is off by (approx) 5~12 hours. I don't recall exactly because I tried so many locations which were close to my area to see if there was a difference. I then selected the CST6DST because that was pretty generic and should have put me for sure within the hour.

Nope . . .

I literally had to select etc/GMT +0 for the *pfSense current time* to reflect the correct time.  >:(

My time zone should be Central -6 DST . . .

If you review the attachment at the upper left using the make belief time zone I placed myself in the time and date is correct. If you look at the NTP time below that is the time the system believes I'm using. For what ever reason(s) various programs seem to either reflect the make belief time I used to make it happen.

Or they will actually display times that make no sense or state the time and date are in the past?!?!

Come on its 2017 time keeping can't seriously be that difficult given all the resources and automated systems in place!!  >:(

- The pfSense computer that hosts the software *BIOS* time is 100% correct and reflects reality.
- Every computer system in my home also reflect real world time, date, DST etc.
- Yet the pfSense software doesn't no matter what I do to compensate or correct for it.

I've scanned the forums dating back five years and there are dozens of threads about this so this is something that has never been fixed. At this point I can't trust the logs to provide me accurate details of events because they are off from 5~12 hours in the past or future. If I can't correct the time issue what's the point of moving forward with the rest of the problem(s)?!?!?

Did you try this : use another browser / device that you didn't use before to connect to the GUI / pfSense ....

Have you selected an alternate time server?

I'm using a local one in the UK, and I select Europe London. It gets it perfectly and knows it's also BST.


[0] Message Index

[#] Next page

Go to full version