Netgate SG-1000 microFirewall

Author Topic: 2.4.0 does not boot without Monitor  (Read 1546 times)

0 Members and 1 Guest are viewing this topic.

Offline TobyX

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
2.4.0 does not boot without Monitor
« on: October 14, 2017, 03:44:01 am »
Hi,
I know; there are already reported but relating to that top. However, I suggest that this is a new bug:

I recently updated to 2.4.0 and from this point I got the following problem:
Pfsense only boots in case of a plugged in (HDMI) monitor.
Whenever I try to start the machine without a monitor the system seems to remain in a "pre-boot" state.
I also waited for a couple of minutes, but it does not work.
This problem did not arise until the update  :-/

Unfortunately, I also lost a previous backup...  :-X ;D

Regards from Germany

Toby

Offline Derelict

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 9824
  • Karma: +1111/-311
    • View Profile
Re: 2.4.0 does not boot without Monitor
« Reply #1 on: October 14, 2017, 03:59:50 am »
What hardware?
Las Vegas, Nevada, USA
Use this diagram to describe your issue.
The pfSense Book is now available for just $24.70!
Do Not PM For Help! NO_WAN_EGRESSTM

marjohh

  • Guest
Re: 2.4.0 does not boot without Monitor
« Reply #2 on: October 14, 2017, 04:00:34 am »
Can you post hardware specs and other info?

It's a bit like saying my car won't start - what's wrong with it!

Offline TobyX

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: 2.4.0 does not boot without Monitor
« Reply #3 on: October 14, 2017, 04:27:16 am »
Oh, sorry . Forgot this.

Intel(R) Core(TM) i5-6600 CPU. I use a shuttle xpc dh170.

Quote
Intel(R) Core(TM) i5-6600 CPU @ 3.30GHz

Current: 3300 MHz, Max: 3301 MHz

4 CPUs: 1 package(s) x 4 core(s)

AES-NI CPU Crypto: Yes (active)
 

Bios is up to date.

Do you need any more information?

Offline Derelict

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 9824
  • Karma: +1111/-311
    • View Profile
Re: 2.4.0 does not boot without Monitor
« Reply #4 on: October 14, 2017, 04:40:38 am »
Unfortunately, that will probably need to be dealt with on the bios/uefi side. What did you upgrade from? If 2.3.4 that did not support UEFI at all. Perhaps there's a "legacy bios mode" or something on that hardware that might fix that. pfSense/FreeBSD does not care if there is a monitor connected or not, as long as there is a console presented it can attach to.
Las Vegas, Nevada, USA
Use this diagram to describe your issue.
The pfSense Book is now available for just $24.70!
Do Not PM For Help! NO_WAN_EGRESSTM

Offline TobyX

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: 2.4.0 does not boot without Monitor
« Reply #5 on: October 14, 2017, 04:59:26 am »
the previews version was 2.3.4-p1
So, you suggest that it is a hardware problem of my device?
But why did this problem arise recently (and not for the 2.3.4 version)?

Accordingly, UEFI should be enabled/disabled?

 (sorry, I still just don't it)

Offline Derelict

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 9824
  • Karma: +1111/-311
    • View Profile
Re: 2.4.0 does not boot without Monitor
« Reply #6 on: October 14, 2017, 05:11:17 am »
FreeBSD 11.1 supports UEFI. FreeBSD 10.3 did not.

It is really hard to say. If you can't boot now (without a monitor connected) I would suggest trying to disable UEFI and trying again.
Las Vegas, Nevada, USA
Use this diagram to describe your issue.
The pfSense Book is now available for just $24.70!
Do Not PM For Help! NO_WAN_EGRESSTM

Offline TobyX

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: 2.4.0 does not boot without Monitor
« Reply #7 on: October 14, 2017, 05:55:22 am »
okay!
This did not lead to a solution.

Mayby, me description was a bit missleading, because the machine itself boots, but not pfsense.

I try to describe the problem in detail:
After the update from 2.3.4-p1 to 2.4.0 the system only starts in case of a plugged-in monitor.
In case of an unplugged monitor the system does not start or does not start pfsense (the machine itself starts!)
Accordingly, I can not access pfsense to get any logs and other info (plugging in the the monitor has not effect, of course)

In this case, I have to plugin the monitor and re-boot the machine. Now, pfsense boots and everything works fine.

To sum up: the machine starts, but not pfsense, in the case of an unplugged monitor.

According to UEFI:
I disabled it, but then I get the message that there is no boot option.

Offline Derelict

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 9824
  • Karma: +1111/-311
    • View Profile
Re: 2.4.0 does not boot without Monitor
« Reply #8 on: October 14, 2017, 06:02:04 am »
Then pfSense/FreeBSD does not have a console to attach to. It is up to the host system to present one.

You are trying to use a system designed for digital signage as a firewall. It is going to be difficult to diagnose if the only available output is to the console and you are having trouble booting without a console.

You might try seeing if it will boot if you change the console to serial in System > Advanced.
Las Vegas, Nevada, USA
Use this diagram to describe your issue.
The pfSense Book is now available for just $24.70!
Do Not PM For Help! NO_WAN_EGRESSTM

Offline TobyX

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: 2.4.0 does not boot without Monitor
« Reply #9 on: October 14, 2017, 06:30:54 am »
okay...

This is the actual setup... and it does not work

https://picload.org/view/dgipwrpl/options.png.html


Offline Derelict

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 9824
  • Karma: +1111/-311
    • View Profile
Re: 2.4.0 does not boot without Monitor
« Reply #10 on: October 14, 2017, 06:38:11 am »
Sorry. That's all I can suggest. Maybe someone else will chime in with other suggestions on that hardware.
Las Vegas, Nevada, USA
Use this diagram to describe your issue.
The pfSense Book is now available for just $24.70!
Do Not PM For Help! NO_WAN_EGRESSTM

Offline TobyX

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: 2.4.0 does not boot without Monitor
« Reply #11 on: October 14, 2017, 08:20:39 am »
Ok... solved it.
There was a very recent (yesterday) bios update.
Now it works perfect.

However, many thanks for assisting me.


marjohh

  • Guest
Re: 2.4.0 does not boot without Monitor
« Reply #12 on: October 14, 2017, 08:39:01 am »
So not a bug in pfSense then... hmm, how unusual... not. ::)

Offline Bleupomme

  • Newbie
  • *
  • Posts: 5
  • Karma: +1/-0
    • View Profile
Re: 2.4.0 does not boot without Monitor
« Reply #13 on: October 15, 2017, 04:04:04 pm »
This just happened to me too on a shuttle XPC:
 - Updated the BIOS, but this did not solve the problem
 - Brute forced BIOS settings
-> by disabling the Serial ports the computer boots normally

Does pfsense 2.4 default to Serial and wait for some sort of connection when there is no monitor?

My two cents...

marjohh

  • Guest
Re: 2.4.0 does not boot without Monitor
« Reply #14 on: October 15, 2017, 04:07:20 pm »
No, nothing to do with pfSense.