The pfSense Store

Author Topic: Port Forwarding not working while routing traffic over OpenVPN interface  (Read 133 times)

0 Members and 1 Guest are viewing this topic.

Offline jacobsmith

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
I recently setup a OpenVPN connection to route all traffic over that VPN which is working. Prior to setting that up I had port forwarding on 22 and 80 to accept incoming WAN connections. I also had firewall rules to allow 22 and 80 with port forwarding.

Once the new routing was set up, inbound traffic on 22+80 stopped working. I tried setting the gateway as WAN in the firewall rules advanced options, but did not seem to work.

I'm running pfsense 2.4.0.

Any ideas what to look at?
« Last Edit: October 24, 2017, 11:39:30 pm by jacobsmith »

Offline mikeisfly

  • Sr. Member
  • ****
  • Posts: 466
  • Karma: +6/-0
    • View Profile
Re: Port Forwarding not working while routing traffic over OpenVPN interface
« Reply #1 on: October 31, 2017, 04:14:54 am »
What ip(s) are port 80 and 22 being forwarded to? You would need to setup a superseding rule to make the gateway of that IP address be pfsense's default gateway. I suspect the IP address is pfsense's LAN IP so just make the rule and the mask would be /32 and move it ahead of the rule that directs all the other traffic over the VPN.

By the way if I'm right about the LAN IP I suggest you use https.