Netgate Store

Author Topic: 2.3.4-RELEASE-p1 => 2.4.0 "system update failed" please help!  (Read 3294 times)

0 Members and 1 Guest are viewing this topic.

Offline chudak

  • Full Member
  • ***
  • Posts: 135
  • Karma: +2/-3
    • View Profile
2.3.4-RELEASE-p1 => 2.4.0 "system update failed" please help!
« on: October 24, 2017, 03:29:57 pm »
Using Web UI got "system update failed" error
"pkg-static: cached package php56-5.6.31: size mismatch, cannot continue
Failed
Failed"

See full stack here https://pastebin.com/LXZ6jEJJ

Any help appreciated!

Offline kejianshi

  • Hero Member
  • *****
  • Posts: 4971
  • Karma: +199/-43
  • Debugging...
    • View Profile
Re: 2.3.4-RELEASE-p1 => 2.4.0 "system update failed" please help!
« Reply #1 on: October 24, 2017, 03:36:39 pm »
Did you try it 2x?

Got the same error, reboot and tried again and it was fine.

Offline chudak

  • Full Member
  • ***
  • Posts: 135
  • Karma: +2/-3
    • View Profile
Re: 2.3.4-RELEASE-p1 => 2.4.0 "system update failed" please help!
« Reply #2 on: October 24, 2017, 03:49:16 pm »
Did you try it 2x?

Got the same error, reboot and tried again and it was fine.

2x did not help, but reboot did !
Upgrading as we speak ....

And after a couple of reboots, my version say 2.4.1 and all packages seem updated

So far see no regressions.
« Last Edit: October 24, 2017, 04:23:46 pm by chudak »

Offline darklogic

  • Full Member
  • ***
  • Posts: 178
  • Karma: +2/-0
    • View Profile
Re: 2.3.4-RELEASE-p1 => 2.4.0 "system update failed" please help!
« Reply #3 on: October 25, 2017, 12:10:26 pm »
My system will not show an update availble. I'm currently on 2.3.4 RELEASE p1 i386. I believe I saw in a form elsewhere that you can't upgrade from x86/i386 to 2.4 or 2.4.1 as it is no longer being supported. Is this true? Do I have to do a complete fresh install on the 2.4.1? Will by backup config from 2.3.4p1 i386 work?

Thanks,

Matt

Offline Grimson

  • Sr. Member
  • ****
  • Posts: 475
  • Karma: +68/-10
    • View Profile
Re: 2.3.4-RELEASE-p1 => 2.4.0 "system update failed" please help!
« Reply #4 on: October 25, 2017, 12:26:41 pm »
I believe I saw in a form elsewhere that you can't upgrade from x86/i386 to 2.4 or 2.4.1 as it is no longer being supported. Is this true?

https://forum.pfsense.org/index.php?topic=121255.0

BlueKobold

  • Guest
Re: 2.3.4-RELEASE-p1 => 2.4.0 "system update failed" please help!
« Reply #5 on: October 25, 2017, 01:37:04 pm »
Quote
My system will not show an update availble.
Ok, thtis can be based on the not availability of the 32Bit OS based pfSense code. Since version 2.4.0/2.4.1
the x86 pfSense is only 64Bit based.

Quote
I'm currently on 2.3.4 RELEASE p1 i386.
- If this is installed on a 32Bit hardware system, you need to get new hardware to install pfSense 2.4.0/2.4.1 on it
As mentioned above, since version 2.4.x pfSense is only 64Bit based and without any NanoBSD support!
- If this is installed on a 64Bit hardware capable to run 32Bit software too, you might be only changing the OS
Do a fresh and full install and play back the configuration backup.xml

Quote
I believe I saw in a form elsewhere that you can't upgrade from x86/i386 to 2.4 or 2.4.1 as it is no longer being supported.

Hardware based it is likes you say, software only based it might be able to realize without any issues.
Many users are installing also on 64Bit their beloved 32Bit OS and it might be running some faster then
they though, but now you will be "pressed" or better forced to install on that 64Bit hardware also 64Bit software
(pfSense), because of the lag of 31Bit support since the version 2.4.x

Quote
Is this true?
If you own 32Bit hardware you canīt upgrade to 2.4.x, but if this is 64Bit hardware you can do it with ease!


Quote
Do I have to do a complete fresh install on the 2.4.1? Will by backup config from 2.3.4p1 i386 work?
a.) Yes you should do a fresh and full install of pfSense 64Bit.
b.) Yes it will be working without any issues like before also too. 


- 32Bit OS support is gone, by getting instead of this ARM support and ARM 64Bit support its on his way too!!!
- NanoBSD is gone completely because the version 3.0 will be totally written new from the "scratch"

If the version 3.0 is written and the ARM64 change is done well too, it might be happen, or in other words it could
be that the NanoBSD is coming at one day, but not yet and not before both systems named above are fully done.
« Last Edit: October 25, 2017, 01:41:10 pm by BlueKobold »

Offline darklogic

  • Full Member
  • ***
  • Posts: 178
  • Karma: +2/-0
    • View Profile
Re: 2.3.4-RELEASE-p1 => 2.4.0 "system update failed" please help!
« Reply #6 on: October 27, 2017, 12:52:04 pm »
With that all being said will my config backup work on a fresh install to a 64bit system when the config was based from x86 i386?

Offline kejianshi

  • Hero Member
  • *****
  • Posts: 4971
  • Karma: +199/-43
  • Debugging...
    • View Profile
Re: 2.3.4-RELEASE-p1 => 2.4.0 "system update failed" please help!
« Reply #7 on: October 27, 2017, 12:59:13 pm »
Yep - minus the rdd data.  At least it always has for me.

BlueKobold

  • Guest
Re: 2.3.4-RELEASE-p1 => 2.4.0 "system update failed" please help!
« Reply #8 on: October 28, 2017, 11:14:27 pm »
Quote
With that all being said will my config backup work on a fresh install to a 64bit system when the config was based from x86 i386?
Be sure it will be running well and working and if not, I mean if something goes wrong for you, you may be also
able to reinstall the older verison and play it back there, if needed.

Offline darklogic

  • Full Member
  • ***
  • Posts: 178
  • Karma: +2/-0
    • View Profile
Re: 2.3.4-RELEASE-p1 => 2.4.0 "system update failed" please help!
« Reply #9 on: October 31, 2017, 02:19:42 pm »
Ok, I will make sure I have an older copy just in case I have to revert back. My config is rather extensive. Thanks for the feedback guys.

Offline tlm4594

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: 2.3.4-RELEASE-p1 => 2.4.0 "system update failed" please help!
« Reply #10 on: November 19, 2017, 01:04:22 pm »
I'm getting no where with updating. I believe I have 64bit hardware-- but I still get "System Update Failed".

I'm on version:
2.3.4-RELEASE-p1 (amd64)
built on Fri Jul 14 14:52:43 CDT 2017
FreeBSD 10.3-RELEASE-p19

My hardware is:
Platform   pfSense
CPU Type   Intel(R) Xeon(R) CPU X3470 @ 2.93GHz
Current: 2933 MHz, Max: 2934 MHz
8 CPUs: 1 package(s) x 4 core(s) x 2 SMT threads
8GB RAM

Any ideas? I'm using hardware I bought online, and from my research this CPU is 64bit


BlueKobold

  • Guest
Re: 2.3.4-RELEASE-p1 => 2.4.0 "system update failed" please help!
« Reply #11 on: November 19, 2017, 01:40:41 pm »
Quote
I'm getting no where with updating. I believe I have 64bit hardware-- but I still get "System Update Failed".
Was this over the webgui or over a memstick image on an USB pen drive? And when USB pen drive what image
you were using for this update?

Quote
CPU Type   Intel(R) Xeon(R) CPU X3470 @ 2.93GHz
It is a real 64Bit CPU!

Quote
Any ideas? I'm using hardware I bought online, and from my research this CPU is 64bit
If you will be able to get the amd64 memstick serial image to download, I woudl do so and then you might be
preparing an USB pen drive for the upgrade. Save your config backup image and then do a fresh and full install.
Play back the config backup and see what is going on.

Offline kejianshi

  • Hero Member
  • *****
  • Posts: 4971
  • Karma: +199/-43
  • Debugging...
    • View Profile
Re: 2.3.4-RELEASE-p1 => 2.4.0 "system update failed" please help!
« Reply #12 on: November 19, 2017, 02:33:54 pm »
Just reinstall...  You can spend forever on this. 

Offline tlm4594

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: 2.3.4-RELEASE-p1 => 2.4.0 "system update failed" please help!
« Reply #13 on: November 19, 2017, 02:54:17 pm »
Just reinstall...  You can spend forever on this.

Is there a quick way to re-install via the web gui? I have my box mounted in a peculiar spot and getting a monitor, keyboard and mouse would be a huge pain.

Thanks

Offline kejianshi

  • Hero Member
  • *****
  • Posts: 4971
  • Karma: +199/-43
  • Debugging...
    • View Profile
Re: 2.3.4-RELEASE-p1 => 2.4.0 "system update failed" please help!
« Reply #14 on: November 19, 2017, 03:31:30 pm »
I thought you already had a huge pain?  Sorry.  I have no easy answer.