The pfSense Store

Author Topic: How do I set up my WAN for an ISP that uses L2TP?  (Read 115 times)

0 Members and 1 Guest are viewing this topic.

Offline ninjai

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
How do I set up my WAN for an ISP that uses L2TP?
« on: November 01, 2017, 09:38:11 pm »
Here in Canada we have a few big providers that ran all the cable (Telus, Shaw, etc), then we have all these little ISP's that piggy back off them.

My ISP just switched me over to Shaw (their network over Shaw coax) and they've given me a "frame IP", "frame routed IPs" and a gateway.

I have a static IP with this apparently.

My frame IP is a class b static (172.16.0.0/16), and my frame routed IPs and gateway are publicly routable IP's.

I'm at a complete loss on how to set this up in pfSense.  I was told to set my WAN to DHCP, which works, and now I get a Shaw IP address and internet connectivity, but the next step is to set up L2TP with these frame IPs or whatever.  This frame business is all jargon to me.

Has anyone ever dealt with this in pfSense before?  How do I set it up?  This is a sample script they give you for a microtik router:

/interface bridge add name=Lan
/interface bridge port add interface=ether2 bridge=Lan
/interface bridge port add interface=ether3 bridge=Lan
/interface bridge port add interface=ether4 bridge=Lan
/interface bridge port add interface=ether5 bridge=Lan
!
/ip dhcp-client add interface=ether1 add-default-route=no disabled=no
ip route add dst-address=209.205.90.194/32 gateway=ether1

!
/ip address add address=208.110.114.41/29 interface=Lan disabled=no
/interface l2tp-client add name=VPN user= xxxx.vpn@pppoe.net
password= xxxx connect-to=209.205.90.194 add-default-route=yes
profile=default disabled=no

To me it looks like they're basically just leaving WAN as DHCP and creating a L2TP client interface and routing all traffic through the L2TP interface instead of the WAN, but I could be wrong.  I can't find any way to do this in the pfsense GUI.

These are the instructions they provide: http://d1p0a2stwfwzqk.cloudfront.net/pdf/static-l2tp.pdf

Anyone have any answers on this?

Thanks!
« Last Edit: November 01, 2017, 09:51:55 pm by ninjai »

Offline thehammer86

  • Jr. Member
  • **
  • Posts: 61
  • Karma: +1/-0
    • View Profile
Re: How do I set up my WAN for an ISP that uses L2TP?
« Reply #1 on: November 03, 2017, 09:20:59 am »
They're using weird lingo.

I have a subnet of IPs routed to me as well.

Have many ports do you have on your pfSense box?

Also, I don't think anything is coming in over L2TP.