Netgate SG-1000 microFirewall

Author Topic: The Website Declined to show this webpage  (Read 225 times)

0 Members and 1 Guest are viewing this topic.

Offline randyhaley

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
The Website Declined to show this webpage
« on: November 02, 2017, 03:26:47 pm »
I get this error when trying to login to the pfSense GUI the first time.

I am using https

Any help would be appreciated. I have rebooted and reset using command 11.

Offline low_key

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: The Website Declined to show this webpage
« Reply #1 on: November 04, 2017, 04:37:04 pm »
I ran into the same issue when setting this up today.  I think it has something to do with the SSL. Here's what fixed it for me:

From the main Pfsense Menu option Press 8 to enter the shell

Once in the shell type viconfig

Search for the section of the config labeled webgui and change the protocol from https to http 

Once this is done restart pfsense and use the web broswer to navigate to Pfsense using the HTTP protocol instead of HTTPS.

Make sure also that you are accessing pfsense from a vm or system on the same network :)

Offline JorgeOliveira

  • Full Member
  • ***
  • Posts: 153
  • Karma: +24/-1
  • May the Triforce be with you...
    • View Profile
Re: The Website Declined to show this webpage
« Reply #2 on: November 04, 2017, 04:40:24 pm »
Which browser are you using? All recent version of Firefox and Google Chrome should work.

Are you using a proxy?
My views have absolutely no warranty express or implied. Always do your own research.

Offline low_key

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: The Website Declined to show this webpage
« Reply #3 on: November 04, 2017, 04:47:13 pm »
Ah ok I was actually using an older version of IE that was installed on the VM by default. 

Once I configure everything I'll install a more updated browser, re-enable HTTPS and test again.  Thanks

Offline randyhaley

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: The Website Declined to show this webpage
« Reply #4 on: November 07, 2017, 02:09:58 pm »
I thought that was the issue as well. I was using IE 8. I updated the VM and it installed IE 11. It works half the time and gives the error the other half.

I will try chrome or firefox to see if it works. It needs to get fixed however if that is the case.

Offline randyhaley

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: The Website Declined to show this webpage
« Reply #5 on: November 07, 2017, 02:26:32 pm »
Well Chrome worked once. The next time I tried it told me I don't have permission to view this page.

Offline randyhaley

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: The Website Declined to show this webpage
« Reply #6 on: November 07, 2017, 04:28:18 pm »
Ok, I solved the issue.

When you are using VM's, be sure the network interface on your host computer did not assign the same address that you assigned for the LAN address of your pfSense firewall. I assigned the network range on VMnet5 to 172.16.1.0/24. Using that information, VMWare assigned the first available IP 172.16.1.1 to the host VMnet5 interface. Not knowing this, I assigned the LAN interface of my pfSense to 172.16.1.1.

I changed the static IP of my host VMnet5 interface to 172.16.1.2 and now I can connect to the WebGUI!