The pfSense Store

Author Topic: Net/IPv6.php failed and broken package updater  (Read 244 times)

0 Members and 1 Guest are viewing this topic.

Offline darkgamer120

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Net/IPv6.php failed and broken package updater
« on: November 02, 2017, 03:53:34 pm »
Hello, I have an SG-1000 from Netgate. I was trying to remove the extra package bind from my SG-1000 as I use Unbound and it was at the point of removing stale packages or something and it took forever so I clicked off of it. Oops. Now any site in the web navigator has lovely PHP errors all over it. Example:
Warning: require_once(Net/IPv6.php): failed to open stream: No such file or directory in /etc/inc/config.inc on line 51 Fatal error: require_once(): Failed opening required 'Net/IPv6.php' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg:/usr/local/www/classes:/usr/local/www/classes/Form:/usr/local/share/pear') in /etc/inc/config.inc on line 51 PHP ERROR: Type: 64, File: /etc/inc/config.inc, Line: 51, Message: require_once(): Failed opening required 'Net/IPv6.php' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg:/usr/local/www/classes:/usr/local/www/classes/Form:/usr/local/share/pear') Warning: fopen(): Filename cannot be empty in /etc/inc/notices.inc on line 72 Fatal error: Call to undefined function gettext() in /etc/inc/notices.inc on line 74

So I tried restarting the web navigator and php-fpm, yeah spits out a shit ton of errors there too.
Enter an option: 11


Warning: require_once(Net/IPv6.php): failed to open stream: No such file or directory in /etc/inc/config.inc on line 51

Fatal error: require_once(): Failed opening required 'Net/IPv6.php' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg:/usr/local/www/classes:/usr/local/www/classes/Form:/usr/local/share/pear') in /etc/inc/config.inc on line 51

Warning: require_once(Net/IPv6.php): failed to open stream: No such file or directory in /etc/inc/config.inc on line 51

Fatal error: require_once(): Failed opening required 'Net/IPv6.php' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg:/usr/local/www/classes:/usr/local/www/classes/Form:/usr/local/share/pear') in /etc/inc/config.inc on line 51


and the PHP-FPM part,
Enter an option: 16

>>> Killing check_reload_status
>>> Killing php-fpm
>>> Starting php-fpm
>>> Starting check_reload_status
nice: /usr/local/sbin/check_reload_status: No such file or directory

Warning: require_once(Net/IPv6.php): failed to open stream: No such file or directory in /etc/inc/config.inc on line 51

Fatal error: require_once(): Failed opening required 'Net/IPv6.php' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg:/usr/local/www/classes:/usr/local/www/classes/Form:/usr/local/share/pear') in /etc/inc/config.inc on line 51


so I was like fuck so I did some Googling and it says to do pkg update -f to re-install all packages, we got a problem there too. :(
2.4.0-BETA][admin@archer.athome]/root: pkg update -f
pkg: Unable to open '/usr/local/etc/pkg/repos//pfSense.conf':No such file or directory
No active remote repositories configured.

I even tried to upgrade to the latest stable 2.4.x version, as I'm still on a snapshotted 2.4-BETA,
Enter an option: 13

/bin/sh: cannot open /usr/local/sbin/pfSense-upgrade: No such file or directory

Warning: require_once(Net/IPv6.php): failed to open stream: No such file or directory in /etc/inc/config.inc on line 51

Fatal error: require_once(): Failed opening required 'Net/IPv6.php' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg:/usr/local/www/classes:/usr/local/www/classes/Form:/usr/local/share/pear') in /etc/inc/config.inc on line 51


Please help me :'(   >:(

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 21312
  • Karma: +1423/-26
    • View Profile
Re: Net/IPv6.php failed and broken package updater
« Reply #1 on: November 09, 2017, 01:52:24 pm »
Your fastest and safest course of action would be to reinstall using the recovery image. You can find a link to that by logging into the portal.
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline darkgamer120

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Net/IPv6.php failed and broken package updater
« Reply #2 on: November 10, 2017, 03:35:57 pm »
Alright, i figured as much.  :-\

Thanks.  8)