The pfSense Store

Author Topic: Captive Portal Problem V 2.4.0  (Read 416 times)

0 Members and 1 Guest are viewing this topic.

Offline awahbi

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Captive Portal Problem V 2.4.0
« on: November 05, 2017, 01:52:16 am »
Dear All,

After I upgraded the pfsense to version 2.4.0; a lot of problems appeared. The main issue was with the captive portal, when I try to block someone or force a traffic shaping process per the MAC address, it does not work at all.

A system log message appears :

/services_captiveportal_mac_edit.php: The command '/sbin/ipfw -q /tmp/oleemployees_macedit59feb71c4b804_tmp' returned exit code '65', the output was 'Line 1: Table _pipe_mac does not exist'

And

/services_captiveportal_mac.php: The command '/sbin/ipfw -q /tmp/olabs_employees_mac59fb1642220dc_tmp' returned exit code '65', the output was 'Line 1: Table _pipe_mac does not exist'


I tried to upgrade to 2.4.1, but still the same problem
Kindly help.

Offline seanpearman

  • Newbie
  • *
  • Posts: 11
  • Karma: +1/-0
    • View Profile
Re: Captive Portal Problem V 2.4.0
« Reply #1 on: November 08, 2017, 02:57:31 pm »
I think there's a known issue with this. https://redmine.pfsense.org/issues/7813

Offline Gertjan

  • Hero Member
  • *****
  • Posts: 2169
  • Karma: +166/-9
    • View Profile
Re: Captive Portal Problem V 2.4.0
« Reply #2 on: November 09, 2017, 09:04:54 am »
I think there's a known issue with this. https://redmine.pfsense.org/issues/7813
The issue was solved with 2.4.0 (and if it wasn't, 2.4.1 will deal with it).

The Default download (Kbit/s) (and upload) setting works - it works for me (using 2.4.1 - I do not keep old versions).

Offline awahbi

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Captive Portal Problem V 2.4.0
« Reply #3 on: November 12, 2017, 12:47:49 am »
Dears,

Thanks for your reply.

I am already on version 2.4.1; and the situation is the same.

How can I get rid of the old versions?

Shall I make a fresh installation of 2.4.1 then restore the configuration?

Offline Gertjan

  • Hero Member
  • *****
  • Posts: 2169
  • Karma: +166/-9
    • View Profile
Re: Captive Portal Problem V 2.4.0
« Reply #4 on: November 12, 2017, 05:31:21 am »
How can I get rid of the old versions?
How ?
An update overwrite all old files - removes stales (unused files).
It's like a Windows PC : when upgrading from Windos 7 to 10, nothings is left from "7".

Shall I make a fresh installation of 2.4.1 then restore the configuration?
Think about this :
YOUR copy of pfSense - and mine, are THE SAME.
The only thing that is different is ... the setup (and of course, packages that can break native behavior).
I'm using a plain vanilla setup, my MAC limiter for the captive portal works. I'm using the built in User Manger - no Radius, No squid - no nothing else.

You can try this :
Re install.
Make the captive portal work with built in login page and a User Manger user.
Set the MAC limiter on the captive portal setup page.
Test - login and see that it works.
Now, add you other settings one by one.
As soon as the MAC limiting doesn't work anymore you know where you can find the issue  - and report back.