Netgate m1n1wall

Author Topic: Atheros/Attansic L2 FastEthernet support  (Read 8663 times)

0 Members and 1 Guest are viewing this topic.

Offline ftcsm

  • Newbie
  • *
  • Posts: 9
    • View Profile
Atheros/Attansic L2 FastEthernet support
« on: January 30, 2009, 07:02:38 pm »
I have received some computers to install pfSense and some of them are based on ASUS P5GC-MX, which has a Attansic (now Atheros) L2 NIC. Seems PC-BSD already has support for it (from google search) and there are some incomplete posts on forums that say FREEBSD 7.1 would have it too.

Is there any way of using this onboard NIC with pfSense 1.2.2 or greater? I really need to use that NIC, need 3 interfaces and there are only 2 PCI slots, already filled with realtek 8139 NICs.

Thanks in advance for your attention,

Flavio
Brazil

Offline wallabybob

  • Hero Member
  • *****
  • Posts: 5262
    • View Profile
Re: Atheros/Attansic L2 FastEthernet support
« Reply #1 on: January 31, 2009, 01:00:06 am »
The release notes for FreeBSD 7.1 (see http://www.freebsd.org/releases/7.1R/relnotes.html says
Quote
The ale(4) driver has been added to provide support for Atheros AR8121/AR8113/AR8114 Gigabit/Fast Ethernet controllers. This driver is not enabled in GENERIC kernels for this release.

I don't know if you NIC is one of those. The testing version of pfSense 1.2.3 is based on FreeBSD 7.1. Some one a bit better acquainted with the pfSense kernel configuration file than I am would need to comment on whether the ale driver is included in the 1.2.3 kernel. If ale driver isn't included a request to one of the pfSense developers fairly has a high likelihood of getting it included in a build soon.


Offline ftcsm

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Atheros/Attansic L2 FastEthernet support
« Reply #2 on: January 31, 2009, 07:42:53 am »
I'll try 1.2.3 and see if it works. I'll post the results for future searchs.

Thanks for the answer.

EDIT: No go. Not only not recognized Atheros L@ but also changed realtek to sundance. I really don't know if sundance change is expected but ale(4) dif not solved Atheros L2 problem.
« Last Edit: February 01, 2009, 06:19:11 am by ftcsm »

Offline wallabybob

  • Hero Member
  • *****
  • Posts: 5262
    • View Profile
Re: Atheros/Attansic L2 FastEthernet support
« Reply #3 on: February 01, 2009, 02:59:07 pm »
Can you post the output of the command pciconf -l -v (You can use the web GUI Diagnostics -> Command option)

This output will help determine if the ale driver is intended to recognise your onboard NIC. and may provide some insight on the sundance observation.


Offline ftcsm

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Atheros/Attansic L2 FastEthernet support
« Reply #4 on: February 02, 2009, 05:53:50 am »
Have not yet run the commands cause I was taking care of my 4 months old son.

I think driver should be ae(4) (saw it on a page about eeepc that uses Atheros L2).

Will check the other NICs but I really doubt they are served by sundance driver but one cannot be too sure :D

Online cmb

  • Administrator
  • Hero Member
  • *****
  • Posts: 6290
    • LinkedIn
    • Twitter
    • View Profile
    • Chris Buechler
Re: Atheros/Attansic L2 FastEthernet support
« Reply #5 on: February 10, 2009, 09:25:12 pm »
This has been added, though it'll be a couple days til new snapshots are available as we're moving the last repo to git.

Offline ftcsm

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Atheros/Attansic L2 FastEthernet support
« Reply #6 on: February 11, 2009, 03:18:55 pm »
Nice to know. I'll keep an eye on it.

By the way, 2 computers had Atheros L2 onboard LAN and 1 really got NICs recognized, even in Linux, as sundance. They are Encore EN832-TX, which normally includes RTL8139 chips.

Thanks everyone for your good work and patience.

Flavio

Offline ftcsm

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Atheros/Attansic L2 FastEthernet support
« Reply #7 on: February 18, 2009, 10:22:13 pm »
Did not work with Feb 18 snapshot, still can't identify the onboard atheros.

Offline wallabybob

  • Hero Member
  • *****
  • Posts: 5262
    • View Profile
Re: Atheros/Attansic L2 FastEthernet support
« Reply #8 on: February 19, 2009, 04:25:09 am »
Did not work with Feb 18 snapshot, still can't identify the onboard atheros.

Please post the output of the command pciconf -l -v (You can use the web GUI Diagnostics -> Command option)

This output will help determine if the ale or ae driver is intended to recognise your Atheros NIC. I had a quick look through the ae driver sources and the comments suggest it should support the Atheros L2 but that driver is not in FreeBSD 7.1 (used in pfSense 1.2.3). The ae driver should be in FreeBSD 8.0

cmb in an earlier reply didn't make clear whether he talking about the addition of the ale driver or the ae driver.

Online cmb

  • Administrator
  • Hero Member
  • *****
  • Posts: 6290
    • LinkedIn
    • Twitter
    • View Profile
    • Chris Buechler
Re: Atheros/Attansic L2 FastEthernet support
« Reply #9 on: February 21, 2009, 04:51:00 pm »
ale(4) is the one that was added.

Offline ftcsm

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Atheros/Attansic L2 FastEthernet support
« Reply #10 on: February 21, 2009, 06:07:34 pm »
I gave up on using P5GC-MX with pfSense. I'll try other motherboards.

Thank you all for your help.

Flavio

Offline brfreenet

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Atheros/Attansic L2 FastEthernet support
« Reply #11 on: February 28, 2009, 03:18:29 pm »
I gave up on using P5GC-MX with pfSense. I'll try other motherboards.

Thank you all for your help.

Flavio

   
Hello to all! Recently I came across the same problem ... The solution is simple. First, download the driver http://www.springdaemons.com/stas/if_ae-1214569185.tar.bz2 unzip into a Freebsd box 7.0 and compile. Copy the module if_ae.ko to your pfsense box 1.2.2 /boot/modules and insert the following line to /boot/loader.conf: if_ae_LOAD = "YES". Ready, module loaded and ready for use.

Sorry for my bad English.
« Last Edit: February 28, 2009, 03:56:22 pm by brfreenet »

Offline ftcsm

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Atheros/Attansic L2 FastEthernet support
« Reply #12 on: March 03, 2009, 03:46:24 pm »
Your english is really not worse than mine :D

Really thanks for your help, I had already give up on that mission.

Does it works on FreeBSD 7.1 (for pfSense 1.2.3 or greater)? If yes, on a VM install with FreeBSD 7.1, which option should I select during install to speed up the preparation process?

Hoping not to look an ingrate, can you put some instructions on the process (like a mini-howto or just the basic steps)? I assume my little knowledge of compiling kernel related things in FreeBSD and I have to test it really fast.

I'll try it anyway, even with no instructions. Maybe I can do it myself without much problems  ;)

Flavio

Offline brfreenet

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Atheros/Attansic L2 FastEthernet support
« Reply #13 on: March 04, 2009, 05:52:26 am »
Flávio, you does not need to compile kernel. Unzip the archive of link in a folder and follows these steps:

1- cd "/folder_of _file" make
2- cp if_ae.ko /boot/modules
3- vi /boot/loader.conf  "if_ae_load=" YES"
4- It restarts the machine.

I did not test with version 1.2.3 of the Pfsense, but it must function since that you compile with Freebsd 7.1.

Offline brfreenet

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Atheros/Attansic L2 FastEthernet support
« Reply #14 on: March 04, 2009, 06:01:26 am »
Any thing, sends me an email chaper_ibest.com.br