Netgate SG-1000 microFirewall

Author Topic: E2guardian4  (Read 363 times)

0 Members and 1 Guest are viewing this topic.

Offline Asterix

  • Hero Member
  • *****
  • Posts: 888
  • Karma: +32/-0
    • View Profile
E2guardian4
« on: November 09, 2017, 05:49:17 pm »
Installed the E2guardian4 package this evening but having issues getting it to start filtering. I see the below error in the logs. I do not have a CA configured and have selected manual local proxy 127.0.0.1 at port 3128. But the below error seems that E2 is still looking for a CA at port 8888.



/pkg_edit.php: The command '/usr/local/etc/rc.d/e2parent.sh start' returned exit code '1', the output was 'FATAL: No valid signing SSL certificate configured for HTTP_port 127.0.0.1:8888 Squid Cache (Version 3.5.27): Terminated abnormally. CPU Usage: 0.016 seconds = 0.016 user + 0.000 sys Maximum Resident Size: 47616 KB Page faults with physical i/o: 0'

No valid signing SSL certificate configured for HTTP_port 127.0.0.1:8888
« Last Edit: November 09, 2017, 06:40:28 pm by Asterix »

Offline Asterix

  • Hero Member
  • *****
  • Posts: 888
  • Karma: +32/-0
    • View Profile
Re: E2guardian4
« Reply #1 on: November 10, 2017, 08:57:23 pm »
Was the package pulled out? I don't see it on the list of available packages anymore.
« Last Edit: November 11, 2017, 02:37:59 pm by Asterix »

Offline Asterix

  • Hero Member
  • *****
  • Posts: 888
  • Karma: +32/-0
    • View Profile
Re: E2guardian4
« Reply #2 on: November 12, 2017, 11:33:20 am »
Never mind. Looks like I can see the E2guardian4 package if I add marcelloc unofficial repo for WPAD package.

Offline pfsensation

  • Full Member
  • ***
  • Posts: 213
  • Karma: +3/-0
    • View Profile
Re: E2guardian4
« Reply #3 on: November 23, 2017, 05:53:41 pm »
Make sure you have the unofficial repo added  and make sure you've got that CA generated for SSL MITM. After setting that up in E2G settings, it should work fine.