The pfSense Store

Author Topic: 2.4 Upgrade Fail  (Read 254 times)

0 Members and 1 Guest are viewing this topic.

Offline bigraz1968

  • Jr. Member
  • **
  • Posts: 41
  • Karma: +0/-0
    • View Profile
2.4 Upgrade Fail
« on: November 11, 2017, 04:22:47 pm »
I decided to upgrade to 2.4 from 2.3.4.  The upgrade went fine.  After the reboot, no one could get to the internet.  All DNS errors.  I use DNS Resolver for DNS.  The Unbound service is running.  Not sure how to get this working.  All the DNS rules are forwarding port 53 to the firewall 192.168.1.1(Router)

Please Help!!!

Thanks

Randy

Offline Gertjan

  • Hero Member
  • *****
  • Posts: 2079
  • Karma: +166/-9
    • View Profile
Re: 2.4 Upgrade Fail
« Reply #1 on: November 12, 2017, 05:51:18 am »
I decided to upgrade to 2.4 from 2.3.4.  The upgrade went fine.  After the reboot, no one could get to the internet.  All DNS errors.  I use DNS Resolver for DNS.  The Unbound service is running.  Not sure how to get this working. 
When you install a fresh clean copy, and the very minimal setup like: give it a name and domaine the pfSense work - setup DHCP and done.
If you go further - adding new settings - like:
All the DNS rules are forwarding port 53 to the firewall 192.168.1.1(Router)
... and things break, well ....
On the LAN interface, without any rules (your rules) and the build in PASS rule, it works out of the box.
Other 'LAN interfaces ? Add a Mega PAS rule and => it works.
You know what to do now  ;)


Btw : have unbound listen to ALL interfaces, even the WAN - or, do not touch the default settings and you're done. (So, basically, do nothing and it works !)

Offline bigraz1968

  • Jr. Member
  • **
  • Posts: 41
  • Karma: +0/-0
    • View Profile
Re: 2.4 Upgrade Fail
« Reply #2 on: November 12, 2017, 06:26:40 am »
Thanks for your reply but I was hoping I would not need to do a clean install.   Is it anything I could try first.

Randy

Offline revengineer

  • Jr. Member
  • **
  • Posts: 62
  • Karma: +4/-0
    • View Profile
Re: 2.4 Upgrade Fail
« Reply #3 on: November 12, 2017, 07:13:27 am »
If you have your config file, a complete reinstall barely takes longer than an upgrade install. It does not seem worth spending extensive time on troubleshooting unless you run into the same issue after the reinstall. In the process, switch to ZFS file system for added resilience and reduced risk of future disk issues after power outages.
« Last Edit: November 12, 2017, 10:39:15 am by revengineer »

Offline bigraz1968

  • Jr. Member
  • **
  • Posts: 41
  • Karma: +0/-0
    • View Profile
Re: 2.4 Upgrade Fail
« Reply #4 on: November 13, 2017, 06:48:25 am »
Update:

I think in my situation my issue was caused by pf blocker.  I ran the 2.4 update via the shell not the GUI.  Update appeared to go thru fine.  Once the firewall rebooted, No internet.  All DNS errors.  Tried fixing the resolver.   No luck.  I tried to remove my installed packages.  The package manager show none installed.  Prior to the update I had pf blocker, Squid, Squidguard and LightSquid installed.

I pulled out my old firewall running 2.3.3 plugged it in and was up running fine,  the next morning, No Internet.  I rebooted the firewall, still not working.  DNS issues.  The pf blocker package was installed.  I removed it and everything immediately started working.

Not saying pf blocker is a problem, but in my case.  I should have removed it and reinstalled it after upgrading.  Now off to rebuilding the original firewall.

Hope this helps someone.

Randy