pfSense Gold Subscription

Author Topic: 2.4.0 / 2.4.1 hang during boot at hpet0: High precision timer  (Read 283 times)

0 Members and 1 Guest are viewing this topic.

Offline obstler

  • Newbie
  • *
  • Posts: 17
  • Karma: +0/-0
    • View Profile
2.4.0 / 2.4.1 hang during boot at hpet0: High precision timer
« on: November 19, 2017, 11:18:05 am »
hi,

I've just upgraded from 2.3.x to 2.4 and unfortunately the system no longer boots -- boot hangs pretty soon a the line

hpet0: <High Precision Event Timer> iomem 0xfed00000...
(see screenshot)

I can get it to boot by going in the boot options and setting "Safe Mode" to On. Booting takes a very long time, but it succeeds. Don't know if booting in Safe mode has any drawbacks for the operation of pfSense?

Also tried 2.4.1 -- exactly same problem.

The system is a Zotac ZBOX CI327 nano with an Intel N3450 CPU and 2x Gigabit Ethernet. Hast been running just fine with pfSense 2.3.x so far.

Problem now is that I need to attach monitor/keyboard in case the system reboots, and manually select Safe Mode.

Is that boot hang a known problem that will be addressed in an update soon?

Not sure if I should restore the system back down to 2.3 or keep booting safe mode in the mean time.

I'll be more than happy to provide more information in case it helps figuring out and solving the issue.

thanks

Offline breakaway

  • Jr. Member
  • **
  • Posts: 73
  • Karma: +3/-0
    • View Profile
Re: 2.4.0 / 2.4.1 hang during boot at hpet0: High precision timer
« Reply #1 on: November 20, 2017, 05:09:36 am »
Have you tried doing a fresh install of 2.4.1 from USB or CDROM media to see if your issue is related to upgrading or some problem between pfSense and your hardware? I've found firmware upgrades can cause problems. Would be a good opportunity to switch your filesystem to ZFS as well.

Offline Birke

  • Jr. Member
  • **
  • Posts: 57
  • Karma: +12/-0
    • View Profile
Re: 2.4.0 / 2.4.1 hang during boot at hpet0: High precision timer
« Reply #2 on: November 27, 2017, 03:39:57 am »
use hint.hpet.0.clock="0" in /boot/loader.conf.local.
or press escape in the boot menu and then enter set hint.hpet.0.clock="0".

edit:
if that works, you might set all the options mentioned here:
https://forum.pfsense.org/index.php?topic=139733.msg763901#msg763901
« Last Edit: November 27, 2017, 03:58:50 am by Birke »

Offline internetservices

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: 2.4.0 / 2.4.1 hang during boot at hpet0: High precision timer
« Reply #3 on: December 06, 2017, 10:54:15 am »
Solution:
 disable 'Monitor M-Wait' in bios
Could be under Features tab > CPU Configuration