Netgate SG-1000 microFirewall

Author Topic: Upgrade 2.3.4-RELEASE-p1 to 2.4.x not possible  (Read 1559 times)

0 Members and 1 Guest are viewing this topic.

Offline AudiAddict

  • Full Member
  • ***
  • Posts: 201
  • Karma: +0/-0
    • View Profile
Upgrade 2.3.4-RELEASE-p1 to 2.4.x not possible
« on: November 26, 2017, 06:40:45 am »
I am unable to upgrade to the latest versions since some time now. I did read some other threads for troubleshooting but still can't solve.
Your help is much appreciated.

GUI shows:


System/ Update / Update Settings
Branch Stable (Default)

Update from shell shows:

Quote
Enter an option: 13

>>> Updating repositories metadata...
Updating pfSense-core repository catalogue...
pfSense-core repository is up to date.
Updating pfSense repository catalogue...
pfSense repository is up to date.
All repositories are up to date.
>>> Unlocking package pfSense-kernel-pfSense... done.
>>> Locking package pfSense-kernel-pfSense... done.
Your packages are up to date
*** Welcome to pfSense 2.3.4-RELEASE-p1 (i386 full-install) on volvo ***

I did notice i386 in the above and in other threads I'm seeing AMD64 snapshots?

Furthermore I can't ping pkg.pfsense.org (like many others). But all other sites, dns entries etc work fine from shell (including www.pfsense.org)

Quote
[2.3.4-RELEASE][root@volvo.xxx.local]/root: ping pkg.pfsense.org
ping: cannot resolve pkg.pfsense.org: No address associated with name

[2.3.4-RELEASE][root@volvo.xxx.local]/root: ping www.pfsense.org
PING www.pfsense.org (208.123.73.69): 56 data bytes
64 bytes from 208.123.73.69: icmp_seq=0 ttl=46 time=156.047 ms
64 bytes from 208.123.73.69: icmp_seq=1 ttl=46 time=157.568 ms
64 bytes from 208.123.73.69: icmp_seq=2 ttl=46 time=160.518 ms
64 bytes from 208.123.73.69: icmp_seq=3 ttl=46 time=160.542 ms
64 bytes from 208.123.73.69: icmp_seq=4 ttl=46 time=158.091 ms
64 bytes from 208.123.73.69: icmp_seq=5 ttl=46 time=157.981 ms
64 bytes from 208.123.73.69: icmp_seq=6 ttl=46 time=156.489 ms
64 bytes from 208.123.73.69: icmp_seq=7 ttl=46 time=158.318 ms
--- www.pfsense.org ping statistics ---
8 packets transmitted, 8 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 156.047/158.194/160.542/1.537 ms

[2.3.4-RELEASE][root@volvo.xxx.local]/root: ping google.nl
PING google.nl (216.58.212.131): 56 data bytes
64 bytes from 216.58.212.131: icmp_seq=0 ttl=55 time=11.853 ms
64 bytes from 216.58.212.131: icmp_seq=1 ttl=55 time=11.550 ms

Any idea's? Things I've also tried are: turn on/off dns forwarder, reboot and manual update through shell.
« Last Edit: November 26, 2017, 06:44:06 am by AudiAddict »

Offline ivor

  • Administrator
  • Hero Member
  • *****
  • Posts: 728
  • Karma: +154/-135
    • View Profile
    • Netgate
Re: Upgrade 2.3.4-RELEASE-p1 to 2.4.x not possible
« Reply #1 on: November 26, 2017, 06:52:52 am »
pfSense 2.4 is 64 bit only, so no support for i386. You will need a 64 bit hardware to use it.
« Last Edit: November 26, 2017, 06:56:29 am by ivor »
Need help fast? Commercial support: https://www.netgate.com/support/

Offline AudiAddict

  • Full Member
  • ***
  • Posts: 201
  • Karma: +0/-0
    • View Profile
Re: Upgrade 2.3.4-RELEASE-p1 to 2.4.x not possible
« Reply #2 on: November 26, 2017, 07:02:09 am »
Is this system not capable of doing this?

http://www.fit-pc.com/web/products/fit-pc2/fit-pc2-2i-specifications/fit-pc2i-specifications/

I thought most 32bit systems can be upgrade to use 64 bit OS.

If not possible I think I need to find a replacement :(. I really love this current box (only 6-8watt usage and runs pfsense grat).

Or will this 386 platform keep getting updates (security I guess is most important)?

Offline ivor

  • Administrator
  • Hero Member
  • *****
  • Posts: 728
  • Karma: +154/-135
    • View Profile
    • Netgate
Re: Upgrade 2.3.4-RELEASE-p1 to 2.4.x not possible
« Reply #3 on: November 26, 2017, 07:08:25 am »
Sorry, that's a 32 bit CPU so it will not support 64 bit. I think you got it mixed up, 64 bit CPU's support 32 bit OS.

We made an announcement that we intend to support 2.3.x series for at least a year from 2.4.0-RELEASE, so the security updates will continue. 2.3.5-RELEASE was released recently:

https://www.netgate.com/blog/pfsense-2-3-5-release-now-available.html

Read our blog more often to stay on top of the news :)
Need help fast? Commercial support: https://www.netgate.com/support/

Offline AudiAddict

  • Full Member
  • ***
  • Posts: 201
  • Karma: +0/-0
    • View Profile
Re: Upgrade 2.3.4-RELEASE-p1 to 2.4.x not possible
« Reply #4 on: November 26, 2017, 07:13:54 am »
Ok Thanks! Will check the blog more often.

I guess I will run this version for another year or purchase a comparable new 64bit based box.

PS: 2.3.5 is released but not able to auto update. Is this correct? I can't select any other branch then stable or development (should I choose the latter)? I did try  pkg install -fy pfSense-repo pfSense-upgrade but 2.3.4 is the latest. Is it possible that there still is an issue with the pkg update?


Offline Gertjan

  • Hero Member
  • *****
  • Posts: 2425
  • Karma: +191/-9
    • View Profile
Re: Upgrade 2.3.4-RELEASE-p1 to 2.4.x not possible
« Reply #5 on: November 26, 2017, 08:55:52 am »
...
PS: 2.3.5 is released but not able to auto update. Is this correct? I can't select any other branch then stable or development (should I choose the latter)? I did try  pkg install -fy pfSense-repo pfSense-upgrade but 2.3.4 is the latest. Is it possible that there still is an issue with the pkg update?
Not normal, but this happens - see the 'huge'** amount of thread related  to this issue. Pick any and do what they say.
The update system not being able to see the updates can be a DNS issue - pfSense not being able to checkout the update servers - or some others reasons.
As you already discovered, 2.3.5 i386 is the last version available.
Not being able to auto-upgrade is a good reason to re-install - just save the config upfront, and install again. This will take care of any issues on your setup for sure.

** this is relative of course. The probably other 99,9 % upgraded just fine - but these people don't post on the forum ;)
« Last Edit: November 26, 2017, 04:42:27 pm by Gertjan »

Offline ivor

  • Administrator
  • Hero Member
  • *****
  • Posts: 728
  • Karma: +154/-135
    • View Profile
    • Netgate
Re: Upgrade 2.3.4-RELEASE-p1 to 2.4.x not possible
« Reply #6 on: November 26, 2017, 04:37:40 pm »
PS: 2.3.5 is released but not able to auto update. Is this correct? I can't select any other branch then stable or development (should I choose the latter)? I did try  pkg install -fy pfSense-repo pfSense-upgrade but 2.3.4 is the latest. Is it possible that there still is an issue with the pkg update?

Try running option 13 from the console. If it doesn't update to 2.3.5, go to System > Update - Branch and switch to "Latest development snapshots". Wait for it to retrieve an update and then select back the "Latest stable version 2.3.x" branch. To be clear, do not update to the development snapshot, this is to make sure you have the correct update repository selected.
Need help fast? Commercial support: https://www.netgate.com/support/

Offline Derelict

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 9793
  • Karma: +1107/-311
    • View Profile
Re: Upgrade 2.3.4-RELEASE-p1 to 2.4.x not possible
« Reply #7 on: November 26, 2017, 05:50:56 pm »
System > Update, Update Settings.

Select Security/Errata if it is available. It should not be since you are on i386 you should only see latest stable. Hit Save there. Or switch off to another repo then back as was suggested by ivor.

pkg.pfsense.org does not have A/AAAA records. It has a SRV record:

$ dig +short _https._tcp.pkg.pfsense.org srv
10 10 443 files00.netgate.com.
10 10 443 files01.netgate.com.

Those hosts will have A/AAAA records.
« Last Edit: November 26, 2017, 06:06:31 pm by Derelict »
Las Vegas, Nevada, USA
Use this diagram to describe your issue.
The pfSense Book is now available for just $24.70!
Do Not PM For Help! NO_WAN_EGRESSTM

Offline dgwilson

  • Newbie
  • *
  • Posts: 20
  • Karma: +0/-0
    • View Profile
    • David's Opinions
Re: Upgrade 2.3.4-RELEASE-p1 to 2.4.x not possible
« Reply #8 on: December 22, 2017, 06:57:27 pm »
PS: 2.3.5 is released but not able to auto update. Is this correct? I can't select any other branch then stable or development (should I choose the latter)? I did try  pkg install -fy pfSense-repo pfSense-upgrade but 2.3.4 is the latest. Is it possible that there still is an issue with the pkg update?

Try running option 13 from the console. If it doesn't update to 2.3.5, go to System > Update - Branch and switch to "Latest development snapshots". Wait for it to retrieve an update and then select back the "Latest stable version 2.3.x" branch. To be clear, do not update to the development snapshot, this is to make sure you have the correct update repository selected.

Performing this action from the GUI allowed me to see the 2.3.5 release.
What was broken is now unbroken.
Next step upgrade... AFTER I return... and AFTER a backup! :-)

Thank you!

- David

Offline HeadGremlin

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Upgrade 2.3.4-RELEASE-p1 to 2.4.x not possible
« Reply #9 on: January 11, 2018, 09:01:44 pm »
Saw several different posts on this.  This is the latest one.  I figured I would post here.  Sorry if I am reviving an older post.  I too had difficulties updating.  Got the error below.  I used option 8 to enter the command prompt and used the command:

pkg-static update -f
exit

Then ran option 13 the update seemed to work without issue.  Keep in mind though that I have a 64 bit processor.  Therefore the architecture is supported

>>> Updating repositories metadata...
Updating pfSense-core repository catalogue...
pkg-static: Repository pfSense-core has a wrong packagesite, need to re-create database
Fetching meta.txz: . done
Fetching packagesite.txz: . done
Processing entries:
pkg-static: wrong architecture: FreeBSD:11:amd64 instead of freebsd:11:x86:64
pkg-static: repository pfSense-core contains packages with wrong ABI: FreeBSD:11:amd64
Processing entries... done
Unable to update repository pfSense-core
Updating pfSense repository catalogue...
pkg-static: Repository pfSense has a wrong packagesite, need to re-create database
Fetching meta.txz: . done
Fetching packagesite.txz: .......... done
Processing entries:
pkg-static: wrong architecture: FreeBSD:11:amd64 instead of freebsd:11:x86:64
pkg-static: repository pfSense contains packages with wrong ABI: FreeBSD:11:amd64
Processing entries... done
Unable to update repository pfSense
Error updating repositories!
*** Welcome to pfSense 2.3.4-RELEASE (amd64 full-install) on [My Client] ***

Offline Gertjan

  • Hero Member
  • *****
  • Posts: 2425
  • Karma: +191/-9
    • View Profile
Re: Upgrade 2.3.4-RELEASE-p1 to 2.4.x not possible
« Reply #10 on: January 12, 2018, 10:56:35 am »
Saw several different posts on this.  This is the latest one.  I figured I would post here.  Sorry if I am reviving an older post.  ....
Your post isn't related to thread (subject).
Because :
pkg-static: wrong architecture: FreeBSD:11:amd64 instead of freebsd:11:x86:64
You're trying to update a x86 (32 bits) system with amd64 (64 bits) update (or the other way around ?).
This isn't possible.

If your system supports amd64, then you should save the config, and do a complete re-install with an amd64 pfSense version.

Offline Fmslick

  • Jr. Member
  • **
  • Posts: 75
  • Karma: +2/-1
  • ﴾͡๏̯͡๏﴿ O'RLY?
    • View Profile
    • Fmslick.com
Re: Upgrade 2.3.4-RELEASE-p1 to 2.4.x not possible
« Reply #11 on: January 18, 2018, 08:14:25 pm »
I was having the same issue with my modded Watchguard x550e after having few DNS issues in the pass but doing what ivor said worked.  ;)

Try running option 13 from the console. If it doesn't update to 2.3.5, go to System > Update - Branch and switch to "Latest development snapshots". Wait for it to retrieve an update and then select back the "Latest stable version 2.3.x" branch. To be clear, do not update to the development snapshot, this is to make sure you have the correct update repository selected.

Thanks ivor, this helped me out on a modded Watchguard x550e. All tho you could have put the part  "do not update to the development snapshot" a bit sooner lol but all good I should not have been rush reading!!  ::)
We all start same where

Offline AllGamer

  • Newbie
  • *
  • Posts: 23
  • Karma: +1/-0
    • View Profile
Re: Upgrade 2.3.4-RELEASE-p1 to 2.4.x not possible
« Reply #12 on: January 18, 2018, 08:50:43 pm »