The pfSense Store

Author Topic: How to enable speedstep in bios on minisys box  (Read 277 times)

0 Members and 1 Guest are viewing this topic.

Offline wgstarks

  • Jr. Member
  • **
  • Posts: 39
  • Karma: +0/-0
    • View Profile
How to enable speedstep in bios on minisys box
« on: November 28, 2017, 06:55:05 am »
Iím working on configuring my new pfSense box and would like to use powerd, but for that to work I need to enable Intel SpeedStep. Iíve been through the bios several times. I donít see any settings for speedstep in advanced>cpu. Am I looking in the wrong menu?
« Last Edit: November 29, 2017, 09:16:29 pm by wgstarks »
pfSense vs 2.4.2
Box: Minisys IBOX-501 N10E
CPU: Intel Atom E3845
NIC: Intel WG82583 1000M x 4
RAM: 8GB

Offline stephenw10

  • Administrator
  • Hero Member
  • *****
  • Posts: 11909
  • Karma: +467/-15
    • View Profile
Re: How to enable speedstep in bios on minisys box
« Reply #1 on: November 28, 2017, 08:42:40 am »
The BIOS may not provide a setting. Or it may not pass the required values via ACPI.

The the boot log when you have powerd enabled, do you see any entries for est?

Correctly detected and attached:
Code: [Select]
est0: <Enhanced SpeedStep Frequency Control> on cpu0
est1: <Enhanced SpeedStep Frequency Control> on cpu1
est2: <Enhanced SpeedStep Frequency Control> on cpu2
est3: <Enhanced SpeedStep Frequency Control> on cpu3

Not correctly attached:
Code: [Select]
est0: <Enhanced SpeedStep Frequency Control> on cpu0
est: CPU supports Enhanced Speedstep, but is not recognized.
est: cpu_vendor GenuineIntel, msr b280b2806000b28
device_attach: est0 attach returned 6
est1: <Enhanced SpeedStep Frequency Control> on cpu1
est: CPU supports Enhanced Speedstep, but is not recognized.
est: cpu_vendor GenuineIntel, msr b280b2806000b28
device_attach: est1 attach returned 6

Steve

Offline wgstarks

  • Jr. Member
  • **
  • Posts: 39
  • Karma: +0/-0
    • View Profile
Re: How to enable speedstep in bios on minisys box
« Reply #2 on: November 28, 2017, 09:09:56 am »
Correctly detected and attached:
Code: [Select]
est0: <Enhanced SpeedStep Frequency Control> on cpu0
est1: <Enhanced SpeedStep Frequency Control> on cpu1
est2: <Enhanced SpeedStep Frequency Control> on cpu2
est3: <Enhanced SpeedStep Frequency Control> on cpu3
Not sure how to access the boot log but I think I did see this whiz by on the monitor during boot. I guess this means that speedstep is enabled by default. Thanks for the help.
pfSense vs 2.4.2
Box: Minisys IBOX-501 N10E
CPU: Intel Atom E3845
NIC: Intel WG82583 1000M x 4
RAM: 8GB

Offline stephenw10

  • Administrator
  • Hero Member
  • *****
  • Posts: 11909
  • Karma: +467/-15
    • View Profile
Re: How to enable speedstep in bios on minisys box
« Reply #3 on: November 28, 2017, 02:12:10 pm »
It's in /var/log/dmesg.boot

You can open that from Diagnostics > Edit File.

Or you can run:
Code: [Select]
cat /var/log/dmesg.boot
Steve

Offline wgstarks

  • Jr. Member
  • **
  • Posts: 39
  • Karma: +0/-0
    • View Profile
Re: How to enable speedstep in bios on minisys box
« Reply #4 on: November 29, 2017, 08:50:05 am »
Thanks.

The retailer that I purchased the minisys box from claims that SpeedStep isnít supported by the board they use. Pretty sure they are wrong though. I can see that CPU frequency is throttled in the dashboard. They also tried to tell me that the box uses Realtek nics. Theyíre really Intel.😏

My guess is that SpeedStep is enabled but there isnít a bios setting for it.
pfSense vs 2.4.2
Box: Minisys IBOX-501 N10E
CPU: Intel Atom E3845
NIC: Intel WG82583 1000M x 4
RAM: 8GB

Offline johnkeates

  • Hero Member
  • *****
  • Posts: 633
  • Karma: +50/-1
    • View Profile
Re: [solved] How to enable speedstep in bios on minisys box
« Reply #5 on: November 29, 2017, 09:00:15 am »
The E3845 CPU definitely supports EIST, so that should work indeed.

Offline stephenw10

  • Administrator
  • Hero Member
  • *****
  • Posts: 11909
  • Karma: +467/-15
    • View Profile
Re: [solved] How to enable speedstep in bios on minisys box
« Reply #6 on: November 29, 2017, 11:06:13 am »
The board has to have the correct bit set for Speedstep to be enabled but it sounds like it is there whatever they say,  ::)

If you see the CPU frequency scaling in the dashboard (in rational steps) that's usually fairly conclusive.

You can also see the available levels from:
Code: [Select]
[2.4.2-RELEASE][admin@8860.stevew.lan]/root: sysctl dev.est.0.freq_settings
dev.est.0.freq_settings: 2400/8 2200/0 2000/0 1800/0 1600/0 1400/0 1200/0

[2.4.2-RELEASE][admin@8860.stevew.lan]/root: sysctl dev.cpu.0.freq_levels
dev.cpu.0.freq_levels: 2400/8 2200/0 2000/0 1800/0 1600/0 1400/0 1200/0

Those should show the same levels otherwise it's using some other frequency scaling which is usually a bad thing.

Steve

Offline wgstarks

  • Jr. Member
  • **
  • Posts: 39
  • Karma: +0/-0
    • View Profile
Re: [solved] How to enable speedstep in bios on minisys box
« Reply #7 on: November 29, 2017, 09:16:02 pm »
The board has to have the correct bit set for Speedstep to be enabled but it sounds like it is there whatever they say,  ::)

If you see the CPU frequency scaling in the dashboard (in rational steps) that's usually fairly conclusive.

You can also see the available levels from:
Code: [Select]
[2.4.2-RELEASE][admin@8860.stevew.lan]/root: sysctl dev.est.0.freq_settings
dev.est.0.freq_settings: 2400/8 2200/0 2000/0 1800/0 1600/0 1400/0 1200/0

[2.4.2-RELEASE][admin@8860.stevew.lan]/root: sysctl dev.cpu.0.freq_levels
dev.cpu.0.freq_levels: 2400/8 2200/0 2000/0 1800/0 1600/0 1400/0 1200/0

Those should show the same levels otherwise it's using some other frequency scaling which is usually a bad thing.

Steve

Not sure what this means?

Clip from boot log-
Code: [Select]
est0: <Enhanced SpeedStep Frequency Control> on cpu0
est1: <Enhanced SpeedStep Frequency Control> on cpu1
est2: <Enhanced SpeedStep Frequency Control> on cpu2
est3: <Enhanced SpeedStep Frequency Control> on cpu3

From ssh-
Code: [Select]
[2.4.2-RELEASE][wgstarks@odin.dahoney.me]/root: sysctl dev.est.0.freq_settings
dev.est.0.freq_settings: 1909/2000 1743/1835 1577/1670 1411/1505 1245/1341 1079/1176 913/1011 747/847 498/600
[2.4.2-RELEASE][wgstarks@odin.dahoney.me]/root: sysctl dev.est.0.freq_levels
sysctl: unknown oid 'dev.est.0.freq_levels'

Dashboard screenshot-

pfSense vs 2.4.2
Box: Minisys IBOX-501 N10E
CPU: Intel Atom E3845
NIC: Intel WG82583 1000M x 4
RAM: 8GB

Offline stephenw10

  • Administrator
  • Hero Member
  • *****
  • Posts: 11909
  • Karma: +467/-15
    • View Profile
Re: How to enable speedstep in bios on minisys box
« Reply #8 on: December 03, 2017, 08:58:22 am »
Looks like you missed part of the difference between those lines. It should be:

Code: [Select]
sysctl dev.cpu.0.freq_levels
The output from the other sysctl looks good though. It lists valid Wattage numbers next to each step at least. The driver is ceratinly loading and attaching correctly.

Steve