pfSense Gold Subscription

Author Topic: Web GUI Unresponsive in pfSense 2.3.4  (Read 74 times)

0 Members and 1 Guest are viewing this topic.

Offline wizard1

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Web GUI Unresponsive in pfSense 2.3.4
« on: November 28, 2017, 07:55:05 am »
Hello!

Currently I have a primary/secondary pfSense cluster setup using CARP - this seems to work really well. However, whenever I log in to the secondary node, in order to do updates etc. the web interface is not always responsive, or it becomes unresponsive after a few minutes. The primary node however seems to work perfectly.

Both VM's are running on version 2.3.4 of pfSense, the secondary node has the following software packages installed:

  • Open-VM-Tools
  • openvpn-client-export
  • Shellcmd
  • snort
  • squid
  • squidGuard

The work around seems to be log into the console and restart the PHP-FPM service, and/or the webConfigurator. Which I wouldn't mind doing if it was an occasional problem. But as it happens so frequently the web interface is not very usable.

After restarting the PHP-FPM service, I see some nginx errors in the System > General log (attached).

I lot of the threads I've seen on this issue seem to be quite old and reference lighttpd, which I think I am right in saying, has now been replaced with nginx.

I've also read this thread https://forum.pfsense.org/index.php?topic=139126.0 which seems to suggest that snort is the problem. I have tried uninstalling snort, but the issue still seems to persist.

Any further help or suggestions much appreciated.