The pfSense Store

Author Topic: hn0: unknown RNDIS status 0x40010013  (Read 138 times)

0 Members and 1 Guest are viewing this topic.

Offline drgonzois5150

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
hn0: unknown RNDIS status 0x40010013
« on: November 29, 2017, 11:38:34 am »

Hi Everyone,

I'm running pfsense 2.4.2 on Hyper-V on Windows 10 Pro with a Dell Wireless 1830 802.11ac adapter (Dell XPS) laptop.   I have my pfsense Hyper configured with 3 interfaces as follows:

HN0 - WAN - using DHCP IPv4 network
HN1 - LAN - internal only hyperv IPv4 network
HN2 - OPT1 - internal only hyperv IPv4 network

all of my VM's work fine by routing IP traffic through my pfsense vm via the WAN link except im seeing the following status error message in my pfsense VM:

hn0: unknown RNDIS status 0x40010013
hn0: unknown RNDIS status 0x40010013

..and on and on and on.  The message seems to happen every minute or so.

any ideas??

thanks!



Offline NogBadTheBad

  • Sr. Member
  • ****
  • Posts: 385
  • Karma: +32/-0
    • View Profile
Re: hn0: unknown RNDIS status 0x40010013
« Reply #1 on: November 30, 2017, 05:25:19 am »
FYI FreeBSD doesn't 802.11ac Wi-Fi.

Not sure about the hn0 issue, unless the WAN interface is the Wi-Fi adaptor.


Offline drgonzois5150

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: hn0: unknown RNDIS status 0x40010013
« Reply #2 on: December 08, 2017, 09:43:27 am »
yes the WAN interface is the Dell Wireless 1830 802.11ac adapter.  Does anyone have any ideas? thx all!

Offline NogBadTheBad

  • Sr. Member
  • ****
  • Posts: 385
  • Karma: +32/-0
    • View Profile
Re: hn0: unknown RNDIS status 0x40010013
« Reply #3 on: December 09, 2017, 07:33:13 am »
Find a USB WiFi adaptor that will work with FreeBSD / pfSense or use the LAN port on the XPS.

Try looking on the FreeBSD web site.