pfSense English Support > General Questions

VoIP degradation of quality

(1/2) > >>

joelones:
I currently have an Asterisk Raspberry Pi box doing my VoIP behind of pfsense, incoming calls come in fine and all but what I do notice is the stuttering and clarity of the call degrades. More os, others, while talking to have remarked that my voice tends to degrade to that of a robot over time.

"Firewall Optimization Option" is set to Conservative in pfsense and I'm not port forward or anything else.

 On the Asterisk side registrations are set to 120s and my trunk with freephoneline.ca is set up as follows:


--- Code: ---context=from-trunk
host=voip.freephoneline.ca
username=
secret=
type=friend
insecure=port,invite
dtmfmode=auto
disallow=all
allow=ulaw&g729
fromdomain=voip.freephoneline.ca
canreinvite=no
qualify=yes
nat=yes
--- End code ---

Any random thoughts on what could be going on here?

KOM:
If the signalling and data flow are working and the only problem is poor call quality, you may have a local contention issue that can be solved by traffic shaping.  Is it always the same poor quality, or does it randomly change between good & bad?  What kind of link do you have, and how saturated is it?  If you have a fast link with lots of spare bandwidth, it might be your VoIP provider is oversubscribing their trunks.  I use smokeping to monitor how busy my VoIP provider's designated IP address is.  Regular packet loss is a clue that that IP might be too busy.

joelones:

--- Quote from: KOM on December 01, 2017, 02:42:02 pm ---If the signalling and data flow are working and the only problem is poor call quality, you may have a local contention issue that can be solved by traffic shaping.  Is it always the same poor quality, or does it randomly change between good & bad?  What kind of link do you have, and how saturated is it?  If you have a fast link with lots of spare bandwidth, it might be your VoIP provider is oversubscribing their trunks.  I use smokeping to monitor how busy my VoIP provider's designated IP address is.  Regular packet loss is a clue that that IP might be too busy.

--- End quote ---

It randomly changes on me. I've got a 30Mbps connection and I'm not saturating my link. I'd put money on the VoIP provider being the culprit. Never heard of smokeping, difficult to use?

KOM:

--- Quote ---Never heard of smokeping, difficult to use?
--- End quote ---

https://oss.oetiker.ch/smokeping/

You can install it on your pi as its already in the repo. You only need to edit the General and Targets files in /etc/smokeping/config.d

virgiliomi:
Just a note though, that some larger VoIP services may use a single hostname, then rotate servers using SRV records under that hostname. In fact, the hostname that could be used could point to their website, but the SRV records within could point to their VoIP servers elsewhere, not even in the same physical location. That makes monitoring a bit harder.

If it's not your bandwidth that is the issue, other potential issues could be the audio format being used for the call - check your Pi's CPU usage during the call; it may be having to convert audio formats and could be falling behind over time - or issues on your provider's end. Try setting up a phone, SIP client, or ATA to point directly to your provider and see if it happens there as well.

Navigation

[0] Message Index

[#] Next page

Go to full version