Netgate SG-1000 microFirewall

Author Topic: software RAID1 for OS, necessary?  (Read 202 times)

0 Members and 1 Guest are viewing this topic.

Offline pecker88

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
    • View Profile
software RAID1 for OS, necessary?
« on: December 04, 2017, 11:12:07 am »
I have 2 identical new Intel 545s 256GB SSD drives.

Should I use the built-in Intel software raid on my SuperMicro A1SRI-2358F motherboard to create a RAID1 mirror for the OS or is just 1 drive sufficient?

This will be a primary gateway at at remote office location, stability/up-time is important.

thanks!

Offline Jailer

  • Sr. Member
  • ****
  • Posts: 399
  • Karma: +54/-2
    • View Profile
    • Bored Guy Blog
Re: software RAID1 for OS, necessary?
« Reply #1 on: December 04, 2017, 05:38:15 pm »
You'd be better off with a ZFS mirror. It's simple to set up during install.

Offline pecker88

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
    • View Profile
Re: software RAID1 for OS, necessary?
« Reply #2 on: December 04, 2017, 07:35:59 pm »
I mis-spoke in my OP, the mirror setup via the pfSense install is what I was referring to.
Would be installing 2.4 stable build.

Offline kpa

  • Hero Member
  • *****
  • Posts: 1188
  • Karma: +132/-6
    • View Profile
Re: software RAID1 for OS, necessary?
« Reply #3 on: December 04, 2017, 08:40:24 pm »
Do not use the provided BIOS RAID configurator or any of the provided utilities for it. Instead use ZFS mirror as suggested, ZFS does poorly if it doesn't have a direct access to the disks used. In fact a configuration where ZFS is used on top of a software pseudo RAID defeats most of advantages ZFS offers.

Offline pecker88

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
    • View Profile
Re: software RAID1 for OS, necessary?
« Reply #4 on: December 07, 2017, 09:07:16 am »
SuperMicro A1SRI-2358F + Chassis CSE-101i isn't really "made" for 2x HDs, but the HD bay does easily fit 2 SSD atop each other.
But, since I'm using external pwr supply, the mobo only has 1 male molex connector for HD pwr. So, I had to order female molex to 2x SATA power for the SSDs. Wasn't easy to find female molex to SATA power, but finally got 1 in today.

Got everything up and running with Auto Install (ZFS), very easy. Thanks for recommendations everyone.

Code: [Select]
pool: pfSenseZFSpool
 state: ONLINE
  scan: scrub repaired 0 in 0h0m with 0 errors on Thu Dec  7 07:01:02 2017
config:

NAME        STATE     READ WRITE CKSUM
pfSenseZFSpool  ONLINE       0     0     0
  mirror-0  ONLINE       0     0     0
    ada0p3  ONLINE       0     0     0
    ada1p3  ONLINE       0     0     0

errors: No known data errors
« Last Edit: December 07, 2017, 09:12:58 am by pecker88 »