pfSense Support Subscription

Author Topic: WAN ip keep on and off  (Read 100 times)

0 Members and 1 Guest are viewing this topic.

Offline yashiharu

  • Newbie
  • *
  • Posts: 24
  • Karma: +0/-0
    • View Profile
WAN ip keep on and off
« on: December 06, 2017, 12:22:59 am »
2.4.2-RELEASE (amd64)
CPU usage: <8%
Intel(R) Core(TM) i3-4010U CPU @ 1.70GHz
INTEL GB LAN

problem:
Slow internet and even on & off on clients

pfsense:
the interface of WAN keep flashing between real IP, n/a, 0.0.0.0
there're no problem on last few months
i did reboot all devices and called ISP to reboot
still the same problem

Log:
Quote
Dec 6 14:18:02   php-fpm   77565   /rc.newwanip: ROUTING: setting default route to 158.176.170.1
Dec 6 14:18:02   php-fpm   77565   /rc.newwanip: rc.newwanip: on (IP address: 158.176.***.***) (interface: WAN[wan]) (real interface: em0).
Dec 6 14:18:02   php-fpm   77565   /rc.newwanip: rc.newwanip: Info: starting on em0.
Dec 6 14:18:02   check_reload_status      Starting packages
Dec 6 14:18:02   php-fpm   77565   /rc.newwanip: pfSense package system has detected an IP change or dynamic WAN reconnection - 158.176.***.*** -> 158.176.***.*** - Restarting packages.
Dec 6 14:18:01   check_reload_status      Starting packages
Dec 6 14:18:01   php-fpm   58899   /rc.newwanip: pfSense package system has detected an IP change or dynamic WAN reconnection - -> - Restarting packages.
Dec 6 14:18:01   check_reload_status      Reloading filter
Dec 6 14:18:01   php-fpm   58899   /rc.newwanip: rc.newwanip called with empty interface.
Dec 6 14:18:01   php-fpm   58899   /rc.newwanip: rc.newwanip: on (IP address: ) (interface: []) (real interface: ovpns2).
Dec 6 14:18:01   php-fpm   58899   /rc.newwanip: rc.newwanip: Info: starting on ovpns2.
Dec 6 14:18:01   check_reload_status      Restarting ipsec tunnels
Dec 6 14:18:01   php-fpm   90414   /rc.linkup: ROUTING: setting default route to 158.176.170.1
Dec 6 14:18:01   check_reload_status      rc.newwanip starting em0
Dec 6 14:18:01   kernel      em0: link state changed to UP
Dec 6 14:18:01   check_reload_status      Linkup starting em0
Dec 6 14:18:00   kernel      ovpns2: link state changed to DOWN
Dec 6 14:18:00   check_reload_status      rc.newwanip starting ovpns2
Dec 6 14:18:00   php-fpm   77565   /rc.newwanip: Creating rrd update script
Dec 6 14:18:00   check_reload_status      Reloading filter
Dec 6 14:18:00   kernel      ovpns2: link state changed to UP
Dec 6 14:18:00   php-fpm   77565   OpenVPN PID written: 48855
Dec 6 14:18:00   php-fpm   77565   OpenVPN terminate old pid: 72901
Dec 6 14:18:00   php-fpm   77565   /rc.newwanip: Resyncing OpenVPN instances for interface WAN.
Dec 6 14:17:59   kernel      em0: link state changed to DOWN
Dec 6 14:17:59   check_reload_status      Linkup starting em0
Dec 6 14:17:59   php-fpm   90414   /rc.linkup: HOTPLUG: Configuring interface wan
Dec 6 14:17:59   php-fpm   90414   /rc.linkup: DEVD Ethernet attached event for wan
Dec 6 14:17:59   check_reload_status      Reloading filter
Dec 6 14:17:58   php-fpm   8575   /rc.start_packages: Restarting/Starting all packages.
Dec 6 14:17:58   php-fpm   26907   /rc.linkup: DEVD Ethernet detached event for wan
Dec 6 14:17:58   check_reload_status      Reloading filter
Dec 6 14:17:58   check_reload_status      updating dyndns wan
Dec 6 14:17:56   php-fpm   77565   /rc.newwanip: The command '/usr/local/sbin/unbound -c /var/unbound/unbound.conf' returned exit code '1', the output was '[1512541076] unbound[32063:0] error: bind: address already in use [1512541076] unbound[32063:0] fatal error: could not open ports'

Any device plz?

Offline yashiharu

  • Newbie
  • *
  • Posts: 24
  • Karma: +0/-0
    • View Profile
Re: WAN ip keep on and off
« Reply #1 on: December 06, 2017, 04:42:07 am »
problem solved by:

Interfaces > WAN > Speed and Duplex
from autoselect to 100baseTX full-duplex (100MB line)

no more unstable

Offline JKnott

  • Hero Member
  • *****
  • Posts: 984
  • Karma: +36/-4
    • View Profile
Re: WAN ip keep on and off
« Reply #2 on: December 06, 2017, 06:07:51 am »
If you have to manually configure it, there's something wrong somewhere.  Both ends are supposed to auto negotiate and setting one end, but not the other can cause problems.  What happens if you connect another computer?  If it does the same, there's an issue with the modem.  If it stops, the problem is with your firewall computer.