Netgate SG-1000 microFirewall

Author Topic: Adding IPv4 address to pppoe0 failed(IGNORING for now.  (Read 175 times)

0 Members and 1 Guest are viewing this topic.

Offline solte98@hotmail.com

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Adding IPv4 address to pppoe0 failed(IGNORING for now.
« on: December 15, 2017, 03:04:22 am »
hi,

I am a avid pfsense fan and I have been using this at home with BT (using a draytek adsl vigor modem) for a while.  I swapped ISP and suddenly I cannot get pfsense with pppoe to work.  I swapped it with a drayetk router and all is fine! 

It seems like it is getting the correct IP (I cleared it out below)... BUT then fails and assigns 0.0.0.0

The portion of the log is

Dec 15 08:29:22   ppp      [wan] IPCP: rec'd Configure Reject #1 (Req-Sent)
Dec 15 08:29:22   ppp      [wan] COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
Dec 15 08:29:22   ppp      [wan] IPCP: SendConfigReq #2
Dec 15 08:29:22   ppp      [wan] IPADDR 0.0.0.0
Dec 15 08:29:22   ppp      [wan] PRIDNS 0.0.0.0
Dec 15 08:29:22   ppp      [wan] SECDNS 0.0.0.0
Dec 15 08:29:22   ppp      [wan_link0] LCP: rec'd Protocol Reject #3 (Opened)
Dec 15 08:29:22   ppp      [wan_link0] LCP: protocol IPV6CP was rejected
Dec 15 08:29:22   ppp      [wan] IPV6CP: protocol was rejected by peer
Dec 15 08:29:22   ppp      [wan] IPV6CP: state change Req-Sent --> Stopped
Dec 15 08:29:22   ppp      [wan] IPV6CP: LayerFinish
Dec 15 08:29:22   ppp      [wan] IPCP: rec'd Configure Request #2 (Req-Sent)
Dec 15 08:29:22   ppp      [wan] IPCP: SendConfigAck #2
Dec 15 08:29:22   ppp      [wan] IPCP: state change Req-Sent --> Ack-Sent
Dec 15 08:29:22   ppp      [wan] IPCP: rec'd Configure Nak #2 (Ack-Sent)
Dec 15 08:29:22   ppp      [wan] IPADDR x.x.x.x
Dec 15 08:29:22   ppp      [wan] 78.32.141.114 is OK
Dec 15 08:29:22   ppp      [wan] PRIDNS 195.74.113.58
Dec 15 08:29:22   ppp      [wan] SECDNS 195.74.113.62
Dec 15 08:29:22   ppp      [wan] IPCP: SendConfigReq #3
Dec 15 08:29:22   ppp      [wan] IPADDR x.x.x.x
Dec 15 08:29:22   ppp      [wan] PRIDNS 195.74.113.58
Dec 15 08:29:22   ppp      [wan] SECDNS 195.74.113.62
Dec 15 08:29:22   ppp      [wan] IPCP: rec'd Configure Ack #3 (Ack-Sent)
Dec 15 08:29:22   ppp      [wan] IPADDR x.x.x.x
Dec 15 08:29:22   ppp      [wan] PRIDNS 195.74.113.58
Dec 15 08:29:22   ppp      [wan] SECDNS 195.74.113.62
Dec 15 08:29:22   ppp      [wan] IPCP: state change Ack-Sent --> Opened
Dec 15 08:29:22   ppp      [wan] IPCP: LayerUp
Dec 15 08:29:22   ppp      [wan] x.x.x.x -> 0.0.0.0
Dec 15 08:29:22   ppp      [wan] IFACE: Adding IPv4 address to pppoe0 failed(IGNORING for now. This should be only for PPPoE friendly!): Destination address required




marjohh

  • Guest
Re: Adding IPv4 address to pppoe0 failed(IGNORING for now.
« Reply #1 on: December 15, 2017, 05:19:52 am »
Which ISP have you switched to?

Offline solte98@hotmail.com

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Adding IPv4 address to pppoe0 failed(IGNORING for now.
« Reply #2 on: December 15, 2017, 06:53:06 am »
The reseller is Southern Communications, but it seems they are using Entanet for my home connection.

marjohh

  • Guest
Re: Adding IPv4 address to pppoe0 failed(IGNORING for now.
« Reply #3 on: December 15, 2017, 08:11:39 am »
Strange as it works with the Draytek, are there any settings in the Draytek that might need setting in the advanced PPPoE settings on pfSense?

I could find no info or support site, apart from a bunch of threads about people having issues with IPv6.

Offline solte98@hotmail.com

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Adding IPv4 address to pppoe0 failed(IGNORING for now.
« Reply #4 on: December 15, 2017, 11:07:25 am »
I can disable IPv6.

The only setting I can see is where the MTU has been entered with value 1500.

I can try to enter that, and will post another log file

Offline JKnott

  • Hero Member
  • *****
  • Posts: 1204
  • Karma: +53/-11
    • View Profile
Re: Adding IPv4 address to pppoe0 failed(IGNORING for now.
« Reply #5 on: December 15, 2017, 11:38:36 am »
I can disable IPv6.

The only setting I can see is where the MTU has been entered with value 1500.

I can try to enter that, and will post another log file

Normally PPPoE uses 1492.  This is to allow the PPPoE header to fit within the Ethernet frame, along with user IP packets.  Going smaller than necessary won't cause problems but larger might.


Offline solte98@hotmail.com

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Adding IPv4 address to pppoe0 failed(IGNORING for now.
« Reply #6 on: February 12, 2018, 05:22:58 pm »
Hi,

I am revisiting this post as I am back to my home location after being away for nearly 2 months.  ok, so I have swapped the draytek 2860 for the PFsense box again (with the draytek 130 vdsl modem).

Again, draytek 2860 works fine, but pfsense has the same errors even with IPv6 disabled.

I will contact the ISP again to see if I can make them work