Netgate SG-1000 microFirewall

Author Topic: PPPoE connection dropping intermittently / WAN interface reset  (Read 278 times)

0 Members and 1 Guest are viewing this topic.

Offline Verta

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
PPPoE connection dropping intermittently / WAN interface reset
« on: December 09, 2017, 01:53:32 pm »
Hi all,

I've recently purchased an SG-3100 which is terminating my VDSL connection via a Draytek Vigor 130 modem over PPPoE.

This setup has been rock solid since December 1st until today. Four times today my PPPoE connection has dropped, however my VDSL modem has maintained sync.

Normally, when the VDSL modem loses sync and the PPP connection resets, you see these messages in ppp.log:
Code: [Select]
Nov 30 19:40:55 pfsense ppp: [wan]   REDACTED -> REDACTED
Dec  1 14:18:58 pfsense ppp: [wan_link0] LCP: no reply to 1 echo request(s)
Dec  1 14:19:08 pfsense ppp: [wan_link0] LCP: no reply to 2 echo request(s)
Dec  1 14:19:18 pfsense ppp: [wan_link0] LCP: no reply to 3 echo request(s)
Dec  1 14:19:28 pfsense ppp: [wan_link0] LCP: no reply to 4 echo request(s)
Dec  1 14:19:38 pfsense ppp: [wan_link0] LCP: no reply to 5 echo request(s)
Dec  1 14:19:38 pfsense ppp: [wan_link0] LCP: peer not responding to echo requests
Dec  1 14:19:38 pfsense ppp: [wan_link0] LCP: state change Opened --> Stopping
Dec  1 14:19:38 pfsense ppp: [wan_link0] Link: Leave bundle "wan"
Dec  1 14:19:38 pfsense ppp: [wan] Bundle: Status update: up 0 links, total bandwidth 9600 bps
Dec  1 14:19:38 pfsense ppp: [wan] IPCP: Close event

The logs for the disconnects today give no indication as to why the link dropped, all I get is the following:

Code: [Select]
Dec  1 14:30:07 pfsense ppp: [wan]   REDACTED -> REDACTED
Dec  1 14:30:07 pfsense ppp: [wan_link0] rec'd unexpected protocol IP
Dec  9 11:27:55 pfsense ppp: Multi-link PPP daemon for FreeBSD
Dec  9 11:27:55 pfsense ppp:
Dec  9 11:27:55 pfsense ppp: process 67445 started, version 5.8 (nobody@pfSense_factory-v2_4_1_armv6-pfSense_factory-v2_4_1-job-01 16:39 21-Oct-2017)
Dec  9 11:27:55 pfsense ppp: waiting for process 98028 to die...
Dec  9 11:27:55 pfsense ppp: caught fatal signal TERM
Dec  9 11:27:55 pfsense ppp: [wan] IFACE: Close event
Dec  9 11:27:55 pfsense ppp: [wan] IPCP: Close event
Dec  9 11:27:55 pfsense ppp: [wan] IPCP: state change Opened --> Closing

When I look into system.log, it says the interface goes down & up:
Code: [Select]
Dec  9 11:27:51 pfsense check_reload_status: Linkup starting mvneta2
Dec  9 11:27:51 pfsense kernel: mvneta2: link state changed to DOWN
Dec  9 11:27:52 pfsense check_reload_status: Reloading filter
Dec  9 11:27:54 pfsense check_reload_status: Linkup starting mvneta2
Dec  9 11:27:54 pfsense kernel: mvneta2: link state changed to UP
Dec  9 11:27:55 pfsense ppp: Multi-link PPP daemon for FreeBSD

The SG-3100 is connected to the modem by a brand new 0.5m Cat6a cable, in a locked closet - so I don't think it's the cable, but I will get one out to test.

Has anyone else experience similar, or could point to why this might happen, other than a faulty cable?

Thanks,
Verta.

Offline Grimson

  • Sr. Member
  • ****
  • Posts: 431
  • Karma: +63/-7
    • View Profile
Re: PPPoE connection dropping intermittently / WAN interface reset
« Reply #1 on: December 09, 2017, 03:53:13 pm »
Has anyone else experience similar, or could point to why this might happen, other than a faulty cable?

If it worked fine for a few days I would guess your provider has some issues at the moment.

Offline Verta

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: PPPoE connection dropping intermittently / WAN interface reset
« Reply #2 on: December 09, 2017, 04:24:58 pm »
Has anyone else experience similar, or could point to why this might happen, other than a faulty cable?

If it worked fine for a few days I would guess your provider has some issues at the moment.

Thanks for the response. I've dug out a new cable and noticed that whenever I move the cable, the port on the SG-3100 goes down, whetever it's connected to the modem or a switch - maybe a faulty port? I'll drop Netgate a line.

Offline JKnott

  • Hero Member
  • *****
  • Posts: 1380
  • Karma: +60/-13
    • View Profile
Re: PPPoE connection dropping intermittently / WAN interface reset
« Reply #3 on: December 09, 2017, 04:41:00 pm »
You might try the cable first.
This page unintentionally left blank.

Offline Verta

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: PPPoE connection dropping intermittently / WAN interface reset
« Reply #4 on: December 12, 2017, 12:55:50 pm »
I'm four cables in and getting some interesting results. Any cable that has a shielded RJ45 connector, the port will drop when the cable is moved. Any unshielded RJ45 connector and the port doesn't drop. I'm reporting back to the reseller I bought the unit from to see if they think it's faulty or not.

Thanks for the assistance.

Offline JKnott

  • Hero Member
  • *****
  • Posts: 1380
  • Karma: +60/-13
    • View Profile
Re: PPPoE connection dropping intermittently / WAN interface reset
« Reply #5 on: December 12, 2017, 01:01:44 pm »
One thing about shielded cables.  They're supposed to be grounded at one and only one point.  If they're not grounded, the shield is ineffective.  If grounded at more than one point, ground loops may occur.
However, given that just moving the cable causes failure, it's likely a poor connection somewhere.

Rule of thumb, when something fails, cables and connectors are the likely suspects.
This page unintentionally left blank.