Netgate SG-1000 microFirewall

Author Topic: Dashboard gateway showing very high ping time  (Read 207 times)

0 Members and 1 Guest are viewing this topic.

Offline Heimire

  • Full Member
  • ***
  • Posts: 119
  • Karma: +6/-0
    • View Profile
Dashboard gateway showing very high ping time
« on: December 14, 2017, 11:16:07 am »
Take a look at the images.
Its from a 2.4.2 firewall.

Notice how high those ping times to the gateways are when they are viewed from the dashboard.

Look how much less (normal) they are when I ping the gateways.

Does anyone know if its a bug in this version?



Offline johnpoz

  • Hero Member
  • *****
  • Posts: 15765
  • Karma: +1502/-210
  • Not a pfSense employee, they cannot fire me...
    • View Profile
Re: Dashboard gateway showing very high ping time
« Reply #1 on: December 14, 2017, 12:25:38 pm »
Can not duplicate this.. Running 2.4.2

PING 64.53.246.1 (64.53.246.1): 56 data bytes
64 bytes from 64.53.246.1: icmp_seq=0 ttl=255 time=10.638 ms
64 bytes from 64.53.246.1: icmp_seq=1 ttl=255 time=9.671 ms
64 bytes from 64.53.246.1: icmp_seq=2 ttl=255 time=8.606 ms
64 bytes from 64.53.246.1: icmp_seq=3 ttl=255 time=8.534 ms
64 bytes from 64.53.246.1: icmp_seq=4 ttl=255 time=8.371 ms
64 bytes from 64.53.246.1: icmp_seq=5 ttl=255 time=8.460 ms
64 bytes from 64.53.246.1: icmp_seq=6 ttl=255 time=12.785 ms
64 bytes from 64.53.246.1: icmp_seq=7 ttl=255 time=8.492 ms
64 bytes from 64.53.246.1: icmp_seq=8 ttl=255 time=8.178 ms
64 bytes from 64.53.246.1: icmp_seq=9 ttl=255 time=10.264 ms

--- 64.53.246.1 ping statistics ---
10 packets transmitted, 10 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 8.178/9.400/12.785/1.395 ms

Ping from pfsense avg shows 9.4 and widget shows
- An intelligent man is sometimes forced to be drunk to spend time with his fools.
- Please don't PM me for personal help
- if you want to say thanks applaud or https://www.freebsdfoundation.org/donate/
1x SG-2440 2.4.3-RELEASE (work)
1x SG-3100 2.4.3-RELEASE (work)
1x SG-4860 2.4.3-RELEASE (home)

Offline Heimire

  • Full Member
  • ***
  • Posts: 119
  • Karma: +6/-0
    • View Profile
Re: Dashboard gateway showing very high ping time
« Reply #2 on: December 14, 2017, 01:43:38 pm »
Its strange.

If I ping from a laptop on the LAN side its less than 1 ms too.

so pinging from the firewall interface and a laptop shows < 1ms but the dashboard shows between 2 and 8 ms, mostly around 4 or so.

Anyone else?


Offline johnpoz

  • Hero Member
  • *****
  • Posts: 15765
  • Karma: +1502/-210
  • Not a pfSense employee, they cannot fire me...
    • View Profile
Re: Dashboard gateway showing very high ping time
« Reply #3 on: December 14, 2017, 02:46:25 pm »
So this gateway is on your lan?  less than 1 ms is lan speeds, normally this would not be a  ISP/WAN connection speed..

So dpinger would be sending 0 sized pings.. While your normal pings would be sending some data in the ping.. Maybe the gateway takes longer to answer the zero sized pings?  That is a wild ass guess... But only thing that comes to mind that could be different.

In your gateway monitor you can tell it to send some data to match up with what your normal pings are sending.. "56 data bytes"
- An intelligent man is sometimes forced to be drunk to spend time with his fools.
- Please don't PM me for personal help
- if you want to say thanks applaud or https://www.freebsdfoundation.org/donate/
1x SG-2440 2.4.3-RELEASE (work)
1x SG-3100 2.4.3-RELEASE (work)
1x SG-4860 2.4.3-RELEASE (home)

Offline Heimire

  • Full Member
  • ***
  • Posts: 119
  • Karma: +6/-0
    • View Profile
Re: Dashboard gateway showing very high ping time
« Reply #4 on: December 14, 2017, 04:01:51 pm »
No the gateway is on the WAN but its in a data center so its a gig connection to a device in the same building.
But thats kind of the same thing you mentioned  of being a lan.

In the other data center we have 2.2.6 and we are seeing real numbers like as in .6ms and it matches the ping when done.
so that does not match this behavior.