Netgate SG-1000 microFirewall

Author Topic: Cron issue  (Read 245 times)

0 Members and 1 Guest are viewing this topic.

Offline BeerCan

  • Jr. Member
  • **
  • Posts: 92
  • Karma: +9/-0
    • View Profile
Cron issue
« on: December 19, 2017, 07:44:35 pm »
Don't know what I did but the cron job is getting hung up

I rebooted  no luck
killed cron job and ran force update   no luck
I reinstalled pfblocker and  no luck


It just stays like this for hours


Offline BBcan177

  • Moderator
  • Hero Member
  • *****
  • Posts: 2608
  • Karma: +824/-5
    • View Profile
    • Click for Support
Re: Cron issue
« Reply #1 on: December 19, 2017, 07:47:36 pm »
That's odd. Either try a reboot or kill any pfb pids

ps auxww | grep pfb

kill -9 <pid #s>
"Experience is something you don't get until just after you need it."

 | http://pfblockerng.com | Twitter @BBcan177  | #pfBlockerNG |

Offline BBcan177

  • Moderator
  • Hero Member
  • *****
  • Posts: 2608
  • Karma: +824/-5
    • View Profile
    • Click for Support
Re: Cron issue
« Reply #2 on: December 19, 2017, 07:50:07 pm »
Actually I have seen this issue before. 

There is a file I think:

/var/run/booting

Or something like that. This file is stopping the cron run from executing. The next release will show this in the log. 

So just delete that file. 
"Experience is something you don't get until just after you need it."

 | http://pfblockerng.com | Twitter @BBcan177  | #pfBlockerNG |

Offline BeerCan

  • Jr. Member
  • **
  • Posts: 92
  • Karma: +9/-0
    • View Profile
Re: Cron issue
« Reply #3 on: December 19, 2017, 07:54:16 pm »
Actually I have seen this issue before. 

There is a file I think:

/var/run/booting

Or something like that. This file is stopping the cron run from executing. The next release will show this in the log. 

So just delete that file.

That file is not there

Just rebooted again  same issue.  Weird, the system was fine yesterday and I have made zero changes in the last 5 days

Offline BBcan177

  • Moderator
  • Hero Member
  • *****
  • Posts: 2608
  • Karma: +824/-5
    • View Profile
    • Click for Support
Re: Cron issue
« Reply #4 on: December 19, 2017, 08:10:09 pm »
Try to delete these Alexa DB files as it might have gotten corrupt:

rm /var/db/pfblockerng/top*
rm /var/db/pfblockerng/pfbalexawhitelist.txt  
"Experience is something you don't get until just after you need it."

 | http://pfblockerng.com | Twitter @BBcan177  | #pfBlockerNG |

Offline BeerCan

  • Jr. Member
  • **
  • Posts: 92
  • Karma: +9/-0
    • View Profile
Re: Cron issue
« Reply #5 on: December 19, 2017, 08:30:46 pm »
Try to delete these Alexa DB files as it might have gotten corrupt:

rm /var/db/pfblockerng/top*
rm /var/db/pfblockerng/pfbalexawhitelist.txt 

Did that and it did re download top1m.csv and downloaded/recreated the whitelist

Now it seems stuck here

Code: [Select]
UPDATE PROCESS START [ 12/19/17 21:25:55 ]

===[  DNSBL Process  ]================================================

Alexa Database downloading ( approx 21M ) ... Please wait ...

Offline BeerCan

  • Jr. Member
  • **
  • Posts: 92
  • Karma: +9/-0
    • View Profile
Re: Cron issue
« Reply #6 on: December 19, 2017, 08:40:22 pm »
Found the issue.

I don't know how it happened (I must have did it somehow)  But in the alexa whitelist setting settings, none of the TLD Inclusions were selected.  I re selected the defaults, and now everything seems to be working.

Thanks for pointing me in the right direction BBcan177
« Last Edit: December 19, 2017, 08:44:56 pm by BeerCan »