Netgate SG-1000 microFirewall

Author Topic: pfBlockerNG and PFSense 2.4.2  (Read 386 times)

0 Members and 1 Guest are viewing this topic.

Offline bab5470

  • Newbie
  • *
  • Posts: 17
  • Karma: +0/-0
    • View Profile
pfBlockerNG and PFSense 2.4.2
« on: December 21, 2017, 07:35:06 pm »
I just upgraded to pfsense 2.4.2 now I want to install pfBlockerNG. When I attempt to do so using the GUI I get the following error:

WARNING: Current pkg repository has a new OS major version.
         pfSense should be upgraded before doing any other
         operation
Failed

I did a bit of googling and the suggestion seems to be to go to System -> Update -> Update Settings and set the branch to "Legacy Stable version 2.x" but I've already upgraded to 2.4.2 so does that mean the only way to get this package to work is to downgrade?

I believe I've also seen references that pfBlockerNG works in at least 2.4.0 sans DNSBL so that's why I'm confused why I'm getting this error.


Thanks,
Brad

Offline BBcan177

  • Moderator
  • Hero Member
  • *****
  • Posts: 2601
  • Karma: +810/-5
    • View Profile
    • Click for Support
Re: pfBlockerNG and PFSense 2.4.2
« Reply #1 on: December 21, 2017, 07:46:09 pm »
I don't think this has anything to do with pfBlockerNG....  Try to post in the "Installation/Upgrade" forum and I'm sure someone will be able to help there...

The latest version should be fine now for DNSBL and 2.4...

There is a PR which will increase the memory for PHP which seems to fix the issues for some...

This was merged today...

    https://github.com/pfsense/pfsense/pull/3881

Hope this helps!
"Experience is something you don't get until just after you need it."

 | http://pfblockerng.com | Twitter @BBcan177  | #pfBlockerNG |

Offline RonpfS

  • Hero Member
  • *****
  • Posts: 705
  • Karma: +96/-2
    • View Profile
Re: pfBlockerNG and PFSense 2.4.2
« Reply #2 on: December 21, 2017, 07:50:24 pm »
Change to "Latest development snapshots ..." save
Change to "Latest stable version ..." save
now try again with Package Manager.
2.3.5-RELEASE-p1 (amd64)
Intel Core2 Quad CPU Q8400 @ 2.66GHz 8GB
pfBlockerNG 2.1.2_2/Dev, suricata 4.0.1_1

Offline Birke

  • Jr. Member
  • **
  • Posts: 69
  • Karma: +13/-0
    • View Profile
Re: pfBlockerNG and PFSense 2.4.2
« Reply #3 on: December 22, 2017, 02:53:51 am »
i guess its because the latest stable release is not 2.4.2 but 2.4.2_1.

Offline bab5470

  • Newbie
  • *
  • Posts: 17
  • Karma: +0/-0
    • View Profile
Re: pfBlockerNG and PFSense 2.4.2
« Reply #4 on: December 22, 2017, 08:20:04 am »
Change to "Latest development snapshots ..." save
Change to "Latest stable version ..." save
now try again with Package Manager.

I tried that - it didn't help. Same error.

Offline bab5470

  • Newbie
  • *
  • Posts: 17
  • Karma: +0/-0
    • View Profile
Re: pfBlockerNG and PFSense 2.4.2
« Reply #5 on: December 22, 2017, 08:20:35 am »
i guess its because the latest stable release is not 2.4.2 but 2.4.2_1.

Sorry I guess I wasn't specific enough. I *am* running 2.4.2_1 already. So that's not the issue either.

Offline Impatient

  • Jr. Member
  • **
  • Posts: 28
  • Karma: +1/-0
    • View Profile
Re: pfBlockerNG and PFSense 2.4.2
« Reply #6 on: December 22, 2017, 02:01:06 pm »
i guess its because the latest stable release is not 2.4.2 but 2.4.2_1.

Sorry I guess I wasn't specific enough. I *am* running 2.4.2_1 already. So that's not the issue either.

If you go to the System Tab then the System Update Tab what is listed for the Current Base System and Latest Base System?