Netgate SG-1000 microFirewall

Author Topic: Upgrade from 2.3.4 to 2.3.4_1 fails (pkg-static: XXXX Not Found)  (Read 273 times)

0 Members and 1 Guest are viewing this topic.

Offline josef.masek

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Upgrade from 2.3.4 to 2.3.4_1 fails (pkg-static: XXXX Not Found)
« on: December 28, 2017, 11:34:07 am »
Update (by web  System / UpdateSystem / Update  button Confirm) fails wit output:
pkg-static: https://pkg.pfsense.org/pfSense_v2_3_4_i386-pfSense_v2_3_4/All/pfSense-Status_Monitoring-1.6.2.txz: Not Found
>>> Locking package pfSense-kernel-pfSense_wrap... done.
Failed

HW is PC ENGINES ALIX2d3.

When I try to resolve pkg.pfsense.org it seems does't exist:
masek@maseknb:~$ dig  pkg.pfsense.org

; <<>> DiG 9.10.3-P4-Ubuntu <<>> pkg.pfsense.org
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 29063
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;pkg.pfsense.org.      IN   A

;; AUTHORITY SECTION:
pfsense.org.      300   IN   SOA   ns1.netgate.com. admin.netgate.com. 201608322 3600 7200 1209600 3600

;; Query time: 371 msec
;; SERVER: 127.0.1.1#53(127.0.1.1)
;; WHEN: Thu Dec 28 18:33:29 CET 2017
;; MSG SIZE  rcvd: 101

masek@maseknb:~$ ping pkg.pfsense.org
ping: unknown host pkg.pfsense.org




All upgrade output:
>>> Updating repositories metadata...
Updating pfSense-core repository catalogue...
pfSense-core repository is up to date.
Updating pfSense repository catalogue...
pfSense repository is up to date.
All repositories are up to date.
**** WARNING ****
Duplicate slice required!!

Before starting the upgrade process, the currently mounted nanobsd partition
needs to be cloned to the secondary partition, where the update will happen

After installation a reboot will be required to switch partition.

>>> Cleaning secondary partition... done.
>>> Duplicating current slice... done.
>>> Restoring slice label... done.
>>> Testing duplicated partition integrity... done.
>>> Mounting second partition to run upgrade... done.
>>> Removing resolv.conf symlink from upgrade partition... done.
>>> Copying resolv.conf to upgrade partition... done.
>>> Downloading upgrade packages...
Updating pfSense-core repository catalogue...
pfSense-core repository is up to date.
Updating pfSense repository catalogue...
pfSense repository is up to date.
All repositories are up to date.
Checking for upgrades (102 candidates): .......... done
Processing candidates (102 candidates): ..... done
The following 48 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
   libidn2: 2.0.4 [pfSense]
   libunistring: 0.9.7 [pfSense]

Installed packages to be UPGRADED:
   php56-zlib: 5.6.30 -> 5.6.31 [pfSense]
   php56-xmlwriter: 5.6.30 -> 5.6.31 [pfSense]
   php56-xmlreader: 5.6.30 -> 5.6.31 [pfSense]
   php56-xml: 5.6.30 -> 5.6.31 [pfSense]
   php56-tokenizer: 5.6.30 -> 5.6.31 [pfSense]
   php56-sysvshm: 5.6.30 -> 5.6.31 [pfSense]
   php56-sysvsem: 5.6.30 -> 5.6.31 [pfSense]
   php56-sysvmsg: 5.6.30 -> 5.6.31 [pfSense]
   php56-sqlite3: 5.6.30 -> 5.6.31 [pfSense]
   php56-sockets: 5.6.30 -> 5.6.31 [pfSense]
   php56-simplexml: 5.6.30 -> 5.6.31 [pfSense]
   php56-shmop: 5.6.30 -> 5.6.31 [pfSense]
   php56-session: 5.6.30 -> 5.6.31 [pfSense]
   php56-readline: 5.6.30 -> 5.6.31 [pfSense]
   php56-posix: 5.6.30 -> 5.6.31 [pfSense]
   php56-pdo_sqlite: 5.6.30 -> 5.6.31 [pfSense]
   php56-pdo: 5.6.30 -> 5.6.31 [pfSense]
   php56-pcntl: 5.6.30 -> 5.6.31 [pfSense]
   php56-openssl: 5.6.30 -> 5.6.31 [pfSense]
   php56-opcache: 5.6.30 -> 5.6.31 [pfSense]
   php56-mcrypt: 5.6.30 -> 5.6.31 [pfSense]
   php56-mbstring: 5.6.30 -> 5.6.31 [pfSense]
   php56-ldap: 5.6.30 -> 5.6.31 [pfSense]
   php56-json: 5.6.30 -> 5.6.31 [pfSense]
   php56-hash: 5.6.30 -> 5.6.31 [pfSense]
   php56-gettext: 5.6.30 -> 5.6.31 [pfSense]
   php56-filter: 5.6.30 -> 5.6.31 [pfSense]
   php56-dom: 5.6.30 -> 5.6.31 [pfSense]
   php56-curl: 5.6.30 -> 5.6.31 [pfSense]
   php56-ctype: 5.6.30 -> 5.6.31 [pfSense]
   php56-bz2: 5.6.30 -> 5.6.31 [pfSense]
   php56-bcmath: 5.6.30 -> 5.6.31 [pfSense]
   php56: 5.6.30 -> 5.6.31 [pfSense]
   pfSense-rc: 2.3.4 -> 2.3.4_1 [pfSense-core]
   pfSense-kernel-pfSense_wrap: 2.3.4 -> 2.3.4_1 [pfSense-core]
   pfSense-default-config-serial: 2.3.4 -> 2.3.4_1 [pfSense-core]
   pfSense-base-nanobsd: 2.3.4 -> 2.3.4_1 [pfSense-core]
   pfSense-Status_Monitoring: 1.6.1_3 -> 1.6.2 [pfSense]
   pfSense: 2.3.4 -> 2.3.4_1 [pfSense]
   nginx: 1.10.3_1,2 -> 1.12.1,2 [pfSense]
   dnsmasq: 2.76,1 -> 2.78,1 [pfSense]
   curl: 7.54.0 -> 7.54.1 [pfSense]

Installed packages to be REINSTALLED:
   openldap-client-2.4.44 [pfSense]
   oniguruma5-5.9.6_1 [pfSense]
   libmcrypt-2.5.8_3 [pfSense]
   libltdl-2.4.6 [pfSense]

Number of packages to be installed: 2
Number of packages to be upgraded: 42
Number of packages to be reinstalled: 4

The process will require 5 MiB more space.
44 MiB to be downloaded.
[1/48] Fetching php56-zlib-5.6.31.txz: .. done
[2/48] Fetching php56-xmlwriter-5.6.31.txz: .. done
[3/48] Fetching php56-xmlreader-5.6.31.txz: .. done
[4/48] Fetching php56-xml-5.6.31.txz: ... done
[5/48] Fetching php56-tokenizer-5.6.31.txz: . done
[6/48] Fetching php56-sysvshm-5.6.31.txz: . done
[7/48] Fetching php56-sysvsem-5.6.31.txz: . done
[8/48] Fetching php56-sysvmsg-5.6.31.txz: . done
[9/48] Fetching php56-sqlite3-5.6.31.txz: .. done
[10/48] Fetching php56-sockets-5.6.31.txz: .... done
[11/48] Fetching php56-simplexml-5.6.31.txz: ... done
[12/48] Fetching php56-shmop-5.6.31.txz: . done
[13/48] Fetching php56-session-5.6.31.txz: .... done
[14/48] Fetching php56-readline-5.6.31.txz: .. done
[15/48] Fetching php56-posix-5.6.31.txz: .. done
[16/48] Fetching php56-pdo_sqlite-5.6.31.txz: .. done
[17/48] Fetching php56-pdo-5.6.31.txz: ...... done
[18/48] Fetching php56-pcntl-5.6.31.txz: .. done
[19/48] Fetching php56-openssl-5.6.31.txz: ...... done
[20/48] Fetching php56-opcache-5.6.31.txz: ........ done
[21/48] Fetching php56-mcrypt-5.6.31.txz: .. done
[22/48] Fetching php56-mbstring-5.6.31.txz: .......... done
[23/48] Fetching php56-ldap-5.6.31.txz: ... done
[24/48] Fetching php56-json-5.6.31.txz: ... done
[25/48] Fetching php56-hash-5.6.31.txz: .......... done
[26/48] Fetching php56-gettext-5.6.31.txz: . done
[27/48] Fetching php56-filter-5.6.31.txz: ... done
[28/48] Fetching php56-dom-5.6.31.txz: ....... done
[29/48] Fetching php56-curl-5.6.31.txz: .... done
[30/48] Fetching php56-ctype-5.6.31.txz: . done
[31/48] Fetching php56-bz2-5.6.31.txz: .. done
[32/48] Fetching php56-bcmath-5.6.31.txz: ... done
[33/48] Fetching php56-5.6.31.txz: .......... done
[34/48] Fetching pfSense-rc-2.3.4_1.txz: . done
[35/48] Fetching pfSense-kernel-pfSense_wrap-2.3.4_1.txz: .......... done
[36/48] Fetching pfSense-default-config-serial-2.3.4_1.txz: . done
[37/48] Fetching pfSense-base-nanobsd-2.3.4_1.txz: .......... done
pkg-static: https://pkg.pfsense.org/pfSense_v2_3_4_i386-pfSense_v2_3_4/All/pfSense-Status_Monitoring-1.6.2.txz: Not Found
>>> Locking package pfSense-kernel-pfSense_wrap... done.
Failed

Offline nattygreg

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Upgrade from 2.3.4 to 2.3.4_1 fails (pkg-static: XXXX Not Found)
« Reply #1 on: April 05, 2018, 05:21:01 pm »
I have spent the last two weeks, trying to upgrade pfsense and trying to load packages keep getting errors - reinstall pfsense a couple of times basically pulling out my hair.

Here is the fixed

login into pfsense using ssh, when the console loads choose option 8
the shell command and enter this text  pkg upgrade pkg

click enter after it finishes

choose option 13 from the same console after that you can install any package that you wish.
the package manager is broken in 2.4.2 , 2.4.2_1 and 2.4.3

Offline jahonix

  • Hero Member
  • *****
  • Posts: 2613
  • Karma: +156/-27
  • volunteer since 2006
    • View Profile
Re: Upgrade from 2.3.4 to 2.3.4_1 fails (pkg-static: XXXX Not Found)
« Reply #2 on: April 05, 2018, 07:38:44 pm »
the package manager is broken in 2.4.2 , 2.4.2_1 and 2.4.3
Irrelevant to know, he's using 2.3.4 on an ALIX board which cannot run 64-bit software at all.
Chris